VirtualBox

Ticket #5250 (closed defect: duplicate)

Opened 5 years ago

Last modified 4 years ago

VB crashes when logging into windows 2003 server -> duplicate of #4987

Reported by: KeyzerSuze Owned by:
Priority: major Component: guest additions
Version: VirtualBox 3.0.8 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

Hi

I have ii virtualbox-3.0 3.0.8-53138_Debian_lenny Sun VirtualBox

running on a deb amd64 server

Linux bblx02 2.6.30-2-amd64 #1 SMP Fri Sep 25 22:16:56 UTC 2009 x86_64 GNU/Linux

The problem happens run xvncserver on the machine and and from a remote machine I connect to it from another machine, I then run VirtualBox, which starts up the windows 2003 server. this works okay, when I login it starts to work, but then the whole thing crashes

I get this is dmesg

VirtualBox[9824]: segfault at 20 ip 00007fdb3d47e563 sp 00007fdb362c8ed0 error 4 in libXt.so.6.0.0[7fdb3d450000+5e000]

my hunch is, that it is an interaction between the guest additions and the fact that VirtualBox is running in a vncserver X. I previously had a 2.1.x version of GA and then installed the 3.0.8 version - same problem

when I run it headless it works okay, I can rdesktop and login - no problems.

there is nothing logged in the VBox log

Alex

Change History

comment:1 Changed 5 years ago by Fulike

I have the same issue: host Ubuntu 8.04 64 bit - Virtualbox 3.0.6 and 3.0.8 guest: Windows 2003

In Virtualbox <3.0.4 the Windows 2003 works fine.

comment:2 Changed 5 years ago by sandervl73

A core dump would be very useful in this case.

comment:3 Changed 5 years ago by frank

If you can provide a core dump, please contact me via private E-mail at frank _dot_ mehnert _at_ sun _dot_ com. Thank you!

comment:4 Changed 4 years ago by frank

Fulike, your problem is apparently clipboard-related. Are you able to login if you disable the clipboard in the VM settings?

comment:5 Changed 4 years ago by Fulike

If I disable the clipboard, the Windows 2003 guest works fine.

comment:6 Changed 4 years ago by michael

  • Status changed from new to closed
  • Resolution set to duplicate
  • Summary changed from VB crashes when logging into windows 2003 server to VB crashes when logging into windows 2003 server -> duplicate of #4987

Thanks for the core dump. This looks like a duplicate of ticket #4987, so I will close it. I hope that I have fixed this in 3.0.10 though, so please give that a go when it becomes available. If not, you might want to say so on #4987.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use