VirtualBox

Ticket #5249 (closed defect: duplicate)

Opened 4 years ago

Last modified 4 years ago

USB devices inaccessible because /dev/bus/usb no write permissions for group vboxusers -> duplicate of #3394

Reported by: schlomo Owned by:
Priority: critical Component: USB
Version: VirtualBox 3.0.8 Keywords: udev permissions unavailable
Cc: Guest type: other
Host type: Linux

Description

Issue
USB devices are visible but greyed out (Status: Unavailable)

Cause
The files in /dev/bus/usb have no write permission for the vboxusers group because the mode is 644 and not 664.

In /etc/udev/rules.d/10-vboxdrv.rules there is a rule setting the MODE to 0644, but this is overridden by /lib/udev/rules.d/50-udev-default.rules which sets the MODE to 0644.

Solution
The solution is to write the rule in /etc/udev/rules.d/10-vboxdrv.rules like this: SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", GROUP="vboxusers", MODE:="0664"

Note the final assignment with := instead of =

Observed on openSUSE 11.1 i586

Change History

comment:1 Changed 4 years ago by michael

  • Summary changed from USB devices inaccessible because /dev/bus/usb no write permissions for group vboxusers to USB devices inaccessible because /dev/bus/usb no write permissions for group vboxusers -> duplicate of #3394

This is one of the issues discussed in ticket #3394, so I am marking this one as a duplicate. This is an (Open?)SUSE 11-only issue which is "fixed" (you could also read that as "worked around on their side") in OpenSUSE 12. It would be great though if you could tell us exactly what the line in 50-udev-default.rules is (either on this ticket or on #3394) which changes permissions, so that we could check for it in our installer script and apply a workaround automatically if it is found.

comment:2 Changed 4 years ago by michael

  • Status changed from new to closed
  • Resolution set to duplicate

comment:3 Changed 4 years ago by schlomo

  • Status changed from closed to reopened
  • Resolution duplicate deleted

I would suggest changing the /etc/udev/rules.d/10-vboxdrv.rules file which is distributed by VirtualBox instead of patching a file distributed by openSUSE. What would be the harm of my suggested change? AFAKT none whatsovever.

I would therefore suggest to fix the /etc/udev/rules.d/10-vboxdrv.rules file for the next VirtualBox (sub)release.

comment:4 Changed 4 years ago by michael

  • Status changed from reopened to closed
  • Resolution set to duplicate

Sorry, closing this again, as it is still a duplicate. And please, I never suggested patching a file distributed by SUSE - all changes are confined to 10-vboxdrv.rules (including the suggestions in #3394 about renaming that file).

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use