VirtualBox

Ticket #4987 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Segmentation fault after logging in to Windows 7 x86 (Clipboard) -> probably fixed in 3.0.10

Reported by: avs Owned by:
Priority: major Component: guest additions
Version: VirtualBox 3.0.6 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

VM is aborted after a user is logged in. No crash if the guest additions 3.0.6 is uninstalled. Everything works in 2.1.4

Host: An OpenVZ container on Linux vessel 2.6.26-2-openvz-amd64 #1 SMP Wed Aug 19 23:15:49 UTC 2009 x86_64 GNU/Linux

Guest: Windows 7 x86

Attachments

VBox.log Download (39.0 KB) - added by avs 5 years ago.
VBox.2.log Download (33.2 KB) - added by avs 5 years ago.

Change History

Changed 5 years ago by avs

comment:1 Changed 5 years ago by avs

I do have a core dump (~200MB gzipped)

comment:2 Changed 5 years ago by avs

VBox also crashes if the guest is Windows XP x86

comment:3 Changed 5 years ago by avs

I'm able to reproduce the issue on another computer, where openvz is not installed. The issue appears if I connect to the computer through vnc.

comment:4 Changed 5 years ago by avs

Frank, I've got a core dump using your pre-compiled binaries virtualbox-bin-3.0.6 Attaching new VBox.log.

Changed 5 years ago by avs

comment:5 follow-up: ↓ 6 Changed 5 years ago by Steltek

I have the same problem starting with Virtualbox 3.0.6 with my Windows XP guests. My VBox.log file stops with the same lines as the first one above:

00:01:22.751 Starting host clipboard service

00:01:22.751 Initializing X11 clipboard backend

00:01:22.754 ClipStopX11: stopping the shared clipboard X11 backend

comment:6 in reply to: ↑ 5 Changed 5 years ago by Steltek

Sorry forgot some additional information: Debian unstable, 2.6.30-1-686-bigmem #1 SMP Mon Aug 3 17:32:39 UTC 2009 i686 GNU/Linux. "Intel(R) Xeon(R) CPU 3050 @ 2.13GHz"

comment:7 Changed 5 years ago by mklight

I have also seen this problem with Virtualbox 3.0.6 and 3.0.8 with my Windows XP guest when running VirtualBox inside of a VNC session. My Vbox.log file also ends with 00:14:02.707 ClipStopX11: stopping the shared clipboard X11 backend Removing Guest additions or not running inside of VNC resolves the problem.

comment:8 Changed 5 years ago by Steltek

I never tried running outside of VNC but I can confirm that removing the Guest additions or disabling the Clipboard sharing works around the issue for me.

comment:9 Changed 5 years ago by frank

  • Summary changed from Segmentation fault after logging in to Windows 7 x86 to Segmentation fault after logging in to Windows 7 x86 (Clipboard)

comment:10 follow-up: ↓ 12 Changed 5 years ago by michael

Sorry, I noticed this ticket a little late. Would one of the people experiencing this issue be able to get a core dump of the crash please? (avs, do you still have yours?)

comment:11 Changed 5 years ago by michael

See  http://www.virtualbox.org/wiki/Core_dump for instructions on how to generate a core dump.

comment:12 in reply to: ↑ 10 Changed 5 years ago by avs

Replying to michael:

Sorry, I noticed this ticket a little late. Would one of the people experiencing this issue be able to get a core dump of the crash please? (avs, do you still have yours?)

I do, it's about 300Mb compressed. Where should I upload it to?

comment:13 Changed 5 years ago by michael

Sent private mail with an upload link.

comment:14 Changed 5 years ago by avs

Uploaded.

comment:15 Changed 5 years ago by Steltek

I also got a core dump from one of my systems (XP guest, Debian host).

61M when compressed with bzip2. Where can I send that to?

comment:16 follow-up: ↓ 17 Changed 5 years ago by michael

Steltek: sorry for the delay in answering (lots of other things in parallel). If you still have your core dump, I will send you a private mail telling you where to upload it, otherwise I avs's dump should hopefully do the trick.

comment:17 in reply to: ↑ 16 Changed 5 years ago by Steltek

Replying to michael:

Steltek: sorry for the delay in answering (lots of other things in parallel). If you still have your core dump, I will send you a private mail telling you where to upload it, otherwise I avs's dump should hopefully do the trick.

I still have it. You can either PM me on the community forums or mail me at vboxcoredump@…

comment:18 Changed 4 years ago by michael

  • Summary changed from Segmentation fault after logging in to Windows 7 x86 (Clipboard) to Segmentation fault after logging in to Windows 7 x86 (Clipboard) -> probably fixed in 3.0.10

I think that I have fixed this in 3.0.10. It would be great if you could give that a try when it becomes available. Note that the problem was that the clipboard initialisation on the host was failing, and that we were not handling that correctly. Ergo, the clipboard will almost certainly not work for you. I have added additional logging to see why the initialisation is failing.

comment:19 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

comment:20 Changed 4 years ago by Steltek

The segmentation fault is indeed fixed and yes, clipboard shared doesn't work. Initialisation fails with this:

00:01:26.974 Guest Log: VBoxTray: Started. 00:01:27.068 Starting host clipboard service 00:01:27.068 Initializing X11 clipboard backend 00:01:27.069 Shared clipboard: failed to load the XFIXES extension. 00:01:27.069 Shared clipboard: failed to setup the termination mechanism. 00:01:27.069 Shared clipboard: initialisation failed: VERR_NOT_SUPPORTED 00:01:27.069 Failed to initialise the shared clipboard 00:01:27.113 Guest Additions capability report: (0x5) seamless: yes, hostWindowMapping: no, graphics: yes 00:02:22.829 Guest Log: VBOXNP: DLL loaded.

Do we need to open a new ticket for that?

comment:21 Changed 4 years ago by avs

Upgrading to 3.0.10 fixed the segmentation fault. Thanks.

comment:22 Changed 4 years ago by michael

Steltek: don't know if it is worth creating a new ticket, unless this annoys the other subscribers to this one. Actually I suspected that the problem was that your X server doesn't support XFIXES, and we made that a requirement sometime in the 3.0 series as without it, the clipboard code needed some rather ugly and fragile workarounds. What sort of X server are you using? Presumably not a recent X.Org.

comment:23 Changed 4 years ago by Steltek

I'm actually running VirtualBox from within vnc4server (Debian package version 4.1.1+X4.3.0-32). I'll have to check and see if I can somehow get XFIXES loaded in there.

comment:24 Changed 4 years ago by michael

Some quick googling says that it supports XFIXES, and that you just need to add the parameters "-extension XFIXES" to the command line.

comment:25 Changed 4 years ago by Steltek

I read the same thing, however it doesn't work. The VNC server log output shows this:


Unrecognized option: -extension use: X [:<display>] [option] -a # mouse acceleration (pixels) -ac disable access control restrictions [...] Copyright (C) 2002-2005 RealVNC Ltd. See  http://www.realvnc.com for information on VNC. Underlying X server release 40300000, The XFree86 Project, Inc


So I guess the Debian version of vnc4server does not support that (or it needs to be enabled differently somehow).

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use