VirtualBox

Ticket #5235 (closed defect: worksforme)

Opened 5 years ago

Last modified 5 years ago

VirtualBox 3.0.8 won't install on RedHat 5.4

Reported by: robertr64 Owned by:
Priority: major Component: other
Version: VirtualBox 3.0.8 Keywords:
Cc: rjrodrig@… Guest type: other
Host type: Linux

Description (last modified by frank) (diff)

i used to be able to install and use VirtualBox with either the RedHat 4 build rpm or the .run file. Now, since trying to upgrade to 3.0.8, I get an error from RPM or YUM:

[root@notready ~]# yum install VirtualBox
Loaded plugins: changelog, downloadonly, ibm-additional-metadata, ibm-cds-
              : plugin, ibm-house-cleaning, ibm-repository, ibm-security, ibm-
              : upgrade-oc, security
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package VirtualBox.i386 0:3.0.8_53138_rhel4-1 set to be updated
--> Processing Dependency: libpython2.3.so.1.0 for package: VirtualBox
--> Finished Dependency Resolution
VirtualBox-3.0.8_53138_rhel4-1.i386 from virtualbox has depsolving problems
  --> Missing Dependency: libpython2.3.so.1.0 is needed by package VirtualBox-3.0.8_53138_rhel4-1.i386 (virtualbox)
Error: Missing Dependency: libpython2.3.so.1.0 is needed by package VirtualBox-3.0.8_53138_rhel4-1.i386 (virtualbox)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
[root@notready ~]# 

I can't find libphthon2 in our standard RedHat 5 repositories via YUM, but we do have python installed.

When using the .run file instead of the rpm, I get a message that the X86 environment is unsupported.

Change History

comment:1 Changed 5 years ago by frank

  • Description modified (diff)

If this is RedHat 5.4, why are you try to install the rhel4 package and not the rhel5 package?

Regarding the error message when you try to install the .run package: In that case you tried to install the wrong package. Use the x86 .run package if your host is 32-bit, use the amd64 .run package if your host is 64 bit.

comment:2 Changed 5 years ago by robertr64

I don't see any Redhat 5 package on the web site or on YUM, that's why I had the R4 one. It used to work ok with VrtiualBox 3.0.6. The .run file I'm getting errors on is the 32-bit version.

comment:3 Changed 5 years ago by frank

What about this page? Search for RHEL5. And is your host 32-bit or 64-bit?

comment:4 Changed 5 years ago by robertr64

That's where I looked; still only showing RedHat 3 and 4. The host is 32-bit Linux and the run file worked previously with 3.0.6.

comment:5 Changed 5 years ago by frank

I'm sorry? There is NO package for RedHat 3 but there are only packages for RedHat/CentOS 4 and RedHat/CentOS 5!

And I still doubt that the 32-bit .run installer does not work on your system. Did you really try to install VirtualBox-3.0.8-53138-Linux_x86.run?

comment:6 Changed 5 years ago by robertr64

Looks ok now via YUM with RHEL5, was not finding it earlier.

comment:7 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use