VirtualBox

Ticket #4969 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

Linux 64bit guest on Windows 32bit host hangs on boot with 100% CPU

Reported by: andylong Owned by:
Priority: blocker Component: other
Version: VirtualBox 3.0.6 Keywords: guest boot freeze write protecting
Cc: Guest type: Linux
Host type: Windows

Description

My host machine is a Windows Vista Home Premium 32bit installation on a 64bit (Core2 Duo P8600 - with VT extensions) machine. My guest install is a Debian Linux 2.6.30-1 amd64 install (standard Debian kernel) but this bug can also be reproduced with a fresh new VM and the Ubuntu 9.04 Live CD for amd64.

Halfway through the guest kernel boot, specifically after this line: " Write protecting the kernel read-only data: 6708k " the guest machine freezes and keeps one of my host CPU's two cores at 100%. This never happened with 3.0.4; instead I have never managed to boot the guest since updating to 3.0.6.

I tried disabling all extensions and all the guest's peripherals I could disable, but everything was useless. Of course I could not disable using the CPU's virtualization extensions because they are necessary to run a 64bit guest on a 32bit host OS.

I have already confirmed that the amd64 architecture explicitly supports intel's x86-64.

Attached is the logfile for my test boot with the mentioned Ubuntu Live CD.

Attachments

VBox.log Download (52.6 KB) - added by andylong 5 years ago.
Logfile for test boot with Ubuntu 9.04 amd64 Live CD iso

Change History

Changed 5 years ago by andylong

Logfile for test boot with Ubuntu 9.04 amd64 Live CD iso

comment:1 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #4947.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use