VirtualBox

Ticket #4947 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

64-bit guests will not boot on WinXP 32-bit host (VT-x only) -> fixed in SVN/3.0.8

Reported by: rasta Owned by:
Priority: critical Component: other
Version: VirtualBox 3.0.6 Keywords:
Cc: Guest type: Solaris
Host type: Windows

Description

HOST:

WinXPsp3 32-bit with VT (dual quad-core Intel Xeon E5345 processors) 4 GB RAM NVIDIA Quadro FX 3500 video card, 256 MB VRAM VBox 3.0.6

GUEST:

Solaris 10 u7, 1500 MB RAM assigned to guest, 128 MB VRAM, guest additions installed IOAPIC, ACPI, PAE, VT-x enabled

32-bit guest boots fine, NAT dropped packet problem (#4343) resolved. Network/internet connectivity good.

64-bit guest will not boot. Several USB controller errors come up, and then a page fault and return to GRUB.

Log attached.

Attachments

Solaris 10 u7-2009-09-10-14-30-48_RASTA.log Download (89.0 KB) - added by rasta 5 years ago.
Vbox log of 64-bit Solaris guest that will not boot
VBox.log Download (52.7 KB) - added by andylong 5 years ago.
Log of failed boot with Linux 2.6.30 guest
VBox.2.log Download (42.6 KB) - added by gibraltar 5 years ago.
VB 3.0.7 crash log

Change History

Changed 5 years ago by rasta

Vbox log of 64-bit Solaris guest that will not boot

comment:1 Changed 5 years ago by zephyrus

METOO. "Solaris 10 u7 64-bit guest will not boot on WinXP 32-bit host"

Exactly the same. The guest Solaris 64 bit version was pre-installed using the previous version of VirtualBox. During the boot, USB error is shown a few times. This EHCI controller is not usable. Then fatal kernel swap error and the boot failed.

Failsafe entry boots up fine. It can mount the partition of the main solaris, which failed to boot, and can run fsck, which showed no problem.

Linux 32 bit guest (Debian Gnu/linux) ran despite the fact that it was put into sleep before the upgrade, and that the Guest tool iso image is no longer found, and so Vbox refused to continue initially. (I will post another bug entry about this.)

Not being able to boot 64 bit solaris is a total failure.

comment:2 Changed 5 years ago by rasta

Obviously, 64-bit Solaris guests were bootable on 32-bit WinXP hosts using previous Vbox versions, but the guests were very unstable.

I started a forum thread about this problem:

 http://forums.virtualbox.org/viewtopic.php?f=20&t=22217

comment:3 Changed 5 years ago by zephyrus

I forgot to mention. (comment #2) I use AMD athlong dual core 5050E. So it is likely that the problem is CPU-independent (#1 is a problem on Intel CPU.)

Right, I reverted to 3.0.2. As #3 mentioned, solaris10 64bit was a little unstable. (Hung during the bulk patching after a fresh install (on this AMD PC), hung after a few hours [just sitting there without any interactive input] (on a different Intel Dual CPU PC), etc. That is why I jumped on the new upgrade hoping for a stabler operation...)

comment:4 Changed 5 years ago by ghchinoy

I have the same/similar issue: Win2008R2 (x64) client on WinXP/Vista(x32) host worked great in 3.0.4, now the vm won't boot. CPU Intel T7600. Reverting to 3.0.4

comment:5 Changed 5 years ago by Papo06

Same problem on Window XP pro 32 bits host running Debian Etch 64 bits guest (amd64 arch) linux kernel 2.6.24 with 512Mo ram, host cpu core 2 duo / 2gb ram, i go back to 3.0.2 (i had mouse/keyboards issues in 3.0.4)

comment:6 Changed 5 years ago by frank

  • Priority changed from major to critical
  • Summary changed from Solaris 10 u7 64-bit guest will not boot on WinXP 32-bit host to 64-bit guests will not boot on WinXP 32-bit host

Changed 5 years ago by andylong

Log of failed boot with Linux 2.6.30 guest

comment:7 Changed 5 years ago by andylong

Confirmed with Linux 2.6.30-amd64 guest - VirtualBox 3.0.6 on Windows Vista 32bit host - on a x86-64 Intel Core2 Duo P8600 machine with native VT extensions.

Guest boot freezes with 100% host CPU after the line Write protecting the kernel read-only data: 6708k. I never had guest stability problems with this setup, until now.

comment:8 Changed 5 years ago by sandervl73

Investigating. I can reproduce the problem with OpenSolaris x64.

Anybody here not using a Windows host?

comment:9 Changed 5 years ago by TeutonJon78

I have the 64-bit guests not working on 32-bit host, but I'm using Windows Vista SP2.

In the thread on the forum I started about the issue before the bug postings, someone did reply that they had the same problem on a 32-bit Ubuntu host as well, so it seems to just be any 64-bit guest on a 32-bit host.

 http://forums.virtualbox.org/viewtopic.php?f=3&t=22224&start=0

comment:10 Changed 5 years ago by sandervl73

  • Summary changed from 64-bit guests will not boot on WinXP 32-bit host to 64-bit guests will not boot on WinXP 32-bit host -> fixed in SVN/3.0.8

zephyrus: your problem is unrelated. There's a VT-x regression in 3.0.6 for 64 bits guests on 32 bits hosts. Found and fixed. Please create another defect and attach a VBox.log of such a session there.

comment:11 Changed 5 years ago by sandervl73

  • Summary changed from 64-bit guests will not boot on WinXP 32-bit host -> fixed in SVN/3.0.8 to 64-bit guests will not boot on WinXP 32-bit host (VT-x only) -> fixed in SVN/3.0.8

comment:12 Changed 5 years ago by frank

A test build for Windows hosts with the proper bugfix included can be found  here.

comment:13 Changed 5 years ago by andylong

I can't check for regressions, but my Linux VM boots correctly with the test build here (for host & guest specs, see comment above). So it looks like the problem has been fixed. By the way, if it is any useful, I'd like to point out that the bug is not on WinXP systems only: I had it on Vista.

comment:14 Changed 5 years ago by phil

I just downloaded and installed the test build (deleted 3.0.6 and rebooted first), and I can confirm that it seems to have solved the problem, at least on my computer (which is running 32-bit Windows XP SP3 on an Intel Core i7 with VT-x enabled). All of my 64-bit guests are now working again (Windows 7 RC and two OpenSUSE 11.1 guests). All of my 32-bit guests continue to work as well (Windows XP and two Windows 2000 guests). I didn't test extensively, but I didn't encounter any problems with any of my virtual machines. A big thank you to the developers for fixing this problem.

comment:15 follow-up: ↓ 16 Changed 5 years ago by gibraltar

Hmm, sorry to report, but my setup continues to crash with the test version. Windows 7 Ultimate x64 host with Windows SBS 2008 x64 guest still crash with random BSOD.

I've attached a log file to the ticket, hope some one can help.

thanks.

Changed 5 years ago by gibraltar

VB 3.0.7 crash log

comment:16 in reply to: ↑ 15 Changed 5 years ago by gibraltar

Sorry, forgot to mention that the crash only happens with 2 cores enabled on the guest, If I only enable one core the guest boots fine.

comment:17 Changed 5 years ago by sandervl73

gibraltar: that's a different issue. there are numerous tickets open for SMP problems.

comment:18 Changed 5 years ago by hemathor

the same here since i've updated to virtualbox 3.0.6 (latest version from repository).

host: openSUSE 11.0 32bit guest: any 64bit, e.g. openSUSE 11.1 64bit

comment:19 Changed 5 years ago by hmichel

the same here since i've updated to virtualbox 3.0.6 (latest version from repository).

host: Ubuntu 9.04 32bit guest: Ubuntu 9.04 server 64bit

comment:20 Changed 5 years ago by xNuno

Hi! When I try to download 3.08 get page not found can you give me the link please?

comment:21 Changed 5 years ago by frank

3.0.8 is not released yet, patience please.

comment:22 Changed 5 years ago by xNuno

Can I register for Beta?

comment:23 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use