VirtualBox

Ticket #4935 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Virtualbox on Netbook (small form factor Notebook), display resolution and colors

Reported by: zoltanf Owned by:
Priority: major Component: guest additions
Version: VirtualBox 3.0.6 Keywords: display resolution colors netbook
Cc: Guest type: Windows
Host type: Windows

Description

I'm trying to use VirtualBox on my netbook PC.

This PC has limited display resolution, as it is a small 10" LCD screen. The resoult is: 1024 x 576.

The Virtualbox is working fine, except for the display. The guest addons are installed, but the color displayed is in 4 bit. The guest window resizing is not working, the seamless mode is not working. The guest resolution is fixed to 800x600.

The guest in question is Windows XP SP3, but it is probably same for all the windows guests. I have find this similar issue opened here #4194.

Virtualbox version is 3.0.4.

Attachments

0-412663b7807f6e5d.png Download (41.4 KB) - added by zoltanf 5 years ago.
Screenshot
VBox.log Download (50.2 KB) - added by zoltanf 5 years ago.
Log file

Change History

Changed 5 years ago by zoltanf

Screenshot

comment:1 Changed 5 years ago by zoltanf

It happens also on 3.0.6.

Is nobody interested in resolving this issue? This is a showstopper for using VB on small netbook PCs (and they are powerful enough to run a VB and guest machines...)

comment:2 Changed 5 years ago by sandervl73

  • Version changed from VirtualBox 3.0.4 to VirtualBox 3.0.6

VBox.log of such a session please.

Changed 5 years ago by zoltanf

Log file

comment:3 Changed 5 years ago by zoltanf

All the other functions of the VB guest addons (e.g. shared folders, mouse integration, etc) are working fine.

Seems to me that the problem is in handling the minimal supported resolution on the host. Even if the resolution on the host is smaller than 1024x768, or 800x600, the guest should still display fine, since you can give it a smaller resolution or give it a standard SVGA resolution and keep the guest window hosts resolution an show the scroll bars so that the user can scroll the guest around too see all the bits.

Hope this helps...

comment:4 Changed 5 years ago by michael

Not reproducible here (host and guest XP SP2, Guest with Additions installed, host graphics set to 800x600x32bit).

comment:5 Changed 5 years ago by zoltanf

Please note, I think the trick is that the vertical resolution of the host is bellow 600, in my case 576 px.

Anyway, yesturday I was playing with windows resizing, seemless mode and full screen (this i did after instaling the 3.0.6 addons) and eventualy, after couple of minutes, the guest resized the desktop and now everything works just fine. I don't understand how it happened, but it did. I tried replicating the resoult again on one of my other guest VMs, and I done it. After installation of the 3.0.6. addons, couple of guest window resizes, and the guest resolution becomes dynamic with the window, and the colors rase from 4bit to 32bit. I will attach a screenshot of this latter today.

comment:6 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

comment:7 Changed 4 years ago by frank

Should be fixed in VBox 3.0.10.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use