VirtualBox

Ticket #4934 (reopened defect)

Opened 5 years ago

Last modified 4 years ago

Cannot start VM bridged to a VLANs when another VM bridged to another VLAN is already running

Reported by: avok00 Owned by:
Priority: major Component: network
Version: VirtualBox 3.0.4 Keywords: VLAN, VERR_INTNET_INCOMPATIBLE_TRUNK
Cc: 2.2.4 - 3.06 B1 Guest type: other
Host type: Windows

Description

Cannot start VM bridged to a VLANs when another VM bridged to another VLAN is already running.

Windows Vista Business 64bit host SP2

I have 3 VLANs on an Intel PRO/1000 MT Desktop Adapter lan card. I have installed the Intel Proset drivers for the NIC v14.3 They enable me to have each VLAN with its own virtual NIC in the form of for example: Intel(R) PRO/1000 MT Desktop Adapter - VLAN : VLAN2018 (The only way to use VLAN in Windows I know of) If I start a virtual machine bridged to one of the Virtual VLAN NICs it is OK, everything is working I can also start more virtual machines bridged to the same Virtual VLAN NIC But the problem is when I try to start a virtual machine bridged to a different Virtual VLAN NIC,

while those VMs bridged to first Virtual VLAN NIC are still running.

I get a crash with message: VERR_INTNET_INCOMPATIBLE_TRUNK

I tried Virtual Box version 2.2.4-47978 and also latest beta 3.0.6_BETA1-51790 still the same The only difference is that 2.2.4 locks up hard after a couple of VLAN crashes and I need to reboot my host.

For example: start VM1 bridged to VLAN1 - OK start VM2 bridged to VLAN1 - OK start VM3 bridged to VLAN2 - CRASH!!!

Other example: start VM1 bridged to VLAN1 - OK start VM2 bridged to VLAN1 - OK stop VM1 and VM2 start VM3 bridged to VLAN2 - OK

Attachments

RadostinYal LX Ubuntu 32-2009-09-08-23-57-18.log Download (30.0 KB) - added by avok00 5 years ago.
One of the guests that fail. I have windowses that also fail
pfSense_hoved-2010-02-18-02-48-32.log Download (29.8 KB) - added by snorre 4 years ago.
VBox.log Download (33.3 KB) - added by jbrouault 4 years ago.
VirtualBox 3.1.6 error on gentoo x86_64
virtualbox318-w7-64b-intel82567LM.log Download (32.8 KB) - added by schiegl 4 years ago.
VirtualBox 3.18 logfile

Change History

Changed 5 years ago by avok00

One of the guests that fail. I have windowses that also fail

comment:1 Changed 5 years ago by avok00

This is caused by bug when comparing the network adapter names, for more details, see -  http://forums.virtualbox.org/viewtopic.php?f=6&t=15238&p=97841

Please, fix that, it is important!

comment:2 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Should be fixed. Please check 3.0.12 or 3.1.0.

Changed 4 years ago by snorre

comment:3 Changed 4 years ago by snorre

  • Status changed from closed to reopened
  • Resolution fixed deleted

I have this issue in 3.1.4 on Debian squeeze amd64. see attachment

Changed 4 years ago by jbrouault

VirtualBox 3.1.6 error on gentoo x86_64

comment:4 Changed 4 years ago by jbrouault

I am experiencing the same issue with version 1.6.0 under Gentoo amd64, see attached log attachment:VBox.log Download

I tried with Ubuntu x86 and amd64 and could reproduce the bug only with the amd64 system.
This bug seems to happen when host interfaces names contains at least 14 characters, and all characters except the 13th are similar.

For example in the attached log the interfaces are named aaabbbccceeeff and aaabbbccceeegf and the guest machine doesn't start.
If the interfaces are named aaabbbccceeeff and aaabbbccceeefg it starts fine.

Changed 4 years ago by schiegl

VirtualBox 3.18 logfile

comment:5 Changed 4 years ago by schiegl

I'm experiencing the same bug with

  • VirtualBox 3.18
  • Windows 7 64bit
  • Intel 82567LM with two VLANs (100 & 110)

see log: attachment:virtualbox318-w7-64b-intel82567LM.log Download

The interfaces are (automatically) named
"Intel(R) 82567LM-3 Gigabit Network Connection - VLAN : 100" and
"Intel(R) 82567LM-3 Gigabit Network Connection - VLAN : 110". I'm able to start VM's configured with interfaces assigned to same VLAN only.
Adding a second virtual-NIC from the other VLAN - doesn't matter if it's 100 or 110 - fails with the dreaded "VERR_INTNET_INCOMPATIBLE_TRUNK" message.
I didn't want to hack the registry (see forum link), but bought a USB-Ethernet-Adapter for the time until this one's fixed...

comment:6 Changed 4 years ago by schiegl

upgraded to 3.2, same issue... (okay not surprising as the changelog didn't mention a fix)

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use