VirtualBox

Ticket #4870 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Guest loses networking on high traffic load => Fixed in SVN/3.0.8

Reported by: evil Owned by:
Priority: major Component: network/NAT
Version: VirtualBox 3.1.6 Keywords: network load
Cc: Guest type: other
Host type: other

Description

I think this is an old issue apparently never addressed (Ticket #1256 (new defect)), because I am experiencing it in release 3.0.4.

Ubuntu 9.04 host. When one VM (Ubuntu 9.04) has high traffic load on an internal network with another Ubuntu 9.04 guest, it just silently loses connectivity, and only a VM reboot "could" help, but sometimes it must be shut down completely. I am using the default adapter type.

Attachments

VBox.log Download (34.7 KB) - added by evil 5 years ago.
VBox.log.1 Download (55.4 KB) - added by Matt Harrison 4 years ago.
This is the log file of the last run session that lost network (in shutdown state).
VBox.2.log Download (39.3 KB) - added by Matt Harrison 4 years ago.
This log file is the machine currently running but with a dead NAT currently.

Change History

Changed 5 years ago by evil

comment:1 Changed 5 years ago by firefly

I can confirm this as well on OpenSuse 11.1 64 Bit host. I am using bridge mode.

comment:2 Changed 5 years ago by frank

Hmm, evil, why are you using the same intnet for both network cards of the VM?

comment:3 Changed 5 years ago by evil

What do you mean? The configuration is:

src eth1 (192.168.1.10) <-> netem eth1 (192.168.1.1) netem eth2 (192.168.2.1) <-> dest eth1 (192.168.2.20)

so there are 2 internal networks (src_side and dest_side)

each of them has a NATted eth0 down and disconnected

comment:4 Changed 5 years ago by frank

Sorry, my fault. Misread the VBox.log file. Actually the names of the two internal networks are send and receive.

How long does it take until the VM looses the connection?

comment:5 Changed 5 years ago by evil

What I am doing is transfer videos. From destination I do: ssh user@192.168.1.10 "mp4trace -f -s 192.168.2.20 12346 video.mp4"

mp4trace is included in evalvid software. it packetize a video and sends it to the destination.

I do it in a cycle with 5 short videos. Sometimes it loses network on the first, sometimes on another, sometimes it gets to the end, no precise spot. The only thing that I suspect, is that it happens more likely if I am doing something stressful on the host, using CPU. But it's just a feeling

comment:6 Changed 5 years ago by evil

Situation update: I found out an error on netem2 which affected sometimes netem eth2 (192.168.2.1). Cleaning netem rules there restored the network without reboot. Anyway such problem should have been fixed.

So I am back to virtualbox "blame" :) I kept testing and now the network was lost between src eth1 (192.168.1.10) <-> netem eth1 (192.168.1.1), both virtual devices without a netem rule set, ever. And I restored the network turning off/on src machine, which never had any netem rule set.

Cannot figure out any reasonable explanation.

comment:7 Changed 5 years ago by frank

Just fixed a potential hang of the PCNet emulation in rare cases. E1000 is not affected AFAICS.

comment:8 Changed 5 years ago by evil

Apparently it should be solved cause I didn't experience any hang so far with the new package.

I'd like to add as a further information that the same problem was happening also on vmware, but there it was detected as too many I/O requests and it turned the file system into read-only, which was extrmely annoying, way more than the disappearing network.

comment:9 Changed 5 years ago by frank

  • Summary changed from Guest loses networking on high traffic load to Guest loses networking on high traffic load => Fixed in SVN/3.0.8

Thanks for the feedback.

comment:10 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

comment:11 Changed 5 years ago by henrik242

  • Status changed from closed to reopened
  • Resolution fixed deleted

I experience this issue as well, and it hasn't changed in v3.0.8. E1000 is also affected.

comment:12 Changed 5 years ago by henrik242

Sorry, I forgot a couple of details. This is a Mac OSX 10.6 host with a Debian testing guest (kernel 2.6.30-1). I use two network interfaces: one NAT and one Host-only adapter. The NAT interface works great all the time. The host-only interface, however, usually works as it should for a while after boot, then it becomes extremely slow and/or unresponsive.

comment:14 in reply to: ↑ 13 Changed 5 years ago by Hachiman

  • Component changed from network to network/NAT

Replying to henrik242:

The problem is discussed here as well:  http://forum.virtualbox.org/viewtopic.php?f=6&t=19457&start=30&sid=d2fa7b3d50bc97a49f596a0df94743ce

This bug was initially filled against NAT, so could you please open new one against host-only + log files?

comment:15 Changed 5 years ago by henrik242

Hachiman: Sure, it's submitted as ticket #5254

comment:16 Changed 4 years ago by Hachiman

  • Status changed from reopened to closed
  • Resolution set to fixed

comment:17 follow-up: ↓ 18 Changed 4 years ago by Matt Harrison

  • Status changed from closed to reopened
  • Resolution fixed deleted

I seem to be having this same issue. Ubuntu 9.10 64-bit Host (2.6.31-20 kernal) Windows XP SP3 32-bit Guest VirtualBox 3.1.6 r59338

Network Adapter: PCnet-FAST III (NAT)

When I get high traffic load on the guest the network just dies (windows still shows it as connected, but nothing will go through) The only solution is to shutdown and restart the Guest. Trying to repair network in windows does nothing.

Changed 4 years ago by Matt Harrison

This is the log file of the last run session that lost network (in shutdown state).

Changed 4 years ago by Matt Harrison

This log file is the machine currently running but with a dead NAT currently.

comment:18 in reply to: ↑ 17 Changed 4 years ago by Hachiman

Replying to Matt Harrison:

When I get high traffic load on the guest the network just dies (windows still shows it as connected, but nothing will go through) The only solution is to shutdown and restart the Guest. Trying to repair network in windows does nothing.

What kind of network activity in GB approximately? What happens if change virtual adapter e.g. e1000?

comment:19 Changed 4 years ago by Hachiman

  • Version changed from VirtualBox 3.0.4 to VirtualBox 3.1.6

comment:20 Changed 4 years ago by Matt Harrison

Smalled size I've seen is about 500 MB in a short time. Also seen it work fine and then die after about 10 GB. Average speed ranges from .5 - 1 MB/s

I'll give e1000 a try and see if it still happens.

comment:21 follow-up: ↓ 22 Changed 4 years ago by Matt Harrison

Ahh, need an edit button.

Smallest size I've seen transfered before losing connection is about 500 MB in a short time.

comment:22 in reply to: ↑ 21 Changed 4 years ago by Hachiman

Replying to Matt Harrison:

Ahh, need an edit button.

Smallest size I've seen transfered before losing connection is about 500 MB in a short time.

So test should be about 20 of wget of 500Mb file from web server or you're using other protocol?

comment:23 follow-up: ↓ 24 Changed 4 years ago by Matt Harrison

I'm not sure, it is a proprietary program I'm using that does both downloading and uploading data (The reason I'm using WinXP in a VBox, it doesn't run on linux).

I'll try also with just downloading from http and see what happens.

comment:24 in reply to: ↑ 23 Changed 4 years ago by Hachiman

Replying to Matt Harrison:

I'm not sure, it is a proprietary program I'm using that does both downloading and uploading data (The reason I'm using WinXP in a VBox, it doesn't run on linux).

I'll try also with just downloading from http and see what happens.

Does anything changed in 3.2.6, for you?

comment:25 Changed 4 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

No response, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use