VirtualBox

Ticket #4869 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 months ago

OS X features like Exposè and Screen capture does not work

Reported by: faz Owned by:
Priority: major Component: GUI
Version: VirtualBox 3.0.4 Keywords:
Cc: Guest type: Windows
Host type: Mac OS X

Description (last modified by frank) (diff)

In my computer I have set OS X to activate exposé when I move the mouse cursor to the screen corners. When I work on a virtual machine (Win XP Pro) with gust additions installed, I am able to move the mouse outside of it and return to OS X BUT I see that exposé corners are not working. I have to click on the desktop and the exposé starts working again.

Something similar happens when you want to use CMD + SHIFT + 4 to take a screen picture: even if your are outside of VM, OS X does not catch all control from the keyboard and such function does not work too. Again I have to click OS X desktop first.

These issues are not present in similar products like Fusion, your software seems better and lighter then competitors, it will be very nice to have this little issues fixed.

Thanks

Attachments

VBox.log Download (51.6 KB) - added by faz 5 years ago.
vmlog

Change History

Changed 5 years ago by faz

vmlog

comment:1 follow-up: ↓ 2 Changed 5 years ago by Parasyte

Try releasing keyboard capture before using your hot corners? (Press and release CMD) The capture icon in the VBox status bar will "gray out" when capture is released.

comment:2 in reply to: ↑ 1 Changed 5 years ago by faz

Replying to Parasyte:

Try releasing keyboard capture before using your hot corners? (Press and release CMD) The capture icon in the VBox status bar will "gray out" when capture is released.

Yes, that is true but is always a step more you have to do when you need to see other windows. Competitor products, eg. vmware, do not need to do this, exposè is always working.

comment:3 follow-up: ↓ 4 Changed 2 years ago by curtoni

Same behaviour on Mac OS X 10.7 (Lion) using VirtualBox 4.1.6

comment:4 in reply to: ↑ 3 Changed 2 years ago by curtoni

Same behaviour on Mac OS X 10.7 (Lion) using VirtualBox 4.1.8

comment:5 Changed 5 months ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate
  • Description modified (diff)

Actually a duplicate of #4139.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use