VirtualBox

Opened 16 years ago

Closed 15 years ago

Last modified 14 years ago

#1256 closed defect (fixed)

Linux Guest loses networking under heavy load

Reported by: mkostrze Owned by:
Component: network Version: VirtualBox 1.5.6
Keywords: Cc:
Guest type: other Host type: other

Description

I have host Mandriva 2007.1 and guest Mandriva 2008.0. I'm using bridged networking in kind of advanced mode. I created private subnetwork for this guest and I'm doing SNAT for it. I can provide any details you may request, but It was working fine with previous versions of VirtualBox.

After upgrading to VirtualBox 1.5.6 I'm experiencing an issue that the guest networking just stops working, and it usually happens when the heavier network load was generated to it (I have a web server on the guest and the network stops working on the guest when handling multiple connections)

Stops working = the guest and host network devices are up, the tap device on the host is still connected to the br device, but connecting out and from the guest is impossible. Restarting the networking on the guest does not help. Restarting the whole guest by invoking 'reboot' command does not help. Only one thing that helps is to stop the guest and cold-start it from VirtualBox.

I tried both e1000 and pcnet32 driver.

Is there any log I can enable / any experiment to do / any more info I can provide?

Attachments (1)

VBox.log (30.5 KB ) - added by Michal Suchanek 16 years ago.
the log (cannot find anything special in it)

Download all attachments as: .zip

Change History (17)

comment:1 by Frank Mehnert, 16 years ago

The E1000 device is experimental so use the default pcnet device for testing. Which package did you install, the Mandriva package from our website? Please could you attach your VBox.log file after you lost the network in the guest.

comment:2 by mkostrze, 16 years ago

Thank you for the reply.

I installed VirtualBox from package on your site.

I switched the driver back to pcnet32.

I downloaded slightly upgraded version of the package (previously it was buildnumber 28241, now I have 28266).

I recreated all the tapX devices on the host as well as the br device just to be sure :)

I'll attach the logs as soon as I replicate the issue with this driver and this version.

comment:3 by Frank Mehnert, 16 years ago

Note that there was a last-minute regression with the 28241 build which was fixed by the 28266 build. So I hope that you will be able to reproduce your problem anymore. :-)

comment:4 by mkostrze, 16 years ago

Yes I saw the change but now I found the note on the webpage. I lost couple of hours replicating and tracking this with previous build :) :) because for me it was not that it didn't work at all - it was working but quite unreliably. Now all seems to work fine. I'll notify you if should I have any further problems with this. Thanks for the answers and best regards

comment:5 by Michal Suchanek, 16 years ago

I see a similar problem on OS X with VirtualBox 1.6.0.

Both pcnet fast III and e1000 cause problems.

In Windows guest the networking is temporarily lost when network is under load. I cannot copy files or run programs from network shares. I did not encounter such problems with the betas.

comment:6 by Frank Mehnert, 16 years ago

hramrach: Which network interface are you using? NAT?

by Michal Suchanek, 16 years ago

Attachment: VBox.log added

the log (cannot find anything special in it)

comment:7 by Michal Suchanek, 16 years ago

It turns out that the problem is I use samba both inside and outside of virtual box which is not handled correctly by the NAT in VBox.

After shutting down all other stuff that uses Samba the networking in VBox works reliably.

comment:8 by Frank Mehnert, 16 years ago

Component: othernetwork

comment:9 by Frank Mehnert, 16 years ago

The question is what samba inside and outside of VirtualBox is not handled correctly means. Actually the NAT engine does not much more than open a port on the host for an open connection from the guest and emulating some protocols itself.

comment:10 by Michal Suchanek, 16 years ago

There is some inherent flaw in the way how samba protocol works which does not allow more than one samba connection to the same server pass through NAT unless the router implementing the NAT does something special beyond plain IP NAT.

Mounting a samba share in the host and in a guest inside VBox running on the host is probably the same as running two connections through NAT which does not work.

comment:11 by Diego Costantini, 15 years ago

I have a similar problem on release 3.0.4. I have 3 VM connected through internal networks (Ubuntu 9.04 host and guests). One in the middle is just doing IP forwarding, the other 2 are doing some video processing and network transfers which create heavy cpu/network load.

sender --> ipfw --> receiver

When this happens, very often one virtual machine (sender) loses networking, and only a complete VM reboot can restore it (sometimes one is not enough...).

And I quote: Stops working = the guest and host network devices are up, the tap device on the host is still connected to the br device, but connecting out and from the guest is impossible. Restarting the networking on the guest does not help. Restarting the whole guest by invoking 'reboot' command does not help. Only one thing that helps is to stop the guest and cold-start it from VirtualBox.

comment:12 by henrik242, 15 years ago

Someone tried to fix this issue in v3.0.8 (http://www.virtualbox.org/ticket/4870), but the problem's still there.

in reply to:  11 comment:13 by vasily Levchenko, 15 years ago

Replying to evil:

I have a similar problem on release 3.0.4. I have 3 VM connected through internal networks (Ubuntu 9.04 host and guests). One in the middle is just doing IP forwarding, the other 2 are doing some video processing and network transfers which create heavy cpu/network load.

sender --> ipfw --> receiver

When this happens, very often one virtual machine (sender) loses networking, and only a complete VM reboot can restore it (sometimes one is not enough...).

Does it happens on 3.0.8? if yes please attach log files.

And I quote: Stops working = the guest and host network devices are up, the tap device on the host is still connected to the br device, but connecting out and from the guest is impossible. Restarting the networking on the guest does not help. Restarting the whole guest by invoking 'reboot' command does not help. Only one thing that helps is to stop the guest and cold-start it from VirtualBox.

comment:14 by Diego Costantini, 15 years ago

I tested a patched 3.0.7 (which could very well be the 3.0.8) and I didn't experience the problem anymore. Unfortunately now I cannot test the 3.0.8.

comment:15 by vasily Levchenko, 15 years ago

Resolution: fixed
Status: newclosed

comment:16 by henrik242, 15 years ago

I've reported a similar issue in ticket #5254

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use