VirtualBox

Ticket #4851 (new defect)

Opened 5 years ago

Last modified 5 years ago

No device is shown for a network bridge mode setting

Reported by: zephyrus Owned by:
Priority: major Component: network
Version: VirtualBox 3.0.4 Keywords: bridge hardware
Cc: Guest type: Linux
Host type: Windows

Description

After I upgraded to vbox 3.0.4, somehow the network interface setting is broken.

Host Windows XP SP3, Guest Debian GNU/Linux.

If I choose bridge mode within the network interface setting before starting the guest image, no device is shown for selection in the menu. The menu has only one entry, which is "undefined". (I believe a hardware network interface should be shown there.)

So I am forced to use NAT mode for now. It works.

However, this is very inconvenient since I was in the middle of developing a software in the guest OS to use UPnP feature of my local router. Since the guest OS is behind NAT of host/Vbox combination, the software inside guest can't see the broadcast on the local network connected to the router easily. (I tested the software on a different PC where Vbox works with bridge mode. It works there.)

I was thinking that a BSOD crash during the upgrade installation of VBOx 3.0.4 may be causing this, but I am not sure. (Somehow during the installation/upgrade of VBox, windows shoed BSOD. BSOD said something about exception/failure inside FW.SYS. My guess it is a driver attached to the network device. FW.SYS is possibly from symantec internet security, Windows firewall, or FW-1 VPN client module. I suspect FW-1 VPN client now.) [OK I was about to post this message when I found that someone also experienced BSOD and he had FW-1 VPN client module! See Postscript.)

Thinking that installing a new network card might change the host Windows registry and other settings enough to cure the problem, I installed a new network interface card (PCI bus), and disabled the onboard NIC. But it didn't solve the problem. VBox still shows "undefined" for the device selection menu if I try to set the network interface to Bridge-type. I tried the four NIC settings available, but again all the entries would end up with "undefined" hardware interface if I try to set the virtual NIC to Bridge-mode.

I wonder what I should do (uninstall/reinstall Vbox, uninstall/reinstall FW-1 VPN client?)

Anyway, I am posting this to let the developers know that a situation can occur where no real NIC hardware device is shown for selection to set virtual NIC to bridge-mode and that there may be unintended interaction with FW.SYS driver (possibly from FW-1 VPN client package.) during install/upgrade/ordinary run time.

TIA

PS: Ticket #4119 mentions an unfavorable interaction with checkpoint FW-1 VPN client that caused BSOD, and the ticket mentioned FW.SYS (!) So there is probably an unintended interaction with this module during upgrade/installation. But the message I got during BSOD during upgrade was different. It was more like device_irql_not_less_than_or_equal mentioned in  http://www.mail-archive.com/fw-1-mailinglist@beethoven.us.checkpoint.com/msg00312.html Well as bugs go, anything can happen once the incorrect execution path is taken.

Not being able to see the real hardware NIC for selection may be related to a problem mentioned in 4119, but I am not sure.

BTW, I could not find Ticket #4119 when I tried to search the ticket system. google search found # 4119 after a search for "FW.sys windows sp3" when I tried to determine the origin of this driver file.

Again, TIA for your attention.

Change History

comment:1 Changed 5 years ago by zephyrus

Just a thought.

Looking at #4119, I think Vbox may not be seeing the chains of stacked drivers for a real hardware NIC or something. (Just a wild guess. when I check control panel -> devices -> network, there are the lowest-level hardware NIC driver as well as slightly upper level FW-1 network driver and others. This may confuse the Vbox to get to the bottom to reach the real HW NIC. )

The above is my guess of not being shown a valid real HW NIC when I try to set the virtual NIC to bridged mode.

BSOD during upgrade/install may be related to the same observation, but may not.

TIA

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use