VirtualBox

Ticket #4850 (closed defect: fixed)

Opened 5 years ago

Last modified 3 years ago

Dynamic resizing stopped working

Reported by: letezo Owned by:
Priority: major Component: guest additions
Version: VirtualBox 3.0.4 Keywords: dynamic resizing
Cc: Guest type: other
Host type: Linux

Description

Environment

I've 8Gbytes of RAM and an Intel Q6600 CPU (4 cores, 64 bit support), all working fine for 21 months.

It is an entirely new 64 bit Ubuntu 9.04 host installation (on new HDDs), no third party applications installed on the host OS other than available from the Ubuntu repositories without any trickery. The host OS is up to date. I use Gnome with almost the minimal number of Compiz desktop effects.

I've an nVidia Corporation GeForce 8600 GT (rev a1) graphics card with 512Mbytes of on board memory. I use version 180 of the proprietary nVidia Linux drivers installed using Ubuntu's default driver installer. It worked fine out of the box.

I've successfully configured the following guest OSes:

  • Ubuntu 8.10
  • Windows Server 2003

The Ubuntu 8.10 guest was cloned from a vmdk image originally created and used in VMware Server 1.0.7. The VMware Tools was uninstalled first, certainly.

The Windows Server 2003 guest was created in VirtualBox, then copied a physical instance of Windows Server 2003 into the VM and fixed its boot process. All physical drivers were uninstalled first.

Problem

Dynamic resizing of guest screens worked just fine in both guests for a few hours after installing the guest additions into them. Then for some unknown reason dynamic resizing stopped working in both guests (possibly) at the same time, which is strange, since they run different OSes. It happened while running both guests and doing nothing special with them.

I've other guests OSes, they were not running at that time. They seem to be unaffected by this problem. I haven't used suspend or hibernation on those guests nor the host system. No snapshots of these OSes were made.

Attached configuration and all the available log files for both guests.

What I tried already

  • I tried to reinstall the guest additions in both OSes, it did not help.
  • I tried to search the forums, but found only unrelated problems or workarounds not solving my problem.

Attachments

ubuntu-8.10.zip Download (48.0 KB) - added by letezo 5 years ago.
Ubuntu 8.10 guest OS configuration and logs
windows-2003.zip Download (45.4 KB) - added by letezo 5 years ago.
Windows Server 2003 guest OS configuration and logs
VBox.log Download (41.7 KB) - added by letezo 5 years ago.
Log file of the Windows Server 2003 VM right after dynamic resizing started to work again due to applying the workaround below
VBox.2.log Download (43.5 KB) - added by letezo 5 years ago.
Log file for the new single VM observation of the dynamic resizing bug
windows-2003.xml Download (7.5 KB) - added by letezo 5 years ago.
Windows Server 2003 VM configuration file

Change History

Changed 5 years ago by letezo

Ubuntu 8.10 guest OS configuration and logs

Changed 5 years ago by letezo

Windows Server 2003 guest OS configuration and logs

comment:1 Changed 5 years ago by letezo

Automatic resizing of the Ubuntu 8.10 guest suddenly started to work and it worked fine until I shut it down.

On the other hand dynamic resizing in the Windows Server 2003 guest hasn't started to work yet. Its display can be sized explicitly, but not automatically. I try to work this around by adding my full screen video mode and using the guest only in fullscreen mode until this bug is fixed.

comment:2 Changed 5 years ago by letezo

New founding: I had to use the "Auto-resize Guest Display" menu item from the Machine menu of the VM once, then it started to work again. Pressing the Host-F or Host-G keys from the VM did not resize the guest's screen until I selected the menu item once. (I possibly did this as well to the Linux VM unintentionally. I just don't remember.)

NOTE: My host key is the right "Windows Key". I use a standard Hungarian keyboard.

Workaround

If you experience this bug you just have to select the "Auto-resize Guest Display" from the VM's Machine menu once, then resizing start to work again even if you press the above hotkeys.

You might need to restart the guest if it does not work for you the first time. I'm not sure whether this step is required, however.

Attaching my latest log of the Windows Server 2003 VM. It might help the developers to track this down.

Changed 5 years ago by letezo

Log file of the Windows Server 2003 VM right after dynamic resizing started to work again due to applying the workaround below

comment:3 Changed 5 years ago by letezo

VM screen resolutions I used to switch between:

  • Windowed size: 1680x923

The VM had stuck at this size while the bug had been happening, even when switched to fullscreen mode.

  • Full screen size: 1680x1050

It is the fullscreen resolution.

comment:4 Changed 5 years ago by letezo

It just happened to a Windows Server 2003 guest after ~18 hours of error free runtime. I had left the machine and the VM running IDLE for 5 hours before it happened. The screensaver is disabled in the guest. All the power saving options are also disabled in the guest, no automatic power off of the monitor or HDDs.

Attached the log of this session.

I've observed that the Display::handleDisplayResize calls are disappearing while this bug is happening to the VMs.

Changed 5 years ago by letezo

Log file for the new single VM observation of the dynamic resizing bug

comment:5 Changed 5 years ago by letezo

Could you please change the subject to just "Dynamic resizing stopped working"?

Changed 5 years ago by letezo

Windows Server 2003 VM configuration file

comment:6 Changed 5 years ago by letezo

Tried to restart the VM, did not help.

Tried to fit the VM window to the guest, did not help.

Finally found a workaround, which works at least for the Windows guest: When dynamic resizing becomes broken you just have to resize the guest from its own display settings, then dynamic resizing will start to work again when you press Host+F the next time.

comment:7 Changed 5 years ago by letezo

But it is still a bug, which happens once in a few VM days, at least for me.

comment:8 Changed 5 years ago by michael

  • Summary changed from Dynamic resizing in two guests stopped working at the same time to Dynamic resizing stopped working

Just for sanity, could you check if you still get lines containing "VMMDev::SetVideoModeHint" appearing in the machine log at times when a dynamic resize should take place but doesn't? This will show whether the problem is (likely to be) on the host or guest side. If those lines appear, then the host has done its part of the job and the guest is most likely not responding to it for some reason.

comment:9 Changed 5 years ago by letezo

According to the  logs the lines you mentioned are there, so it is a problem in the guest, indeed. But it happened in both my Windows and Linux VMs, so it must be something generic and essentially OS independent issue with Guest Additions or the communication "link" between the host and the guest.

comment:10 Changed 5 years ago by michael

And to be sure, these lines continue to be added when they should be? That is, if you count those lines before and after attempting a dynamic resize, there is at least one additional one in the log afterwards?

comment:11 Changed 5 years ago by letezo

Yes, they appear in the machine log whenever I try to resize, but the guest does not respond by resizing itself.

comment:12 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 4.0.4.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use