VirtualBox

Ticket #4496 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Annoyng "A network cable is unplugged" message => Fixed in SVN

Reported by: axet Owned by:
Priority: major Component: other
Version: VirtualBox 3.0.2 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

Windows XP every 5 seconds show "A network cable is unplugged" message.

Setup two virtual network adapter, first adapter map to NAT, second bridge to connected wire network. After it remove "cable connected" in options menu. Connect real cable to bridged interface. And run Windows XP.

Attachments

Screenshot.png Download (34.1 KB) - added by axet 5 years ago.
(XP) Visual Studio Full 2008-2009-07-12-22-31-33.log Download (61.8 KB) - added by axet 5 years ago.
Screenshot-Additional Options.png Download (12.1 KB) - added by axet 5 years ago.
Screenshot-Sun VirtualBox.png Download (8.1 KB) - added by axet 5 years ago.

Change History

Changed 5 years ago by axet

Changed 5 years ago by axet

Changed 5 years ago by axet

Changed 5 years ago by axet

comment:1 Changed 5 years ago by frank

What do you mean by remove "cable connected" in options menu? If you click on that menu, then the virtual network cable is disconnected and Windows will detect that, regardless of the state of your physical network cable. Or did I misunderstand you?

comment:2 Changed 5 years ago by axet

I was think this. But now i found windows make it independ on physical cable status. Windows always trying to establish connection it happens (as i suspect) because vbnet send signal "Cable connected". Then windows show looking for IP icon on task bar, then show "No network cable". And it happens again and again.

comment:3 Changed 5 years ago by frank

Still don't fully understand your scenario. Is the virtual network cable (in the VM network settings) connected or disconnected?

If it is disabled then the guest will detect that and probably complain.

comment:4 Changed 5 years ago by axet

in vb network device enabled and cable disconnected.

comment:5 Changed 5 years ago by axet

guest should make it once

comment:6 Changed 5 years ago by ctroncoso

Got the same issue with 3.0.6 r52128 Host : Linux Ubuntu 9.04 Guest : WinXp Net Adapter 1 : Bridge -> wlan0 Disconnected (unchecked in adapter list) Net Adapter 2 : NAT Connected Net Adapter 3 : Host-only Disconnected Net Adapter 4 : Bridge -> eth0 Disconnected


Every few seconds, all the supposed disconnected adapters (icons) flash, like in a normal DHCP negociation, and then the anoying message "Cable unplugged". So, I have to disable them from the guest OS to be able to work without bubble messages poping up every few secs.

comment:7 Changed 5 years ago by frank

ctroncoso, please attach a VBox.log of such a VM session when you experience these messages in the guest.

comment:8 Changed 4 years ago by frank

axet, still unable to reproduce. I have a setup which is mostly the same as yours (3 x pcnet, 1st: NAT, 2nd: wlan0, 3rd: eth0, WinXP guest). Currently wlan0 is not connected (I'm connected through eth0) and there is an exclamation mark on the Windows guest but no annoying message boxes. Do you have some system tool installed which is fiddling with the network connections?

comment:9 Changed 4 years ago by axet

annoying message is windows tool tip message appears each few seconds. which told about "A network cable is unplugged". see (Screenshot.png).

i have no special application installed, this issue appear on clean windows installation.

please check all contitions:

  • three interfaces
  • one nat, default connected
  • two other enabled but no virtual/physical cable connected. (Screenshot-Additional Options.png)

comment:10 Changed 4 years ago by axet

oh, my bad. it is nessesery to have physical connection and no virtual connection.

same for wlan0, if it connected to real wifi, and have no virtual cable connected (bridged connection) i got same issue. (bumping tool tip message)

comment:11 Changed 4 years ago by frank

Uh, finally I'm able to reproduce this behavior! Investigating ...

comment:12 Changed 4 years ago by frank

Does not happen with the E1000 device emulation.

comment:13 Changed 4 years ago by axet

oh, nice. look like VM passtrough some events which it should to fliter.

comment:14 Changed 4 years ago by frank

  • Summary changed from Annoyng "A network cable is unplugged" message to Annoyng "A network cable is unplugged" message => Fixed in SVN

Fixed in r24455. The fix will be contained in the next release. Actually the guest was confused because some packets arrived its RX buffers even if the link down.

comment:15 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in 3.0.12.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use