VirtualBox

Ticket #4380 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Copy/Paste not working in Windows guest -> fixed in SVN

Reported by: fgm81 Owned by:
Priority: major Component: guest additions
Version: VirtualBox 3.0.0 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

When in the file manager in the Windows guest, if I select and right click to copy a file, when I go to try and paste the file, the paste options are greyed out. Similarly Ctrl-C --> Ctrl-V also doesn't work.

Attachments

VBox.log Download (59.4 KB) - added by r666 4 years ago.

Change History

comment:1 in reply to: ↑ description ; follow-up: ↓ 2 Changed 5 years ago by d0b33

I can confirm this bug, paste grayed out...  http://imgur.com/dVkHN.jpg Ubuntu 9.04 host, XP SP3 guest, virtualbox 3.0 with 3.0 guest additions for windows.

Replying to fgm81:

When in the file manager in the Windows guest, if I select and right click to copy a file, when I go to try and paste the file, the paste options are greyed out. Similarly Ctrl-C --> Ctrl-V also doesn't work.

comment:2 in reply to: ↑ 1 Changed 5 years ago by d0b33

forum discussion  http://forums.virtualbox.org/viewtopic.php?f=7&t=19350

Replying to d0b33:

I can confirm this bug, paste grayed out...  http://imgur.com/dVkHN.jpg Ubuntu 9.04 host, XP SP3 guest, virtualbox 3.0 with 3.0 guest additions for windows.

Replying to fgm81:

When in the file manager in the Windows guest, if I select and right click to copy a file, when I go to try and paste the file, the paste options are greyed out. Similarly Ctrl-C --> Ctrl-V also doesn't work.

comment:3 Changed 5 years ago by d0b33

Ok found a temporary workaround, disable the shared clipboard setting, bidirectional needs to be fixed.

comment:4 Changed 5 years ago by pablofaria

Same problem here. I could copy via Command Prompt, but the permission of the file is set to readonly. (as the bug about saving with MS-Office suite).

comment:5 Changed 5 years ago by gbc921

I'm having this problem too. When you install Guest Additions, if shared clipboard is active on bi-directional mode, the paste button or shortcut is disabled; but whether you kill the process "Vboxtray.exe" the paste turns on.

Thanks.

comment:6 Changed 5 years ago by michael

Reproduced here, will investigate.

comment:7 Changed 5 years ago by michael

#4414 has been marked as a duplicate of this ticket.

comment:8 Changed 5 years ago by michael

  • Summary changed from Copy/Paste not working in Windows guest to Copy/Paste not working in Windows guest -> fixed in SVN

Fixed in SVN.

comment:9 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

comment:10 Changed 5 years ago by Perryg

  • Status changed from closed to reopened
  • Resolution fixed deleted

My Original ticket #4414 has my information.
Sorry to do this but installed 3.0.2 and GA 3.0.2.
Copy & Paste still does not work. Drag and Drop still does.
Now it caused Explorer to crash and close the VBox GUI and reopen the VBox GUI.
Explorer did not return and caused the Vista screen to reload all objects.
Still closing the guest that has the GA's loaded returns the copy & paste function.

Let me know what you need from me.

comment:11 Changed 5 years ago by Perryg

I found that removing the GA then installing the new GA may have actually fixed this problem. Must be some artifact that does not get overwritten on upgrading the install of the GA. Anyway this seems to resolve the issue.

You may close this ticket once again. Thank you VBox team!

comment:12 Changed 5 years ago by sandervl73

  • Status changed from reopened to closed
  • Resolution set to fixed

comment:13 Changed 5 years ago by siegerstein

  • Status changed from closed to reopened
  • Resolution fixed deleted

Confirm this bug in VB 3.0.2 & GA 3.0.2. Copy -> Past work *only* if VBoxTray shutdown or GA is not installed.

Host OS: Linux Ubuntu 9.04

Guest OS: Windows XP Professional SP3

 http://www.youtube.com/watch?v=b517LJnfu8U

comment:14 Changed 5 years ago by michael

Unfortunately I was unable to reproduce this using VirtualBox 3.0.3 (our internal development version, but only slightly modified over 3.0.2) and the Guest Additions from 3.0.2. I will try again with the released version of 3.0.2 just to be sure of course.

Host OS: Ubuntu 9.04, guest Windows XP Pro SP3, both fully updated; VBoxTray running.

siegerstein: would you be able to try experimenting a bit (possibly with a fresh Windows guest if that is doable) to see if you can isolate this any further, to help me reproduce it? Thanks.

comment:15 follow-up: ↓ 16 Changed 5 years ago by michael

Update: neither do I see this with a release version of VirtualBox 3.0.2 (Ubuntu 9.04 64bit package) and the 3.0.2 Additions.

comment:16 in reply to: ↑ 15 Changed 5 years ago by siegerstein

I have investigated this problem, and found that is was clipboard conflict. In my case it was conflict with VB & Parcellite. After shutdown (also help restart) this clipboard manager, copy -> past work grate! Using glipper and VB have no problem.

Seems same minor conflict with clipboard buffer.

Conclusion: bug fixed.

comment:17 Changed 5 years ago by michael

  • Status changed from reopened to closed
  • Resolution set to fixed

Thanks for the feedback, I will close the ticket again. I may still take a look at Parcellite though, just to be sure it is not something we are doing wrong.

comment:18 Changed 4 years ago by r666

  • Status changed from closed to reopened
  • Resolution fixed deleted

Same for me. virtualbox 3.1.0 with 3.1.0 guest additions for windows. Host OS - Ubuntu 8.04 guest OS - Win XP SP3

Ctrl-C, Ctrl-V doesn't work, paste options are greyed out!

comment:19 Changed 4 years ago by michael

r666: please attach a log file for that guest, if possible running VirtualBox with the environment variable

VBOX_RELEASE_LOG=+shared_clipboard.e.l.l2.l3.f

on the host. You can do this from bash as follows:

$ VBOX_RELEASE_LOG=+shared_clipboard.e.l.l2.l3.f VirtualBox -startvm <your VM name>

Changed 4 years ago by r666

comment:20 Changed 4 years ago by r666

I'm sorry. My mistake, please close.

comment:21 Changed 4 years ago by sandervl73

  • Status changed from reopened to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use