VirtualBox

Ticket #4381 (reopened defect)

Opened 5 years ago

Last modified 5 months ago

windows guest - linux host file permissions changed on shared folders -> Fixed in SVN

Reported by: Tvtech Owned by:
Priority: major Component: shared folders
Version: VirtualBox 3.0.6 Keywords: file permissions, shared folders
Cc: Guest type: Windows
Host type: Linux

Description

I recently upgraded to 3.0.0.

I have a number of EXT3 and EXT4 share folders which I access from a windows host via VirtualBox's shared folder handler. When I access a file in one of the EXT folders it reads and writes to it the first time. When I modify the file and re-save, or auto save it says it is read-only. This primarily happens with Microsoft office related products. [URL=" http://ubuntuforums.org/showthread.php?t=1202151]"]This ThreadURL was started by some one having the same problem in 2.2.4 It does not happen on NTFS shared folders.

Attachments

Windows XP SP3 40G-2009-07-03-11-02-52.log Download (60.7 KB) - added by Tvtech 5 years ago.
Windows XP SP3 40G-2009-07-03-11-02-52.2.log Download (60.7 KB) - added by Tvtech 5 years ago.
virtual box log during permission change
Windows XP SP3 40G-2009-07-03-11-22-16.log Download (63.2 KB) - added by Tvtech 5 years ago.
another log with the same file permissions alteration
VBox.log Download (47.7 KB) - added by auspex@… 5 years ago.
VBox.log as requested by sunlover
Windows 7-2009-11-09-14-56-35.log Download (53.1 KB) - added by scaary 4 years ago.
Windows 7 guest
VBox.2.log Download (45.8 KB) - added by poppafuze 4 years ago.
Win XP Home x86 guest on Karmic host - can't unset read perms on folder in share
VBox.log-2011-06-15 Download (68.1 KB) - added by sholmes 3 years ago.
Log file of for VM where writing to files failed.

Change History

Changed 5 years ago by Tvtech

Changed 5 years ago by Tvtech

virtual box log during permission change

Changed 5 years ago by Tvtech

another log with the same file permissions alteration

comment:1 Changed 5 years ago by pablofaria

I'm just updated for VBox 3.0 and I'm facing the same issue. I didn't find problems with other applications yet, except MS-Office suite (which are taking too long to read the files too).

comment:2 Changed 5 years ago by pablofaria

Just to be clear, I can save the file only once. After this, the permission is changed and I have to restore it before saving again.

comment:3 Changed 5 years ago by Tvtech

A note on the problem:

If you have an instance of Nautilus/Dolphin open to the directory your file is stored in; at the time of file modification/save the permissions do not get changed. Pablo could you try this and verify? I tried with MS word, Excel and visual studio, all MS products. I'll try doing it with a non MS product, to verify.

As noted this happens in Gnome2.26.1 and KDE4 vbox 3.0.0

comment:4 Changed 5 years ago by Tvtech

A note on the problem: clarified.

If you have an instance of Nautilus/Dolphin open in your "HOST OS" to the directory your file is stored in; at the time of file modification/save in your "GUEST OS" the permissions do not get changed. Pablo could you try this and verify? I tried with MS word, Excel and visual studio, all MS products. I'll try doing it with a non MS product, to verify.

As noted this happens in Gnome2.26.1 and KDE4 vbox 3.0.0

comment:5 Changed 5 years ago by yesint

I confirm this bug. I have it in Ubuntu 9.04 host and WinXP guest.  http://www.virtualbox.org/ticket/4390[[BR]]

 http://ubuntuforums.org/showthread.php?p=7568616

comment:6 Changed 5 years ago by meah

Same behaviour on Ver 3.0 Host: Fedora 9 Guest: W2K

copy with Explorer creates 664 copy with totalcommander creates 400 - delete of the files from totalcommander is possible copy with cmd creates 400 - delete of the files from cmd is possible

I reposted it from a closed ticket #2592.

comment:7 Changed 5 years ago by pablofaria

I tried with Nautilus opened and got the same problem. My host is Ubuntu 8.04, with Gnome 2.22.3, with guest WinXP SP3.

comment:8 Changed 5 years ago by moeis

me too! Vbox 3.0 | Host: openSUSE 11.1 KDE 4.2 | Guest: WinXP SP3 Problem occurs with all MS Office 10 / 2007 products in the way described.

comment:9 Changed 5 years ago by annie.furser

Confirming on Ubuntu 9.04 host with Windows XP SP3 guest. Virtualbox 3.0.0 r49315

comment:10 Changed 5 years ago by sunlover

  • Priority changed from minor to major
  • Summary changed from windows guest - linux host file permissions changed on shared folders to windows guest - linux host file permissions changed on shared folders -> Fixed in SVN

Thanks everyone for reporting the problem. The fix will be available in the next VBox version.

comment:11 Changed 5 years ago by wnicholls

Lovely. I can't want and am going back to VBox 2 immediately. I hope the config files are still compatible.

BTW I had a problem almost exactly like this in VirtualBox before, it got fixed ages ago so this is a regression. Times like this I think virtualbox is all a sly plot to make people buy VMWare Workstation. Something critical breaks in every release - I haven't dared find out whether the clipboard sharing works.

I think I solved the problem then by using Samba and connecting to a network drive. If Samba can map permissions correctly, vbox should be able to use the same rules.

Incidentally, normal readonly files (from when I was using VBox 2.2) have permissions 444. Attempting to REMOVE readonly attribute appears to change to 400 (not the expected 666) the ATTRIB command couldn't fix this.

comment:12 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

comment:13 follow-up: ↓ 14 Changed 5 years ago by auspex@…

  • Status changed from closed to reopened
  • Resolution fixed deleted

I just downloaded the latest 3.0.6 r52128, having encountered this issue, and it's still there. So it's either been regressed again, or hasn't been fixed. It's really frustrating when you can't run apps that write to shared storage.

comment:14 in reply to: ↑ 13 ; follow-up: ↓ 15 Changed 5 years ago by sunlover

Replying to auspex@pointerstop.ca:

I just downloaded the latest 3.0.6 r52128, having encountered this issue, and it's still there. So it's either been regressed again, or hasn't been fixed. It's really frustrating when you can't run apps that write to shared storage.

Which application do you use to save files to shared folders? And please attach VBox.log of the VM.

comment:15 in reply to: ↑ 14 Changed 5 years ago by auspex@…

Replying to sunlover:

I'm trying to test an Apache Pluto server, but surely the application is irrelevant - opening the folder in Explorer shows the status as read-only, and the only way to get anything to write into the folder is to create the files first in Explorer.

Changed 5 years ago by auspex@…

VBox.log as requested by sunlover

comment:16 follow-up: ↓ 17 Changed 5 years ago by frank

  • Version changed from VirtualBox 3.0.0 to VirtualBox 3.0.6

Changed 4 years ago by scaary

Windows 7 guest

comment:17 in reply to: ↑ 16 Changed 4 years ago by scaary

Hi, I'm experiencing similar problems with windows XP and Windows 7 (Ubuntu 9.10, VB 3.10). I can make folders and files myself, and deleting them is also not a problem.

But I have e.g My scanner software running in VB. Scanning works fine, but as soon as I try to save it, it simply refuses to write the files on the specified folder.

Same for my java written software; In order to work properly it needs to write some files in normal, by the software created folders. These folders and files are never created by the software and therefore I get a "File not found" exception later on.

It doesn't matter if I have the software running in eclipse, or as stand alone.

Hope you know a fix for the problem. Thanks, scaary

Changed 4 years ago by poppafuze

Win XP Home x86 guest on Karmic host - can't unset read perms on folder in share

comment:18 Changed 4 years ago by poppafuze

Also can confirm inability to of an app to write to a folder in a shared dir. Host is Linux (Karmic, 2.6.31-17-generic x85_64) from XP guest. However, when I manually create a new file in that dir, it seems to work. Only the app has trouble, saying in a popup that it needs write permission to the folder. The logged-in user on the guest is an admin. Also tried running the app as current user but with 'protect' unset.

Each attempt to unset read only perms in the file properties on the guest is ignored.

Also is the "fixed in SVN" portion of ticket title still valid?

comment:19 Changed 4 years ago by sunlover

poppafuze, which application fails to write to a shared folder?

comment:20 Changed 4 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

No response, closing. Please reopen if still relevant.h

comment:21 Changed 3 years ago by tenter

  • Status changed from closed to reopened
  • Resolution fixed deleted

I have the same issue in version 4.0.4 as reported above and in the various duplicate tickets. The issue was first detected in World of Warcraft, but I can easily reproduce using Windows Explorer. In my case I am using Ubuntu 10.10 host and Windows XP client.

The folder appears to be read-only. I can clear it, and all looks fine, but when I refresh it displays as read-only again.

I am reopening since the issue seems to be unresolved.

comment:22 Changed 3 years ago by sholmes

I'm seeing an identical problem with OS X as the host system, VirtualBox 4.0.8 and Windows XP Home as the guest OS.

I'm having the problem with Quicken Deluxe 2011 where it cannot create or modify files. As with others folks, the "Read Only" flag is set on *all* directories and attempts to remove it fail.

I ran a tail on the VBox.log file to see what logs when I attempt to create/edit/overwrite a file through the application and nothing is logged.

Please let me know if there is any other relevant data I can contribute.

Changed 3 years ago by sholmes

Log file of for VM where writing to files failed.

comment:23 Changed 3 years ago by NoraaC

I have this problem also. Host Ubuntu 10.04 Guest WinXp & Win7. Quickbooks 2009 & Foxpro 9 have problems writing to the shared folder. I one case a Foxpro program refused to overwrite a file on the share but if the program deleted the file and then created a new one it worked. Foxpro also reports some cursors that it creates as being read only and unmodifiable.

If I try to run an installer for a Windows program that is located on the shared folder many but not all will report invalid path or choke somewhere later in the install procedure. Others install even when installed on the share with no problem.

I run Vbox on several computers and the symptoms are not exactly the same on all installations making it that much harder to track down.

I have also noticed that the problem seems to be more severe on the Win7 VMs than on WinXP.

This has been on going now for several Vbox versions. I haven't had time to try 4.1 yet.

comment:24 Changed 3 years ago by Zucan

I am having the same problem. I noticed it as well with World of Warcraft when the Curse Client started only seeing a small number of the AddOns that I am using. Further investigation showed that my WoW shared folder, as well as my other non-WoW-related shared folders, were in read-only mode. I could clear it, but to no avail.

I have looked at the underlying folder structure. I own all the files, they are all read/write by me, and there isn't anything odd about the underlying directory trees.

I had upgraded to 4.1.0, and that seemed to be when I first saw it. I just upgraded to 4.1.2 and updated the guest additions. The problem is still there.

I am running Ubuntu 11.04 x64, running VirtualBox 4.1.2, and the Guest OS is Win7 Home Premium 64bit.

comment:25 Changed 5 months ago by Petr Vones

The issue is back in 4.3.4. Windows 2008 host and guest. Changing the readonly flag of a share does not make it writeable, guest restart does not help either.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use