VirtualBox

Ticket #4414 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

Windows HOST can not copy/cut & paste in file manager when VM with GA 3.0.0 running -> duplicate of #4380

Reported by: Perryg Owned by:
Priority: critical Component: other
Version: VirtualBox 3.0.0 Keywords: Host File management
Cc: Guest type: Linux
Host type: Windows

Description

When starting Vista HOST I can move files using copy/cut & paste in the file manager. I can start the VBox GUI, and any VM that does NOT have the 3.0.0 GA installed and can still copy/cut & paste in the HOST. Once I start a VM that has the 3.0.0 GA installed the copy/cut & paste stops working in the HOST file manager. I can drag and drop files still but when I go to paste the paste is grayed out. Text (clipboard options) are still able to be copied and pasted in things like notepad and firefox, but not files. Shutting down the Guest VM with GA 3.0.0 installed will bring back the copy/cut & paste to the HOST. Weird huh? Let me know what else you need. I know you are busy but this is really bugging me. I have tried various things but the only thing that will work is to regress the GA.

I am submitting a log of one VM that when started causes this problem.

Attachments

Ubuntu Jaunty-2009-07-06-17-03-02.log Download (51.4 KB) - added by Perryg 5 years ago.
Log file of Jaunty VM

Change History

Changed 5 years ago by Perryg

Log file of Jaunty VM

comment:1 Changed 5 years ago by antonio.guadagnin

Same bug in Opensuse 11.0 - 2.6.25.20-0.4-pae

comment:2 Changed 5 years ago by michael

Probably a duplicate of #4380. The X11 clipboard code (both for X11 hosts and guests) was not noticing when a format it didn't understand (like a file) was put in the clipboard at the other end, and was re-asserting whatever was already in the X11 clipboard.

To test this theory, copy something in your X11 guest, then copy a file in the Windows host and try to paste text in Notepad or something. It will most likely still paste the text you previously selected in the guest.

comment:3 Changed 5 years ago by Perryg

Read that one and didn't think it applied since Vista host is what is compromised. Nothing to do with X11 on this end that I can tell, could be wrong though. I can have the host and a windows guest with the 3.0.0 GA and it will do the same. I will test this out here in a bit though and post findings. Oh and the clipboard works as far as I can tell it is file copy and paste in the Vista file manager that looses it.

comment:4 Changed 5 years ago by michael

Perryg: it would be interesting if you could try the test I described with an X11 guest (and possibly a Windows one).

comment:5 Changed 5 years ago by Perryg

@michael,

I promise I will do that today. I have a project due in a few hours and can not shut the guest down and well, you understand...

comment:6 Changed 5 years ago by Perryg

@michael,

I had a minute and did as you suggested.

I copies the content of the xorg.conf from the X11 guest. I then copied text from a file on the host. Opened notepad and pasted. It pasted the content from the host file.

While the guest was still up I opened the file manager in Vista and copied a file, went to a test directory, and paste was grayed out. Closed the guest and tried it again (did not reboot, just shut down the guest) paste returned as a function.

Please let me know what else I can do to help find this as I will be at your disposal ready and willing to test anything that you need.

comment:7 Changed 5 years ago by michael

Sorry, what I meant was: copy text in the guest; copy a file (not text!) in the host file manager; try to paste into notepad or something on the host.

comment:8 Changed 5 years ago by michael

That is, no copies of text on the host at all, just a copy of a file and pasting of text.

comment:9 Changed 5 years ago by Perryg

Got it.

Copied content of xorg.conf. copied "file" in Vista file manager. Opened notepad paste was the xorg.conf content. As you suspected.

Where to now?

comment:10 Changed 5 years ago by michael

Now I fix it :) But I'm interested to know if it happens with Windows guests too.

comment:11 Changed 5 years ago by Perryg

@michael,

Windows guest is different. copy text from file in XP. copy file from vista. try to paste in notepad, paste is gray.

Once you copy a file the paste function goes away on the host if it is windows to windows.

Simply amazing! Have at it and do let me know if there is anything else you need.

comment:12 Changed 5 years ago by michael

  • Status changed from new to closed
  • Resolution set to duplicate
  • Summary changed from Windows HOST can not copy/cut & paste in file manager when VM with GA 3.0.0 running to Windows HOST can not copy/cut & paste in file manager when VM with GA 3.0.0 running -> duplicate of #4380

The problem is now fixed in SVN. I will close the ticket as a duplicate.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use