VirtualBox

Ticket #3898 (closed defect: fixed)

Opened 5 years ago

Last modified 15 months ago

Guest window keeps disappearing

Reported by: myxiplx Owned by:
Priority: major Component: GUI
Version: VirtualBox 2.2.2 Keywords: flicker disappear
Cc: Guest type: Windows
Host type: Linux

Description (last modified by frank) (diff)

Since upgrading to 2.2.2 I'm getting a regular 'flicker' of my virtualbox guest window. It keeps disappearing completely, showing the desktop underneath, and it's doing this in both full screen and windowed mode.

Most of the time this is just for a fraction of a second, but it's occasionally been almost a full second long, which made me think virtualbox had crashed the first time I saw it.

2.2.0 was fine, however I have just done a major update of my system, so isolating the cause of this may be tricky. In one step, I upgraded:

Ubuntu 8.10 -> 9.04 VirtualBox 2.2.0 -> 2.2.2

And as part of the upgrade I also installed the latest ATI Radeon Drivers for Linux (v9.4).

Change History

comment:1 Changed 5 years ago by frank

Does the guest window behave like before after you did

VBoxManage setextradata global "GUI/RenderMode" sdl 

and restarted the GUI + VM?

comment:2 Changed 5 years ago by dacheetah

I have the same symptoms (flickering guest window any time the guest window is selected and the host has something pop-up such as a tool-tip or notification message).
I am running two monitors (ATI Drivers) in 64bit 9.04, with the guest window fullscreen on one screen. Currently have VirtualBox 3.0.0 r49315 installed, although the problem existed before upgrading to this version.
I have tried franks suggestion (VBoxManage setextradata global "GUI/RenderMode" sdl) and this appears to have made no difference (even after restarting GUI + VM (even the whole system)).

comment:3 Changed 15 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
  • Description modified (diff)

Please reopen if still relevant with VBox 4.2.6.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use