VirtualBox

Ticket #3897 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

VirtualBox 2.2.2 cannot be start on OpenSolaris due to referenced symbol not found.

Reported by: kgardas Owned by:
Priority: major Component: other
Version: VirtualBox 2.2.2 Keywords:
Cc: Guest type: other
Host type: Solaris

Description

Hello, I have installed VBox 2.2.2 release on my OpenSolaris box, precisely this is SXDE 1/08 aka snv_79a. When I try to run the VirtualBox binary I get following error message:

karel@silence:/opt/VirtualBox$ ./VirtualBox 
VirtualBox: supR3HardenedMainGetTrustedMain: dlopen("/opt/VirtualBox/amd64/VirtualBox.so",) failed: ld.so.1: VirtualBox: fatal: relocation error: file /opt/VirtualBox/amd64/libQtGuiVBox.so.4: symbol FcFreeTypeQueryFace: referenced symbol not found
karel@silence:/opt/VirtualBox$ 

I do have LD_LIBRARY_PATH env var unset for this test to be sure VBox really tries to use its own libraries.

Change History

comment:1 Changed 5 years ago by kgardas

I would also like to add that I've not seen such error up to version 2.1.4 including. Hence in the meantime I'm going to downgrade again to the 2.1.4 release.

comment:2 Changed 5 years ago by ramshankar

This requires installing a patch. Patch number: 138353-02

http://sunsolve.sun.com/search/document.do?assetkey=1-21-138353-02-1}}}

comment:3 in reply to: ↑ description ; follow-up: ↓ 4 Changed 5 years ago by daniel.vergien

I got the same error with vbox 2.2.2 on solaris 10u5 x86. Patch 138353-02 is installed.

dve@nilfsik-ng 2.2.2-46594 $ LC_ALL=C crle

Default configuration file (/var/ld/ld.config) not found
  Default Library Path (ELF):   /lib:/usr/lib  (system default)
  Trusted Directories (ELF):    /lib/secure:/usr/lib/secure  (system default)

Vbox 2.1.4 works without any problems

comment:4 in reply to: ↑ 3 Changed 5 years ago by daniel.vergien

Sorry that I have to replay to myself, but:

I got the same error with vbox 2.2.2 on solaris 10u5 x86. Patch 138353-02 is installed.

is wrong. I can not install this patch since you can only download it with a valid solaris service plan.

comment:5 Changed 5 years ago by jkeil2

Without a solaris service plan: I'd suggest that you perform an upgrade install of your Solaris 10 installation to a newer release.

I've just checked a S10u6 installation, and the missing FcFreeTypeQueryFace function is defined in /usr/lib/libfontconfig.so.1 and /usr/lib/64/libfontconfig.so.1

The same should work with an SX:DE installation; upgrade to a current SX:CE release. E.g. in SX:CE b111 I see:

$ /usr/ccs/bin/nm -p /usr/lib/64/libfontconfig.so.1 | grep FcFreeTypeQueryFace 00000000000000103536 T FcFreeTypeQueryFace

comment:6 Changed 5 years ago by daniel.vergien

O.K. but the the user manual should be updated. On page 16 it says: "Solaris 10 (u4 and higher)"

comment:7 Changed 5 years ago by jkeil2

That's true.

And it also tells us that on opensolaris, build 86 or newer is required (so the original poster kgerdas should definitely upgrade). Not sure if build 86 really has the required FcFreeTypeQueryFace function, but opensolaris build 101b has it.

comment:8 Changed 4 years ago by ramshankar

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use