VirtualBox

Ticket #3892 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

FWKERN.EXE error during installation of version 2.2.2 => Fixed in SVN

Reported by: kirpi Owned by:
Priority: major Component: installer
Version: VirtualBox 2.2.2 Keywords: fwkern.exe, installation failure
Cc: Guest type: other
Host type: Windows

Description

Hello,

I have tried to install VirtualBox 2.2.2 on both Windows Vista Home Premium and Ultimate editions. The installer gets stuck with giving this error:

The application "FW-1 Network Configuration (fwkern.exe)" needs to be closed for the installation to continue. 
Retry/Cancel
  • I only have Checkpoint SmartConsole and Securemote installed. But neither are running, nor the services are started (all services are at manual).
  • The installation file is: VirtualBox-2.2.2-46594-Win.exe
  • Before starting the installation, there is no fwkern.exe process. (Of course I am looking at all users' processes)
  • I use UAC but when asked, I allow the installation the proceed.
  • I leave all default components checked (i.e. I try to install both USB and Networking components).
  • The previous version is uninstalled already and the respective %ProgramFiles% folder is deleted also.
  • I'm asked twice to trust Sun Microsystems based components and I click "install".
  • fwkern.exe process isn't present in my system before installation.
  • Half way in installation process, a fwkern.exe process appears running as the SYSTEM user and then I get the error mentioned above.
  • The proccess can't be killed.
  • When I click cancel, installer tries to roll back the changes, raises the same error mentioned above once more, I click cancel again and it gets stuck indefinitely.
  • When I kill the installer process manually, fwkern.exe process disappears.

Best, Kirpi

Change History

comment:1 Changed 5 years ago by misha

What VBox Version did you have installed before?

comment:2 Changed 5 years ago by kirpi

It was 2.2.0. However, I cleaned the computer of any traces of that version as good as I can. Installation continues until even the Virtualbox starts but it cannot get past this error and rolls back everything.

I will try to kill the installer when it asks me about FWKERN.EXE and then try if this version works.

comment:3 Changed 5 years ago by kirpi

I have managed to install v2.2.2 by killing FWKERN.EXE process several times (running a command prompt as the system user). Virtualbox seems to work nicely now.

I never select "Always trust content from this publisher" during installation of virtual hardware. That might be the reason why installation fails. It seems like, the installer cannot show the prompt for some of the new hardware to be installed.

Just a guess, but could somebody else try installing without selecting "always trust" option.

Best, Kirpi

comment:4 Changed 5 years ago by supertix

hi kirpi! i have the same issue. but i'm not able to stop fwkern.exe process!! i've tried with task manager, taskkill from prompt, process explorer, closing open handles.. how have you killed the process to continue installation?

however fwkern.exe is a module of checkpoint vpn securemote client which is in c:\program files\checkpoint\boot\modules. thanks for the help

p.s. i've tried with and without "always trust" option but it works the same.

comment:5 Changed 5 years ago by kirpi

hi supertix,

you have to run the task manager with the "Local System" account. The details of how to do that are very gory. I could provide you with some simple steps, use at your own risk however :)

  • Open an elevated command prompt, and type in the following commands:
sc delete testsvc
sc create testsvc binpath= "taskmgr" type= own type= interact
sc start testsvc

you can disregard the error message. a moment later, you will be asked a question ("a program can't display a message on your desktop"). Click "Show me the message" and then you will be taken to the local system's desktop with the task manager running. than you can use it to open a command prompt via File -> New Task (Run...) -> cmd. There you can issue commands as the System account. You use this command:

taskkill /IM FWKERN.EXE /F

to kill the process. however, you will see that it doesn't get really killed. that's not really a problem. you can return to your original desktop and check if any questions are asked by then. continue with the installation.

comment:6 Changed 5 years ago by supertix

hi kirpi, i have done all steps but it doesnt work anyway. i opened the local system's desktop and i killed the process from a command prompt. the process doesn't really killed as you right told me. then i returned to my desktop and i clicked on "retry" button, but installation continue to say me that the process cant continue with fwkern.exe active!!

i have to unistall the checkpoint client, and then reinstall it after virtual box installation??

comment:7 Changed 5 years ago by alyssonf

Some problem with mee too. I have done all steps too, but don't work. The some problem. Such a complicated issue in a final version. Any response on this?

comment:8 Changed 5 years ago by misha

We should have a fix for this issue and I'll be able to provide a test build with a fix tomorrow.
The issue is specific to the Check Point VPN client, that's why we did not see this issue since none of is using this software here.

comment:9 Changed 5 years ago by misha

To all seeing the installation issue caused by fwkern.exe: please send me a mail at Mikhail dot Sennikovsky at sun dot com. I'll then send you a link to a new test version that should fix this issue.

comment:10 Changed 5 years ago by kirpi

@supertix

i actually have killed the process more than once. it was about a dosen times i've run the command I gave you. I think only then I didn't need to hit retry..

I'll mail misha and try to re-install with his/her release on the other hand :)

best,

comment:11 Changed 5 years ago by supertix

i have solve with misha test version! it works fine now! :) thanks a lot for support!

comment:12 Changed 5 years ago by frank

  • Summary changed from FWKERN.EXE error during installation of version 2.2.2 to FWKERN.EXE error during installation of version 2.2.2 => Fixed in SVN

Thank you for the feedback.

comment:13 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use