VirtualBox

Ticket #3893 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

Description field with national chars gets mangled

Reported by: baf Owned by:
Priority: trivial Component: GUI
Version: VirtualBox 2.2.2 Keywords:
Cc: Guest type: other
Host type: other

Description

Description field in gui gets progressively mangled. Probably at upgrades.

The text started as: ubuntu på fysisk disk Which correctly is stored as: Xubu_phys.xml: <Description>ubuntu p&#xE5; fysisk disk</Description>

Some upgrades later: Xubu_phys.xml.1.6-macosx.bak: <Description>ubuntu p&amp;amp;amp;amp;amp;amp;amp;#xE5; fysisk disk</Description>

Now: Xubu_phys.xml.really_wrong: <Description>ubuntu p&amp;amp;amp;amp;amp;amp;amp;amp;amp;amp;amp;amp;amp;#xE5; fysisk disk</Description>

To me it looks like upgrade encodes the text without first decoding it. I'm running on OsX 10.5

Change History

comment:1 Changed 5 years ago by frank

  • Component changed from other to GUI

comment:2 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Is this still an issue? Can't reproduce the problem here (although with VBox 3.0.6). Please reopen if necessary.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use