VirtualBox

Ticket #3870 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

smb access in bridged mode not possible => Fixed in SVN

Reported by: main Owned by:
Priority: critical Component: network/hostif
Version: VirtualBox 2.2.2 Keywords: samba bridged
Cc: Guest type: Windows
Host type: Linux

Description

Since 2.2.2 Im not able to access a samba share on the HOST Machine from the GUEST if I use bridged mode. Problem occurs only in bridged networking mode and if the Host is also the samba server. Samba Shares from other machines are possible to access. Could reproduce this problem on 3 machines with xp / 2k3 / 2k8 as guests

Attachments

VBox.log Download (43.1 KB) - added by main 5 years ago.
vbox_wireshark_dump Download (3.9 KB) - added by SeaGreenSky 5 years ago.
Wireshark SSH and HTTP dump

Change History

Changed 5 years ago by main

comment:1 Changed 5 years ago by main

Just saw this in dmesg:

VBoxDrv: dbg - g_abExecMemory=ffffffffa086bd80 vboxdrv: fAsync=0 offMin=0x4a6 offMax=0x107e6 vboxdrv: TSC mode is 'synchronous', kernel timer mode is 'normal'. vboxdrv: Successfully loaded version 2.2.0 (interface 0x000a0009). VBoxNetFlt: dbg - g_abExecMemory=ffffffffa01a8960

comment:2 Changed 5 years ago by frank

The 'dmesg' text is no problem, however, didn't you install the kernel modules of the 2.2.2 release? And, are you sure that your host firewall doesn't block these connections?

comment:3 Changed 5 years ago by main

Firewalls are deactivated. Modules compiled correct. Worked fine in 2.2.0

comment:4 Changed 5 years ago by main

Sry forgot to say, the smb folder gets listed correct. But opening files or changing folder is impossible. It seems that the connection is very very slow.

comment:5 Changed 5 years ago by main

[bastian@pcis-bbri ~]$ modinfo vboxdrv
filename:       /lib/modules/2.6.29-ARCH/misc/vboxdrv.ko
version:        2.2.2 (0x000a0009)
license:        GPL
description:    VirtualBox Support Driver
author:         Sun Microsystems, Inc.
srcversion:     CD996022C112438DD30F338
depends:
vermagic:       2.6.29-ARCH SMP preempt mod_unload
parm:           force_async_tsc:force the asynchronous TSC mode (int)
[bastian@pcis-bbri ~]$ modinfo vboxnetflt
filename:       /lib/modules/2.6.29-ARCH/misc/vboxnetflt.ko
version:        2.2.2 ((0xA2CDe001U))
license:        GPL
description:    VirtualBox Network Filter Driver
author:         Sun Microsystems, Inc.
srcversion:     9FBD2A8271C29D04E388594
depends:        vboxdrv
vermagic:       2.6.29-ARCH SMP preempt mod_unload
[bastian@pcis-bbri ~]$

comment:6 Changed 5 years ago by main

Just converted vdi 2 vmdk and tried with vmware workstation -> No Problems

comment:7 Changed 5 years ago by frank

Does it make any difference if you select E1000 as guest network device emulation (VM settings)?

comment:8 Changed 5 years ago by main

No doesn't help. Same problem with all adapters!

comment:9 Changed 5 years ago by main

Sry to say, I switched to vmware. The network stack is horrible since 2.* only got problems. Will try it again, keep working on it. You guys have done a great job so far, but it's to unstable for productive use.

comment:10 Changed 5 years ago by frank

  • Component changed from network to network/hostif

comment:11 Changed 5 years ago by frank

Still not able to reproduce, though not using ArchLinux but Debian/Lenny with 2.6.29.2 here. Tried with the generic .run package which you used as well. Works fine on two different hosts (both Lenny, one 32-Bit, one 64-Bit). There are two points to keep in mind:

  1. The firewall at the host (switch off if in doubt, you said that you already did that).
  2. Make [homes] / browseable = yes in /etc/samba/smb.conf.

comment:12 Changed 5 years ago by mrlogic

Same problem here, wasn't there before upgrading to 2.2. On my computer shares on other machines in the network are affected to. Host is Debian GNU/Linux (unstable) with 2.6.29-1-amd64, guest is Windows XP Pro SP3. Access is very very slow, the first attempt to list share content succeeds after almost a minute, further attempts are canceled by a timeout.

comment:13 Changed 5 years ago by frank

mrlogic, did you ever test 2.2.0? I'm trying to find out if this is a 2.2.0 regression or a 2.2.2 regression. And, which host network card do you have?

comment:14 Changed 5 years ago by mrlogic

Problem was first there when I upgraded to 2.2.0. My Host network card is an onboard nvidia (NVIDIA nForce® 570 Ultra™ MCP built-in Gigabit MAC with external Marvell PHY).

comment:15 Changed 5 years ago by main

If i remember correct the problem did not exist in 2.2.0

comment:16 Changed 5 years ago by frank

main, I saw that you are using a 2.6.29 kernel. We just found that 2.6.29.2 has a fix gso: Fix support for linear packets which fixes some performance issues. Though this doesn't sound to be related to your problem, could you please anyway check if upgrading to at least 2.6.29.2 or later does fix your problem by any chance?

comment:17 Changed 5 years ago by vvs

Same problem here. As soon as I upgraded from 2.2.0 to 2.2.2, I can't seem to connect to my host Windows Vista system from the guest Linux system (in bridged mode). Even pings don't work.

Once I disable the Windows Firewall, the pings are back, and the samba access from guest to host is restored. But I don't want to completely disable the Windows Firewall, and wasn't able to find any other way to make everything work.

With enabled Windows Firewall, I easily can connect from host to guest samba shares, but not vise versa.

Please note that in VB 2.2.0 there were NO SUCH PROBLEM, and access in both ways was OK, even with enabled Windows Firewall...

Changed 5 years ago by SeaGreenSky

Wireshark SSH and HTTP dump

comment:18 Changed 5 years ago by SeaGreenSky

I'm seeing the same problem - The host (192.168.1.20, CentOS 5.3 64bit, 2.6.18-128.1.10.el5) can ping the guest (192.168.1.100, OpenBSD 4.5 64bit), and the guest can ping the host. I can telnet from the host->guest and from the guest->host on port 22, 25, etc. but cannot ssh or http in either direction. I can ssh and http to/from the guest from/to other hosts on the network without a problem.

If you look at the attached vbox_wireshark_dump you will see entries for bad checksum for ssh & http (from the host to the guest).

I tested 2.2.0 and 2.2.0 on same box, same host OS, with the same result. I wonder which platform - 32bit or 64bit - Frank tested "Debian/Lenny with 2.6.29.2" on, or if this is a kernel version problem.

comment:19 Changed 5 years ago by frank

Still not able to reproduce. What happens if you are using the host interface (vboxnet0) instead of the bridged interface? Still not able to connect? Btw, when talking about disabling the firewall I talk about the firewall at the Linux host, not the guest.

comment:20 Changed 5 years ago by frank

ws, your problem is different because you are talking about a Windows host. SeaGreenSky, did this every work for you with an earlier version?

comment:21 Changed 5 years ago by frank

Finally was able to reproduce this problem with a CentOS 5.3 host. The access works well from a remote host and it works as well over NAT (use \10.0.2.2 to access the host from the guest) as well over host-only networking. But when doing this over bridged networking, the guest connection times out.

comment:22 Changed 5 years ago by frank

Workaround which works here:

/sbin/ethtool -K eth0 tx off

on the host. Can someone confirm that? We will try to fix this properly.

comment:23 Changed 5 years ago by SeaGreenSky

I tested both 2.2.0 (r45846) and 2.2.2 (r46594) on CentOS 5.3 64bit with current updates and both worked fine for ssh and http, both host->guest and guest->host. Wireshark is totally clean during the sessions, I don't see any 'Bad Checksum' packets at all.

Frank, thank you very much for finding a resolution to this. Now I can migrate my VMware VM's :-)

comment:24 Changed 5 years ago by frank

  • Summary changed from smb access in bridged mode not possible to smb access in bridged mode not possible => Fixed in SVN

A better fix: Please have a look at  this defect. This should properly fix the problem. Feedback welcome.

comment:25 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use