VirtualBox

Ticket #377 (closed defect: invalid)

Opened 7 years ago

Last modified 6 years ago

NAT net: DNS not working after net failure

Reported by: xerces8 Owned by:
Priority: major Component: other
Version: VirtualBox 1.3.8 Keywords:
Cc: Guest type: other
Host type: other

Description

vbox 1.3.8 on winXPproSP2

I started a VM (with NAT networking, OS is Ubuntu 7.04), while the host had no network connection. Then I connected the host and networking on the host worked. But in the guest it did not. It turns out, that outgoing TCP connections work, but only to numerical IP addresses. DNS resolving on the other hand not. Tried a manual "nslookup some.server.com" and it failed. The TCP/IP parameters in the VM were correct :

  • address 10.0.2.15
  • gateway 10.0.2.2
  • DNS server : 10.0.2.3

I did not try an external DNS server.

After restarting vbox it still did not work. Only after restarting the host it started to work.

Change History

comment:1 Changed 7 years ago by klaus

This is not caused by some resident part of VirtualBox (as those don't deal with this kind of networking parameters at all).

This seems to be some issue with getting an up-to-date DNS server without a reboot of Windows. Apparently the Windows API we're using (GetNetworkParams) returns nothing useful until that reboot. Likely more a Windows issue than a VBox issue, but I don't have time to look into this right now.

A release log from the VirtualBox 1.4.0 (out soon) would help greatly finding out what really goes wrong.

comment:2 Changed 6 years ago by frank

  • Status changed from new to closed
  • Resolution set to invalid

No response for months, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use