VirtualBox

Ticket #378 (closed defect: fixed)

Opened 7 years ago

Last modified 4 years ago

Won't Install with New Linux Kernel

Reported by: adma Owned by:
Priority: major Component: other
Version: VirtualBox 1.3.8 Keywords:
Cc: Guest type: other
Host type: other

Description

With the recent kernel update patched through in Ubuntu (2.6.20-16), Vbox no longer will run. It ran fine with 2.6.20-15 and I have since reinstalled Ubuntu from scratch to ensure I did not have a dependency issue. Thank you for your time, below is the error message I get:

make KBUILD_VERBOSE=1 -C /lib/modules/2.6.20-16-generic/build SUBDIRS=/tmp/vbox.1 SRCROOT=/tmp/vbox.1 modules gcc: Internal error: Segmentation fault (program cc1) Please submit a full bug report. See <URL:http://gcc.gnu.org/bugs.html> for instructions. For Debian GNU/Linux specific bug reporting instructions, see <URL:file:///usr/share/doc/gcc-4.1/README.Bugs>.

gcc: Internal error: Segmentation fault (program cc1) Please submit a full bug report. See <URL:http://gcc.gnu.org/bugs.html> for instructions. For Debian GNU/Linux specific bug reporting instructions, see <URL:file:///usr/share/doc/gcc-4.1/README.Bugs>.

make[1]: Entering directory `/usr/src/linux-headers-2.6.20-16-generic'

test -e include/linux/autoconf.h -a -e include/config/auto.conf
( \

echo; \ echo " ERROR: Kernel configuration is invalid."; \ echo " include/linux/autoconf.h or include/config/auto.conf are missing."; \ echo " Run 'make oldconfig && make prepare' on kernel src to fix it."; \ echo; \ /bin/false)

mkdir -p /tmp/vbox.1/.tmp_versions rm -f /tmp/vbox.1/.tmp_versions/* make -f scripts/Makefile.build obj=/tmp/vbox.1

gcc -Wp,-MD,/tmp/vbox.1/linux/.SUPDrv-linux.o.d -nostdinc -isystem /usr/lib/gcc/i486-linux-gnu/4.1.2/include -DKERNEL -Iinclude -include include/linux/autoconf.h -Iubuntu/include -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -O2 -pipe -msoft-float -mregparm=3 -march=i586 -ffreestanding -maccumulate-outgoing-args -Iinclude/asm-i386/mach-default -fomit-frame-pointer -g -I/lib/modules/2.6.20-16-generic/build/include -I/tmp/vbox.1/ -I/tmp/vbox.1/include -I/tmp/vbox.1/r0drv/linux -DKERNEL -DMODULE -DLINUX -DIN_RING0 -DIN_RT_R0 -DIN_SUP_R0 -DCONFIG_VBOXDRV_AS_MISC -DX86 -DMODULE -D"KBUILD_STR(s)=#s" -D"KBUILD_BASENAME=KBUILD_STR(SUPDrv_linux)" -D"KBUILD_MODNAME=KBUILD_STR(vboxdrv)" -c -o /tmp/vbox.1/linux/.tmp_SUPDrv-linux.o /tmp/vbox.1/linux/SUPDrv-linux.c

gcc: Internal error: Segmentation fault (program cc1) Please submit a full bug report. See <URL:http://gcc.gnu.org/bugs.html> for instructions. For Debian GNU/Linux specific bug reporting instructions, see <URL:file:///usr/share/doc/gcc-4.1/README.Bugs>.

make[2]: * tmp/vbox.1/linux/SUPDrv-linux.o Error 1 make[1]: * [_module_/tmp/vbox.1] Error 2 make[1]: Leaving directory `/usr/src/linux-headers-2.6.20-16-generic' make: * [vboxdrv] Error 2

Change History

comment:1 Changed 7 years ago by frank

Which Ubuntu version are you using? Could you try to update your host at first? We cannot do much against internal compiler errors...

comment:2 Changed 7 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

No reaction for a month. Closing.

comment:3 Changed 4 years ago by svil

just for the record: i got into same situation, after upgrading to gcc4.4, on kernel 2.6.31-17 (and -16 and probably all else). As a remedy, i found that changing the optimization level from -O2 to -O1 makes gcc happy so it won't die. in /usr/src/linux-headers-2.6.31-17-generic/Makefile find this line (about 533) KBUILD_CFLAGS += -O2 and change to -O1 then /etc/init.d/vboxdrv setup would succeed. a workaround until gcc gets fixed..

comment:4 Changed 4 years ago by frank

This is not a bug of VirtualBox. gcc must be the same version which was used for compiling the Linux kernel, otherwise the new modules will not fit.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use