VirtualBox

Ticket #3733 (closed defect: fixed)

Opened 5 years ago

Last modified 3 years ago

VERR_SUPDRV_INTERFACE_NOT_SUPPORTED with bridged networking

Reported by: andyesten Owned by:
Priority: major Component: network
Version: VirtualBox 2.2.0 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

Installed VirtualBox 2.2 on Ununtu 9.04. When configuering a VM with bridged networking I get the following error:

Failed to start the virtual machine Test. Failed to open/create the internal network 'HostInterfaceNetworking-br0' (VERR_SUPDRV_INTERFACE_NOT_SUPPORTED). Unknown error creating VM (VERR_SUPDRV_INTERFACE_NOT_SUPPORTED).

Attachments

VBox.log Download (30.5 KB) - added by andyesten 5 years ago.
dmesg.txt Download (37.6 KB) - added by i5513 5 years ago.
dmesg
dmesg.2.txt Download (49.1 KB) - added by ktec 5 years ago.
vbox-install.log Download (1.7 KB) - added by ktec 5 years ago.
ktec-vb22.txt Download (1.2 KB) - added by ktec 5 years ago.
ktec-vbose.txt Download (1.5 KB) - added by ktec 5 years ago.
vbox-install.2.log Download (1.5 KB) - added by ktec 5 years ago.

Change History

Changed 5 years ago by andyesten

comment:1 Changed 5 years ago by frank

Please attach the following:

  • the output of dmesg
  • the output of lsmod|grep vbox
  • the file /var/log/vbox-install.log

comment:2 Changed 5 years ago by i5513

Idem in debian sid with 2.6.29 and vbox 2.2.0

I'm attaching dmesg and lsmod, vbox-install.log is not in debian (any equiv?)

Changed 5 years ago by i5513

dmesg

comment:3 Changed 5 years ago by i5513

lsmod | grep vbox: vboxnetflt 68360 0 vboxdrv 90776 2 vboxnetflt

I can't attach lsmod | grep vbox in this ticket, trac tells me:

Oops… Trac detected an internal error:

If you think this really should work and you can reproduce it, you should consider reporting this problem to the Trac team.

Go to  http://trac.edgewall.org/ and create a new ticket where you describe the problem, how to reproduce it. Don't forget to include the Python traceback found below.

TracGuide — The Trac User and Administration Guide Python Traceback

Traceback (most recent call last):

File "/var/lib/python-support/python2.5/trac/web/main.py", line 387, in dispatch_request

dispatcher.dispatch(req)

File "/var/lib/python-support/python2.5/trac/web/main.py", line 237, in dispatch

resp = chosen_handler.process_request(req)

File "/var/lib/python-support/python2.5/trac/attachment.py", line 361, in process_request

self._do_save(req, attachment)

File "/var/lib/python-support/python2.5/trac/attachment.py", line 450, in _do_save

size = upload.file.len

AttributeError: 'cStringIO.StringO' object has no attribute 'len'

comment:4 Changed 5 years ago by frank

i5513, you said you are using VBox 2.2.0 but the kernel module which is loaded is 2.1.4_OSE. Please could you ensure that the correct kernel modules are loaded? I assume that you need to uninstall the VBox OSE kernel headers as these headers contain an udev rule which loads the 2.1.4_OSE kernel modules. I assume the same happens for andyesten.

comment:5 Changed 5 years ago by i5513

Ok, Sorry for the noise

I installed virtualbox-ose-modules-2.6.29-1-686 from repository and it didn't work, but I had to m-a ai virtualbox-ose and then it works again

Thanks you!

comment:6 Changed 5 years ago by andyesten

Nope, checked using the correct kernel module. Reverted to version VirtualBox 2.1.

Andy

comment:7 Changed 5 years ago by frank

Andy, if you submit the information I've asked you in my first reply we could probably help you. Otherwise I have to close this bug, except if other users report the same problem.

comment:8 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

Please reopen this bug if you can provide the information I requested.

comment:9 Changed 5 years ago by ktec

  • Status changed from closed to reopened
  • Resolution worksforme deleted

I get this problem...

keith@keith-laptop:~$ lsmod | grep vbox vboxnetflt 91016 0 vboxdrv 117544 2 vboxnetflt

Will attach the other requested files.

Changed 5 years ago by ktec

Changed 5 years ago by ktec

comment:10 Changed 5 years ago by frank

ktec, although the installation seems to be correct, an vboxdrv module 2.1.4 is loaded when your computer starts. Which VBox package (exact package name please) did you install? And did you previously install any older version of VBox?

comment:11 Changed 5 years ago by frank

Hmm, the 2.1.4 vboxdrv module is OSE. Did you install virtualbox-ose-source and compiled the vboxdrv module yourself? Please do

sudo su -
find /lib/modules -name vbox\* | xargs rm -i
/etc/init.d/vboxdrv setup

After you confirmed to remove any vboxdrv.ko and vboxnetflt.ko modules, they should be properly re-created and you should be able to use bridged networking again.

comment:12 Changed 5 years ago by ktec

Great, first command work so i've deleted the module again now, however the second command doesn't because the file doesnt exist. This is exactly what got me into this mess in the first place. Yes i have installed previous version, and ose version. I've tried god know what to remove ABSOLUTELY everything to do with virtual box and do a completely clean install, with that vboxdrv file, but NOTHING works.

Any suggestions?

comment:13 Changed 5 years ago by frank

I would still like to know which package (exact name please) you installed.

If /etc/init.d/vboxdrv does not exist then you probably installed the wrong package.

comment:14 Changed 5 years ago by ktec

I'm afriad you'll have to guide to that answer, i have number of different installation sources, from the .deb package here to apt-get, and the synaptic gui.

comment:15 Changed 5 years ago by frank

What is the output of

dpkg -s virtualbox-2.2

and what is the output of

dpkg -s virtualbox-ose

?

comment:16 Changed 5 years ago by ktec

Have attached the outputs... Can you let me know which would be the right package to install?

Changed 5 years ago by ktec

Changed 5 years ago by ktec

comment:17 Changed 5 years ago by ktec

Now i can't run ANY of the VM's, they all ask me to run /etc/init.d/vboxdrv setup which i dont have any no 'googling' suggests how to fix. Please reply soon, my work is due yesterday...

comment:18 Changed 5 years ago by frank

Please do the following:

sudo su -
dpkg --purge virtualbox-ose
apt-get install --reinstall virtualbox-2.2

Then you should be able to start your VMs again. Your problem was that you somehow managed it to install virtualbox-ose together with virtualbox-2.2. Don't mix these two packages.

comment:19 Changed 5 years ago by ktec

Thanks Frank,

The reason i ended up like that is because no matter how many times i tried i could not get the packages to install the "/etc/init.d/vboxdrv" script. I tried the ose version as an alternative solution, which obviously didnt help either.

Since doing this, i now see errors in my boot log talking about load kvm module failing. Research suggests its compiled into the kernel, is this a result of installing virtualbox kernel driver stuff?

Is there a way to totally clean my system of all virtualbox stuff - including to the recompiled kernel and roll back to my system before all this, then perhaps i can start again?

Am trying what you've suggested now, so i'll post back when its done...

comment:20 Changed 5 years ago by ktec

Ok, i have followed instructions, and rebooted, and i'm still exactly where i was before. VM's wont load, asking for vboxdrv which isn't there. Something called DRM (or similar) shows something to do with kernel/vboxdrv stuff on boot but i don't know what. Do you know where i can look to find out this information to show you? Or do i need to reboot and write it down by hand?

keith@keith-laptop:~$ sudo /etc/init.d/vboxdrv
[sudo] password for keith: 
sudo: /etc/init.d/vboxdrv: command not found

comment:21 Changed 5 years ago by frank

Your installation is somehow broken. Please repeat (all as root of course)

apt-get install --reinstall virtualbox-2.2

and then do

/bin/ls -l /etc/init.d/vboxdrv

That script must be there.

comment:22 Changed 5 years ago by ktec

So here is the bash log:

keith@keith-laptop:/$ sudo apt-get install --reinstall virtualbox-2.2
[sudo] password for keith: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
Need to get 0B/38.7MB of archives.
After this operation, 0B of additional disk space will be used.
Do you want to continue [Y/n]? Y
Preconfiguring packages ...
(Reading database ... 151457 files and directories currently installed.)
Preparing to replace virtualbox-2.2 2.2.2-46594_Ubuntu_intrepid (using .../virtualbox-2.2_2.2.2-46594%5fUbuntu%5fintrepid_i386.deb) ...
Unpacking replacement virtualbox-2.2 ...
Setting up virtualbox-2.2 (2.2.2-46594_Ubuntu_intrepid) ...
addgroup: The group `vboxusers' already exists as a system group. Exiting.
Messages emitted during module compilation will be logged to /var/log/vbox-install.log.
Success!

keith@keith-laptop:/$ /bin/ls -l /etc/init.d/vboxdrv
/bin/ls: cannot access /etc/init.d/vboxdrv: No such file or directory

I'll attach that vbox-install.log too if it helps.

thanks

Changed 5 years ago by ktec

comment:23 Changed 5 years ago by ktec

Is it possible the dkms is blocking it or something?

comment:24 Changed 5 years ago by frank

I doubt that. Still entirely unclear why /etc/init.d/vboxdrv is not there. That script is definitely included in the package. Does the directory /etc/init.d exist?

comment:25 Changed 5 years ago by ktec

Yep, that directory is definitely there...

I'm going to try touching the file /etc/init.d/vboxdrv and then re-install again. Will let you know if that works.

Is there a way i get remove all this stuff from my machine (including the recompiled kernel), without re-installing the os?

comment:26 Changed 5 years ago by ktec

Nope, that doesnt make a difference

comment:27 Changed 5 years ago by ktec

ok, so i chmoded that file and tried again, and now i get this message on install:

Messages emitted during module compilation will be logged to /var/log/vbox-install.log.
Success!
update-rc.d: warning: /etc/init.d/vboxdrv missing LSB information
update-rc.d: see <http://wiki.debian.org/LSBInitScripts>

comment:28 Changed 5 years ago by ktec

Really i think i need to strip everything to do with vbox off this machine and start again. Unfortunately this is my desktop so i can't possibly consider reinstalling the os to fix it though.

comment:29 Changed 5 years ago by ktec

looking at that, shouldn't i have a load of things in the run levels too, ie /etc/rc0.d/blah?

comment:30 Changed 5 years ago by frank

The runlevel scripts in /etc/rcX.d/ are linked into /etc/init.d. You can remove the whole stuff with

dpkg --purge virtualbox-2.2
find /lib/modules -name vbox\* | xargs rm -i

comment:31 Changed 5 years ago by ktec

Ok, good news is that i followed your advice here again, rebooted, searched and checked there was no trace, and now when i run the package installer i get the prompt asking about installing the kernel business. Going for another reboot now, so i'll let you know.

comment:32 Changed 3 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Looks like this is obsolete.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use