VirtualBox

Ticket #3732 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Incorrect amount of computer memory detected on host system -> fixed in SVN/3.0.8

Reported by: rburkey Owned by:
Priority: major Component: GUI
Version: VirtualBox 2.2.0 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

I am using a Fedora Core 5 host with 1GB of RAM. Guest systems, which are assigned 256M-384M of RAM, boot up and run well. However, I am unable to change the settings on any virtual machine unless I directly edit the XML files containing the settings. Whenever I try to change settings from within the VirtualBox GUI, I immediately see this message:

"On the General page, you have assigned more than 75% of your computer's memory (0 B) to the virtual machine. Not enough memory is left for your host operating system. Please select a smaller amount."

The virtual machine whose settings I was trying to modify is then marked "Inaccessible" and no virtual machines can be started until after the VirtualBox GUI is restarted. Similarly, I cannot create new virtual machines within the GUI, because it indicates that I have 0MB of RAM.

I don't know if it is a related issue or not, but if I try to change the CD/DVD associated with a running guest system using the Devices menu, I get the error message "Failed to open the CD/DVD image", along with "Callee RC: NS_ERROR_FAILURE (0x80004005)".

I should explain that I have been unable to change the virtual-machine settings from the GUI in all versions of VirtualBox since ~1.5, but I used to get the 0x80004005 message instead of the 0MB message. Since there were a lot of suggestions out on the web for dealing with the 0x80004005 message, I concentrated on trying those suggestions (even though none of them ever worked) rather than filing a ticket. But I haven't been able to get any hits googling for the 0MB problem, so I assume it must be a new one.

Change History

comment:1 Changed 5 years ago by frank

Strange problem. First, you don't need to change the memory setting by directly editing the .xml file but you can use VBoxManage modifyvm as well.

Furthermore, please could you check if the VBoxSVC daemon crashes when you are trying to change the settings? To do so, please do in a terminal

/opt/VirtualBox/VBoxSVC

and, in another terminal

VirtualBox

Then try to change the RAM setting. Is the VBoxSVC process still alive? If not, could you send me a  core dump? (In that case, contact me via E-mail at frank _dot_ mehnert _at_ sun _dot_ com.

comment:2 Changed 5 years ago by michael

Could you look on your system for libdus-1.so.*, and if you find it add the exact file names found to this ticket?

comment:3 Changed 5 years ago by rburkey

No, there is no libdus* on my system.

comment:4 Changed 5 years ago by rburkey

Also, here are the relevant responses to the questions Frank asked, and which I sent directly to him rather than adding them as comments earlier:

  1. Using VBoxManage did work fine.
  1. VBoxSVC did crash, with the message:

Informational: VirtualBox object created (rc=00000000). 22970: assertion failed "!_dbus_transport_get_is_connected (connection->transport)" file "dbus-connection.c" line 1797 function _dbus_connection_last_unref Aborted

comment:5 Changed 5 years ago by rburkey

If perchance what was meant was libdbus, then here are all the different variations I find:

/lib/libdbus-1.so.2 /lib/libdbus-1.so.2.0.0 /usr/lib/libdbus-1.so /usr/lib/libdbus-glib-1.so /usr/lib/libdbus-glib-1.so.2 /usr/lib/libdbus-glib-1.so.2.0.0

comment:6 Changed 5 years ago by frank

Btw,  here is a Fedora Core 5 repository.

comment:7 Changed 5 years ago by michael

Sorry, typ: I meant libdbus-1.so.* - but the link provided by Frank answers my question.

comment:8 Changed 5 years ago by michael

Not to mention your next reply which I missed :)

comment:9 Changed 5 years ago by rburkey

I had libdbus 0.61 installed, as Frank's link implied, but then updated to 0.62 and tried VirtualBox again. There was no change. 0.62 is the last version in the local FC5 repository I keep here.

comment:10 Changed 5 years ago by michael

I assume that this is something that needs to be fixed in VirtualBox. We will do that.

comment:11 Changed 5 years ago by michael

  • Summary changed from Incorrect amount of computer memory detected on host system to Incorrect amount of computer memory detected on host system -> fixed in SVN

This should be fixed in the SVN version of VirtualBox.

comment:12 Changed 5 years ago by rburkey

Thanks! (Since you release new versions so often, I'll wait for the next release to try it.)

comment:13 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

comment:14 Changed 5 years ago by elmo

  • Status changed from closed to reopened
  • Resolution fixed deleted

I have the exact same problem, but with VirtualBox 3.0.4. When I go into the settings of VM I get:

On the System page, you have assigned more than 75% of your computer's memory (0 B) to the virtual machine. Not enough memory is left for your host operating system. Please select a smaller amount.

What's strange before I go to settings under Help->About VirtualBox... at the bottom there is:

VirtualBox Graphical User Interface
Version 3.0.4 r50677

But after I go into VM's settings and then click Help->About VirtualBox... at the bottom I get:

VirtualBox Graphical User Interface
Version r0

Also after closing Settings dialog I cannot reenter it as positions in Machine menu are all greyed out except New and Show log.

Also when I try to start VM (I can click on Start if I haven't touched the Settings) it opens VM window, displays info about how to leave VM and when I click to close this dialog it freezes my system immediately. The only thing I can do after that is push reset button on my PC.

I don't quite get why in Settings it can't get the avaible amount of RAM, but VBoxManage can:

$ VBoxManage list hostinfo
VirtualBox Command Line Management Interface Version 3.0.4
(C) 2005-2009 Sun Microsystems, Inc.
All rights reserved.

Host Information:

Host time: 2009-08-28T09:47:20.493000000Z
Processor online count: 2
Processor count: 2
Processor#0 speed: 1800 MHz
Processor#1 speed: 1800 MHz
Memory size: 1982 MByte
Memory available: 1696 MByte
Operating system: Linux
Operating system version: 2.6.28-hardened-r9

VBoxSVC + VirtualBox gives me:

$ /opt/VirtualBox/VBoxSVC
*****************************************
Sun VirtualBox XPCOM Server Version 3.0.4
(C) 2008-2009 Sun Microsystems, Inc.
All rights reserved.

Starting event loop....
[press Ctrl-C to quit]
Informational: VirtualBox object created (rc=00000000).
Segmentation fault

Segmentation fault appears when I enter Settings.

Info about my system:

$ uname -a
Linux ShellBullet 2.6.28-hardened-r9 #18 SMP Fri Aug 28 10:59:21 CEST 2009 x86_64 Intel(R) Core(TM)2 CPU 4300 @ 1.80GHz GenuineIntel GNU/Linux

I tried with PAX compiled in kernel and without it. I also tried:

$ echo 0 > /proc/sys/kernel/randomize_va_space

I tried it because g++ (4.3.4) crashed on some files and firefox did not start with randomize_va_space set to 1, so I though it may be worth try to check if it helps with VirtualBox, but it made no difference.

Version of dbus and hal as below:

$ emerge -pv dbus hal

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] sys-apps/dbus-1.3.0  USE="X -debug -doc (-selinux) -test" 0 kB
[ebuild   R   ] sys-apps/hal-0.5.13-r2  USE="X acpi crypt -apm -consolekit -debug -dell -disk-partition -doc -laptop -policykit (-selinux)" 0 kB

Modules that I have loaded:

$ lsmod
Module                  Size  Used by
vboxnetadp             81548  0 
vboxnetflt             87079  0 
vboxdrv              1689084  1 vboxnetflt
usbhid                 28266  1 
uhci_hcd               29080  0 
intelfb                37784  0 
ehci_hcd               46760  0 
i2c_algo_bit            4645  1 intelfb
i2c_core               14668  2 intelfb,i2c_algo_bit
usbcore               129184  5 usbhid,uhci_hcd,ehci_hcd

comment:15 Changed 5 years ago by frank

elmo, if you could send me a  core dump then we could probably find the reason. If you want to help please contact me via private E-mail at frank _dot_ mehnert _at_ sun _dot_ com.

comment:16 Changed 5 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

elmo, finally fixed the strange settings problem. The VBoxSVC daemon was indeed crashing when the settings dialog was openend. The cause for the crash was that /proc/net/route isn't accessible for normal users on a hardened build. This bug is fixed in SVN and the fix will be included in the next maintenance release. Therefore I will close this bug. Your other problem (host freeze when you start a VM) is a duplicate of #941. I can reproduce the freeze but only if VT-x/AMD-V is not available / disabled for a VM. With VT-x, the VM starts fine. We will investigate and try to fix this problem but this is a bit more difficult.

comment:17 Changed 5 years ago by sandervl73

  • Summary changed from Incorrect amount of computer memory detected on host system -> fixed in SVN to Incorrect amount of computer memory detected on host system -> fixed in SVN/3.0.8
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use