VirtualBox

Ticket #3677 (closed defect: fixed)

Opened 5 years ago

Last modified 2 years ago

VirtualBox 2.2.0 r45846 - Install Guest Additions Fails on Install after Revert snapshot XP Guest

Reported by: darkoth Owned by:
Priority: major Component: other
Version: VirtualBox 2.2.0 Keywords:
Cc: Guest type: other
Host type: other

Description

Host Ubuntu 8.10

I was running Virtualbox 2.1.4 and upgraded yesterday to the new release 2.2.0 r45846. I had a XP Snapshot and went into the GUI Settings, went to snapshots, and did a "Discard Current Snapshot and State". I then started the XP guest and logged in.

Then I went and clicked Devices-> Install Guest Additions and nothing happened. I went to Windows Explorer in the Guest and checked "My Computer" and usually I would see that they had mounted like a CD-ROM and run it manually from there. However they weren't there at all. I tried clicking on Install Guest Additions a few more times and still nothing.

My next step was to shutdown the XP Guest, went to Settings, CD/DVD-ROM section clicked the checkbox for "Mount CD/DVD Drive" and clicked ISO Image File and made sure the "VBoxGuestAdditions.iso" was selected and booted up....

I logged into the Guest XP box and went to Windows Explorer again and they weren't there again when they should have been... I again tried the manual "install guest additions from the Device menu and still nothing.

Change History

comment:1 Changed 5 years ago by darkoth

FYI - To work around this I burned a copy of the /usr/share/virtualbox/VBoxGuestAdditions.iso to a CD/RW disk and mounted the CD-ROM and had it install off the physical CD and installed that way. However, if I eject the CD, start the guest and login and try to use Devices->Install Guest Additions it still doesn't mount it... So the bug itself still isn't resolved.

comment:2 Changed 5 years ago by darkoth

Looking into this more...something is def wrong with the box itself after I did the discard current state in the snapshot... I'm not able to use IE inside the guest. It's like something went wrong with the revert. It was just a normal "XP Pro 32 bit" install with all the latest patches (SP3) and nothing else on it... I had built it the day before 2.2.0 came out and saved that snapshot...

comment:3 Changed 5 years ago by fullaxx

I have seen this problem on VirtualBox 3.0.2 and 3.0.4, on both the Windows and Linux platforms.

After I 'revert to current snapshot' I try to set the VBoxGuestAdditions.iso as the CDROM image, I hit OK, and nothing happens. I can mount any other iso, including a copy of VBoxGuestAdditions.iso renamed to something like VBoxGuestAdditions_2.iso. It seems to single out that iso by name after a 'revert'.

comment:4 Changed 5 years ago by fullaxx

I tried using the following VBoxManage command: VBoxManage modifyvm WinXP-RIP --dvd /opt/VirtualBox/additions/VBoxGuestAdditions.iso

and I get the following error:

ERROR: Could not find a CD/DVD image with UUID {00000000-0000-0000-0000-000000000000} in the media registry ('/home/fullaxx/.VirtualBox/VirtualBox.xml') Details: code VBOX_E_OBJECT_NOT_FOUND (0x80bb0001), component VirtualBox, interface IVirtualBox, callee nsISupports Context: "MountImage(uuid)" at line 1278 of file VBoxManageModifyVM.cpp

When I use any other iso image, the command completed successfully. This is an example of the "copy of" VBoxGuestAdditions completing successfully: VBoxManage modifyvm WinXP-RIP --dvd /opt/VirtualBox/additions/VBoxGuestAdditions_2.iso

I hope this helps.

comment:5 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 4.1.6.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use