VirtualBox

Ticket #3678 (closed defect: fixed)

Opened 6 years ago

Last modified 41 hours ago

vboxgueset does not provide quiesce() support

Reported by: spity Owned by:
Priority: minor Component: guest additions
Version: VirtualBox 2.2.0 Keywords:
Cc: sst-defect@… Guest type: other
Host type: Mac OS X

Description (last modified by frank) (diff)

During SST testing of OpenSolaris build 111 on virtualbox we found out that the kernel module vboxguest delivered as part of the guest additions does not implement the quiesce() callback. The kernel will then not allow fast-reboot (reboot -f).

Steps to reproduce: reboot -f dryrun dmesg | grep quiesce

Change History

comment:2 Changed 6 years ago by ramshankar

This functionality doesn't exist for Solaris 10u5 which happens to be a supported guest and since we build only one binary blob for both OpenSolaris and Solaris 10 systems quiescent support isn't included.

comment:3 Changed 41 hours ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
  • Description modified (diff)

I think this was added in VBox 5.0 / 4.3.30.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use