VirtualBox

Ticket #3676 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

Upgrade VirtualBox 2.2.0 from 2.1.4 - vm hangs after few minutes => pcnet problem

Reported by: thomi Owned by:
Priority: blocker Component: other
Version: VirtualBox 2.2.0 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

Hi vbox Team

i had today a big problem, cause i upgraded to vbox 2.2.0 one of my two vm stopps working after few minutes. Can't control can't do anything with it, need to kill the vm process on the host manually. Now i have reinstalled 2.1.4 and reconfigured my vm's and all works fine. My host is a Ubuntu 8.04 hardy, with kernel 2.6.24-23-generic, the affecting guest is a Ubuntu 8.04 server LTS with kernel 2.6.24-23-server. I have another guest (Ubuntu 8.04 kernel 2.6.24-23-generic) wthout problem in 2.2.0 or 2.1.4.

Attached are the vm settings and the logs from 2.2.0.

My host run's now on 2.1.4, cause the vm's must run..

Thanks for help thomi

Attachments

Machines_v2.2.0_save_20090409.zip Download (74.2 KB) - added by thomi 5 years ago.
v2.2.0 vm settings and logs

Change History

Changed 5 years ago by thomi

v2.2.0 vm settings and logs

comment:1 Changed 5 years ago by thomi

.. additional comment

The problem exists if vbox linux additions are installed or not..

thanks thomi

comment:2 Changed 5 years ago by Flancer

I get the same issue too when upgrading from 2.1.4 to 2.2.0 for my Ubuntu 8.0.4 guest.

My host is running Ubuntu Feisty Fawn though.

I didn't save my earlier config so I couldn't downgrade.

Changing the guest kernel from 2.6.24-23-server to 2.6.24-23-generic made my guest stable again.

comment:3 Changed 5 years ago by smichak

I´m having the same problem with 2.2.0 running a gentoo linux kernel 2.6.28-r4 guest on a windows XP SP3 host.

I noticed however it usually freezes during high networking workload. Changed the networking adapter from "PCNet-FAST III" to "Intel PRO/1000 MT Desktop" and now it seems to be working OK - +6 hours runtime with my usual networking workload and so far so good.

comment:4 follow-up: ↓ 5 Changed 5 years ago by vondralbra

I can confirm the observation of @smichak. The guest usually drops off during a peak in network IO. I'll try to change the settings from PCNET to E1000 though and give feedback. Guest system as well as Host system: Debian Lenny. Host ist AMD64, Guest is i586.

comment:5 in reply to: ↑ 4 Changed 5 years ago by Ralfredo

Replying to vondralbra:

I can confirm the observation of @smichak. The guest usually drops off during a peak in network IO.

I have the same experience! Se #3737 if interested.

comment:6 Changed 5 years ago by frank

  • Summary changed from Upgrade VirtualBox 2.2.0 from 2.1.4 - vm stopps working after few minutes to Upgrade VirtualBox 2.2.0 from 2.1.4 - vm hangs after few minutes => pcnet problem

Yes, this is indeed a problem with the pcnet emulation which will be fixed with the next release.

comment:7 Changed 5 years ago by cbuckridge

I have the same problem. Host is Ubuntu 8.04, client is Windows XP Pro. My client stops working when taking screen captures of the client screen --little to no network usage during client abort. Now I have a client that won't even load.

comment:8 in reply to: ↑ description Changed 5 years ago by nvarona

I have the same problem too..., after I'd Upgrade VirtualBox 2.2.0 from 2.1.4. My Ubuntu Server 8.04 HH - eBox Platform Hangs, especially when I configure it via http (eBox Admin). Note: No Firewall is Active.

Thanks...

Replying to thomi:

Hi vbox Team

i had today a big problem, cause i upgraded to vbox 2.2.0 one of my two vm stopps working after few minutes. Can't control can't do anything with it, need to kill the vm process on the host manually. Now i have reinstalled 2.1.4 and reconfigured my vm's and all works fine. My host is a Ubuntu 8.04 hardy, with kernel 2.6.24-23-generic, the affecting guest is a Ubuntu 8.04 server LTS with kernel 2.6.24-23-server. I have another guest (Ubuntu 8.04 kernel 2.6.24-23-generic) wthout problem in 2.2.0 or 2.1.4.

Attached are the vm settings and the logs from 2.2.0.

My host run's now on 2.1.4, cause the vm's must run..

Thanks for help thomi

comment:9 Changed 5 years ago by mangue

VirtualBox 2.2.2 just released and no comments about this ticket. Can someone confirm if pcnet still hangs? I experienced the same thing with ubuntu 8.04.2 server as a guest.

comment:10 Changed 5 years ago by frank

PCnet shouldn't hang anymore with VirtualBox 2.2.2. If you experience any hang with VirtualBox 2.2.2, please attach a VBox.log file of such a VM session.

comment:11 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use