VirtualBox

Ticket #3574 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

In seamless mode, child windows are only partially visible -> fixed in SVN

Reported by: roadSurfer Owned by:
Priority: minor Component: GUI/seamless
Version: VirtualBox 3.0.2 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

When running in seamless mode, child windows get cropped to the dimensions of their parent window.

Attachments

SeamlessFault.JPG Download (41.9 KB) - added by roadSurfer 5 years ago.
Child window being cropped to parent dimensions

Change History

Changed 5 years ago by roadSurfer

Child window being cropped to parent dimensions

comment:1 Changed 5 years ago by titantux

Hi I've noticed the same way as you said, in order to find it the rest of the window I had to move it in front of the parent window, (Is not so god remedy), the other thing I did it was to open for example four "Konsole" windows together in order to form a big square.

By the way, I have Vista host, Ubuntu 9.04 guest, VB 2.2.4.

comment:2 Changed 5 years ago by michael

Could this be a duplicate of #1681 ?

comment:3 Changed 5 years ago by roadSurfer

I have not seen 1681 myself, when in seamless the menus appear off the top bar in Ubuntu correctly for me, but I have no extensively tested it.

I don't know a lot about GTK (I don't use KDE) I am afraid but I guess it could be the same/a related issue manifesting itself, this time with actual windows and not just menus.

Someone with more knowledge than me would have to check it out. Sorry. I will try and test 1681 on my system when I get the chance.

comment:4 Changed 5 years ago by michael

  • Version changed from VirtualBox 2.1.4 to VirtualBox 3.0.2
  • Summary changed from In seamless mode, child windows are only partially visible to In seamless mode, child windows are only partially visible -> fixed in SVN

This should be fixed in SVN now.

comment:5 Changed 5 years ago by roadSurfer

Just installed 3.02 and this seems to have been vastly improved. Good work!

Remaining problem appears to be on minimise and restore. If you open a child window (say, Edit/Preferences), all appears normal (child window fully display unlike before). The minimise and restore the terminal window; problem is back (child not fully displayed)

comment:6 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

comment:7 Changed 5 years ago by roadSurfer

  • Status changed from closed to reopened
  • Resolution fixed deleted

This is not fixed! Did you not see my last message?

If you minimize the window the problem reappears.

comment:8 Changed 5 years ago by michael

Please give 3.0.4 (and the 3.0.4 Additions) a shot though.

comment:9 Changed 5 years ago by roadSurfer

Please excuse me - I was not aware of the new build. I shall look tonight.

comment:10 Changed 5 years ago by roadSurfer

Yup - all seems to be fine in 3.0.4 (Ubuntu 9.04 hosted on Windows XPsp3)

Good work all!

comment:11 Changed 5 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

comment:12 Changed 5 years ago by titantux

  • Status changed from closed to reopened
  • Resolution fixed deleted

Hi, I got the problem again whit 3.0.8, even the remedy recommended before it does not work, still partial when I change to desk 2 and back to desk 1. Only the window is able to see it when I bringing to front over other windows. the funny thing, when I want to snapshot the problem, it is full visible into just the snapped... ????

Host Vista Enterprise

Guest Ubuntu 9.04

Thanks, Titantux

comment:13 Changed 4 years ago by frank

titantux, I just want to be sure: you updated the guest additions to 3.0.8, correct?

comment:14 Changed 4 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

No response, closing. If you consider to reopen this ticket, please make sure to install VBox 3.1.0 plus the VBox 3.1.0 guest additions. Or VBox 3.0.12 plus 3.0.12 guest additions as version 3.0.12 is perhaps a bit more stable than 3.1.0.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use