VirtualBox

Ticket #3232 (new defect)

Opened 5 years ago

Last modified 4 years ago

Mouse Wheel does not work (Microsoft Laser Mouse 8000)

Reported by: luidolt Owned by:
Priority: major Component: GUI
Version: VirtualBox 2.1.2 Keywords:
Cc: Guest type: other
Host type: Windows

Description

Host: Vista 64bit, Microsoft Laser Mouse 8000, IntelliPoint 6.4, VirtualBox FrontEnd

Guest: CentOS 5,2; Vista 32bit

The mouse wheel (it is one without "steps") does not work at all when using the VirtualBox frontend - The wheels works when using VBoxHeadless and mstsc (although scrolling is too slow).

Attachments

CentOS 5.2 Development 32bit-2009-01-30-16-44-47.log Download (51.9 KB) - added by luidolt 5 years ago.
VBox.log

Change History

Changed 5 years ago by luidolt

VBox.log

comment:1 Changed 5 years ago by bwcook0

I also have problems with the scroll wheel on a Microsoft Wireless Laser Mouse 5000.

Host is Vista, Guest is XP. You have to spin the wheel really fast to get it the scroll a few lines down. In the host, the wheel is very sensitive.

comment:2 Changed 5 years ago by bwcook0

also, uninstalling intellipoint 6.3 solved the issue for me. Something about the way intellipoint sends the scroll information is not working correctly with Virtualbox.

comment:3 Changed 5 years ago by somebd

I had the same problem. I uninstalled intellipoint and solved the problem too.

Host: Vista SP1 32bit Guest: XP SP2

Hardware:

CPU: Intel E8400 Mouse/Keyboard: Microsoft Wireless Laser 6000

comment:4 follow-up: ↓ 6 Changed 5 years ago by aimone

I have version VBox 2.2.2 running an OpenSolaris guest (with extensions installed) on a Vista host. I had a wheel mouse working fine, then "upgraded" to a "Microsoft Wireless Laser Mouse 8000" only to have the wheel cease functioning in the guest.

As mentioned in a previous post I tried removing the IntelliMouse software, but that made no difference. The wheel still does not function in the guest.

Previously xev in the guest would report button press events for the wheel. Now xev reports pointer motion events with no coordinate change instead of button press events.

comment:5 Changed 5 years ago by plinehan

I'm seeing the same thing.

Host: Vista Guest: Ubuntu (Jaunty) VirtualBox: 2.2.4 Mouse: Microsoft Arc Computer: ThinkPad T60p

Running 'xev' only reports mouse wheel events if I scroll very very quickly. I'm not running IntelliPoint, AFAICT. Everything works fine if I use a Logitech 830823 optical mouse.

I think this may be a dupe of Bug #4086.

comment:6 in reply to: ↑ 4 Changed 5 years ago by somebd2

I posted as somebd (forget the pw) that i haven't the problem anymore. Sorry, but the problem is still there. The mouse wheel worked only the first time after I uninstalled the driver and reboot my pc.

comment:7 Changed 5 years ago by aimone

The battery on my MWLM8k needed recharging, so I plugged a M USB Optical Wheel Mouse in for a while. I told Intellimouse what I was using, and the wheel works on this mouse.

When the battery was charged, I just started using the MWLM8k without thinking about it... and the wheel works! The extra buttons are non-operational (horizontal scrolling and side buttons), but the rest seems to work. I guess this is a reasonable workaround -- use the wrong mouse setting (driver?) in Intellimouse!

comment:8 Changed 5 years ago by rkdart

This sounds a bit like the issue described in  KB828675. I was able to fix it (in my case, Vista/Wireless Laser Mouse 5000/Intellipoint 7.0/VirtualBox 3.0.2/Fedora 11 with guest additions) by selecting a similar mouse without a horizontal tilt wheel, which I never use anyway, in the "Connected To" section of the Mouse control panel. Specifically the "Wireless Notebook Presenter Mouse 8000" and hitting "Apply". I tried selecting several other similar mice, but the Presenter Mouse seemed to match most closely in terms of available buttons and mouse/scroll speed.

I had previously disabled the 'high resolution scrolling' (per  this thread) and rebooted in an attempt to work around the problem, but not sure if that is also necessary to make this work. As a bonus, other apps that didn't work properly with Intellipoint (such as the scrollbars in QtCreator in Windows) now work, too. Hope this helps somebody else... really seems more like a Microsoft bug than a VirtualBox bug to me.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use