VirtualBox

Ticket #4086 (closed defect: duplicate)

Opened 5 years ago

Last modified 4 years ago

Scroll wheel very slow with Intellimouse -> duplicate of #3232

Reported by: cortana Owned by:
Priority: major Component: other
Version: VirtualBox 2.2.2 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

I have a Microsoft Wireless Notebook Optical Mouse 4000. According to the USB IDs it is 045e:00e1 "Wireless Laser Mouse 6000 receiver".

Scroll wheel events are not correctly passed through to the guest. If I move the scroll wheel at normal speeds, the guest received only MotionNotify events. Only if I move the scroll wheel very quickly does the occasional ButtonPress/Release event show up.

The physical scroll wheel also acts as two buttons that can be activated by tilting the wheel left and right, but similarly this only causes MotionNotify events to be sent to the guest.

The wheel works fine in both Windows itself, and if I connect it to a machine running Linux natively.

I'm using 64-bit Vista Home Basic as the host, Debian using Linux 2.6.26 as the guest. I don't have any IntelliPoint software installed.

Change History

comment:1 Changed 5 years ago by cortana

In addition I have noticed that a MotionNotify event is sent prior to every mouse click. This makes using the mouse rather frustrating: clicking the mouse usually selects text which is very annoying in an X11 environment where this overwrites the PRIMARY selection buffer...

comment:2 Changed 5 years ago by cortana

Using the evtest program on the relevant device in /dev/input reports this sequence of events when the first mouse button is pressed:

Event: time 1243966466.124489, type 1 (Key), code 272 (LeftBtn), value 1
Event: time 1243966466.124506, type 2 (Relative), code 0 (X), value 1
Event: time 1243966466.124511, type 2 (Relative), code 1 (Y), value 1
Event: time 1243966466.124516, -------------- Report Sync ------------

and released:

Event: time 1243966469.188399, type 1 (Key), code 272 (LeftBtn), value 0
Event: time 1243966469.188417, type 2 (Relative), code 0 (X), value 1
Event: time 1243966469.188422, type 2 (Relative), code 1 (Y), value 1
Event: time 1243966469.188427, -------------- Report Sync ------------

Scrolling the wheel slowly only reports Relative motion events for the X and Y axes. If I scroll it very quickly then the occasional mouse wheel event occurs:

Event: time 1243966573.669565, type 2 (Relative), code 8 (Wheel), value -1

So I think this rules out Xorg configuration issues, etc. :)

comment:3 Changed 5 years ago by plinehan

I'm seeing the same thing.

Host: Vista Guest: Ubuntu (Jaunty) VirtualBox: 2.2.4 Mouse: Microsoft Arc Computer: ThinkPad T60p

Running 'xev' only reports mouse wheel events if I scroll very very quickly. I'm not running IntelliPoint, AFAICT. Everything works fine if I use a Logitech 830823 optical mouse.

I think this may be a dupe of Bug #3232.

comment:4 Changed 5 years ago by michael

The motion notification being sent with mouse clicks should be fixed in version 2.2.4. Has anyone with the slow mouse wheel issues been able to test them with a non-Linux guest? Or for that matter, a Linux guest with no Guest Additions?

comment:5 Changed 5 years ago by michael

Ah, I see someone did on #3232.

comment:6 Changed 5 years ago by michael

  • Status changed from new to closed
  • Resolution set to duplicate
  • Summary changed from Scroll wheel very slow with Intellimouse to Scroll wheel very slow with Intellimouse -> duplicate of #3232
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use