VirtualBox

Ticket #3123 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

Crash in slirp_output

Reported by: greenrd Owned by:
Priority: major Component: network/NAT
Version: VirtualBox 2.1.2 Keywords:
Cc: Guest type: Linux
Host type: Mac OS X

Description

My VirtualBox 2.1.2_OSE VM just crashed - here is an extract from the Mac OS X "Problem Report"

Thread 13 Crashed:
0   VBoxDD.dylib                  	0x1c65607b slirp_output + 107
1   VBoxDD.dylib                  	0x1c661939 if_encap + 185
2   VBoxDD.dylib                  	0x1c662e91 if_start + 193
3   VBoxDD.dylib                  	0x1c669fa3 ip_output + 723
4   VBoxDD.dylib                  	0x1c668cde tcp_output + 1198
5   VBoxDD.dylib                  	0x1c661576 slirp_select_poll + 294
6   VBoxDD.dylib                  	0x1c655f41 drvNATAsyncIoThread(PDMDRVINS*, PDMTHREAD*) + 449
7   VBoxVMM.dylib                 	0x014b6eb5 pdmR3ThreadMain(RTTHREADINT*, void*) + 213
8   VBoxRT.dylib                  	0x013618e0 rtThreadMain + 64 (thread.cpp:639)
9   VBoxRT.dylib                  	0x0138b5d4 rtThreadNativeMain(void*) + 132 (thread-posix.cpp:193)
10  libSystem.B.dylib             	0x91dc0095 _pthread_start + 321
11  libSystem.B.dylib             	0x91dbff52 thread_start + 34

Attachments

virtualbox crash report.txt Download (37.3 KB) - added by greenrd 5 years ago.
VBox.log.2 Download (39.3 KB) - added by greenrd 5 years ago.

Change History

Changed 5 years ago by greenrd

comment:1 Changed 5 years ago by p2k

I'm posting here to be notified when this issue is resolved. FWIW, I'm a bit surprised as I opened #3121 and it's been marked as duplicate of this one and 3123 > 3121.

Regards, Patrick.

comment:2 Changed 5 years ago by p2k

Doesn't seem to work: could someone add me to the CC list?

comment:3 Changed 5 years ago by greyrl

If you'd like to follow this bug, the RSS can be found here:

 http://www.virtualbox.org/ticket/3123?format=rss

Changed 5 years ago by greenrd

comment:4 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Actually I'm quite sure this is a duplicate of #3110. As this is VBox OSE, you could apply r16201 youself and check if this fixes your crash.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use