VirtualBox

Ticket #3121 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

VirtualBox 2.1.2 crashes everytime after the Windows guest boot

Reported by: p2k Owned by:
Priority: blocker Component: other
Version: VirtualBox 2.1.2 Keywords: crash
Cc: Guest type: Windows
Host type: Linux

Description

I just upgraded from VirtualBox 2.1.0 to 2.1.2 and it now crashes a few seconds after every boot of the guest.

I do not even have time to upgrade the Windows guest additions.

The system logs:

me@mydesktop:~$ grep VirtualBox /var/log/*.log
/var/log/kern.log:Jan 23 12:49:24 mydesktop kernel: [164758.957492] VirtualBox[5893]: segfault at c ip b4d907d2 sp b3db4f20 error 4 in VBoxDD.so[b4d00000+1b6000]
/var/log/kern.log:Jan 23 12:55:15 mydesktop kernel: [165110.184855] VirtualBox[6794]: segfault at c ip b4c447d2 sp b3c68f20 error 4 in VBoxDD.so[b4bb4000+1b6000]
/var/log/kern.log:Jan 23 13:02:01 mydesktop kernel: [  316.675700] VirtualBox[6285]: segfault at c ip b4dd07d2 sp b3df4f20 error 4 in VBoxDD.so[b4d40000+1b6000]
/var/log/kern.log:Jan 23 13:11:17 mydesktop kernel: [  872.014683] VirtualBox[7016]: segfault at c ip b4d887d2 sp b3dacf20 error 4 in VBoxDD.so[b4cf8000+1b6000]
/var/log/kern.log:Jan 23 13:15:18 pdecat-desktop kernel: [ 1112.945773] VirtualBox[7381]: segfault at c ip b4ba77d2 sp b3c27f20 error 4 in VBoxDD.so[b4b17000+1b6000]

Some information about my system:

$ uname -a
Linux mydesktop 2.6.27-11-generic #1 SMP Thu Jan 22 17:22:40 UTC 2009 i686 GNU/Linux

$ cat /etc/issue
Ubuntu 8.10 \n \l

$ cat /etc/apt/sources.list.d/virtualbox.list
deb http://download.virtualbox.org/virtualbox/debian intrepid non-free

I have core files that I'll be uploading to the FTP.

Regards, Patrick.

Attachments

VBox-logs.7z Download (11.0 KB) - added by p2k 5 years ago.
Here are the VirtualBox logs

Change History

Changed 5 years ago by p2k

Here are the VirtualBox logs

comment:1 Changed 5 years ago by p2k

me@mydesktop:~$ apt-cache show virtualbox-2.1

Package: virtualbox-2.1
Version: 2.1.2-41885_Ubuntu_intrepid
Architecture: i386
Maintainer: Sun Microsystems, Inc. <info@virtualbox.org>
Installed-Size: 61600
Pre-Depends: debconf (>= 1.1) | debconf-2.0
Depends: libc6 (>= 2.7), libgcc1 (>= 1:4.1.1), libqt4-network (>= 4.4.3), libqtcore4 (>= 4.4.3), libqtgui4 (>= 4.4.3), libsdl1.2debian (>= 1.2.10-1), libssl0.9.8 (>= 0.9.8f-5), libstdc++6 (>= 4.2.1), libx11-6, libxcursor1 (>> 1.1.2), libxext6, libxml2 (>= 2.6.27), libxmu6, libxslt1.1 (>= 1.1.18), libxt6, python2.5 (>= 2.5), psmisc, adduser
Recommends: libasound2, libpulse0, libsdl-ttf2.0-0, dkms, linux-headers, gcc, make, binutils, libhal1 (>= 0.5), pdf-viewer, libgl1
Conflicts: virtualbox
Replaces: virtualbox
Provides: virtualbox
Priority: optional
Section: misc
Filename: pool/non-free/v/virtualbox-2.1/virtualbox-2.1_2.1.2-41885_Ubuntu_intrepid_i386.deb
Size: 32766676
SHA1: 7fc3e9eaa455aa0c32e7ce68644bd054dbfeb6f7
MD5sum: 27ca58bde19aae0ced3eaa2e6ac29d9e
Description: Sun xVM VirtualBox
 VirtualBox is a powerful PC virtualization solution allowing you to run a
 wide range of PC operating systems on your Linux system. This includes
 Windows, Linux, FreeBSD, DOS, OpenBSD and others. VirtualBox comes with a broad
 feature set and excellent performance, making it the premier virtualization
 software solution on the market.

comment:2 Changed 5 years ago by p2k

I managed to boot the Windows guest in safe mode and install the 2.1.2 guest additions.

comment:3 Changed 5 years ago by p2k

That does not solve the crashes:

[ 2336.672440] VirtualBox[8626]: segfault at c ip b4cbc7d2 sp b3ce0f20 error 4 in VBoxDD.so[b4c2c000+1b6000]

comment:4 Changed 5 years ago by p2k

And another:

[ 3925.015532] VirtualBox[10771]: segfault at c ip b4d017d2 sp b3d25f20 error 4 in VBoxDD.so[b4c71000+1b6000]

comment:5 Changed 5 years ago by frank

Did you wrote that you were about to upload the core dumps to our FTP server?

comment:6 Changed 5 years ago by p2k

Sure, it's up : virtualbox-2.1_2.1.2-41885_Ubuntu_intrepid_i386-core.6253.7z

comment:7 Changed 5 years ago by p2k

I downgraded to 2.1.0-41146_Ubuntu_intrepid for now (had to revert the XML configuration files by hand).

comment:8 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Thanks for the core dump. This is actually a duplicate of #3123.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use