VirtualBox

Ticket #2838 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

Slow NAT networking on opensolaris 2008.11 64bit host

Reported by: larghio Owned by:
Priority: major Component: network/NAT
Version: VirtualBox 2.1.0 Keywords:
Cc: Guest type: other
Host type: Solaris

Description

Hi I use opensolaris 2008.11 64bit on my file server and was very happy to see that VirtualBox 2.1.0 fixed the NAT problems that crashed my Windows XP guests every five minutes. My problem now is that im only getting about 0.5Mbit when i upload or download files to the cifs server on the host. and when I U/D files from other cifs serves on the network.

I tried to create a Debian etch guest, but had the same problems with network speed.

I then copied the guests to my workstation (windows XP 32bit) with Virtualbox 2.1.0. there were no network speed problems when i ran my file tranfer tests from the same guests but with an XP host

Back on my opensolaris server i switched the guest from NAT to host interface and tried the same file operations over the network. no speed problems.

after these tests i can only conclude that there is a speed problem with the Virtualbox NAT engine on my opensolaris server

please let me know if you need more informasion, or if I need to clarify something in my description

Attachments

VBox.log.XP.NAT Download (52.5 KB) - added by bqbauer 5 years ago.
VBox.log.XP.bridged Download (52.8 KB) - added by bqbauer 5 years ago.
VBox.log.osol.NAT Download (52.6 KB) - added by bqbauer 5 years ago.
VBox.log.osol.bridged Download (52.8 KB) - added by bqbauer 5 years ago.

Change History

comment:1 Changed 5 years ago by bqbauer

I have a similar performance difference on my system between NAT and host interface with 2.1.0. Using SFTP, I transferred a file from OpenSolaris 2008.11 host to an XP SP3 guest. Using NAT, throughput was about 7Mb/s (for clarity, I DO mean megabits). Using Host Interface networking, throughput was about 70Mb/s. For both, the guest is configured with the 100Mb AMD PCnet-FASTIII adapter. In both situations, the guest thought it had a 100Mb link and had no complaints. Same 50MB files used for each test, deleting between the tests. No antivirus on guest.

comment:2 Changed 5 years ago by bqbauer

I just performed the same test with the same files, but using an OpenSolaris 2008.11 guest to the same host. Results are virtually identical to my previous post. NAT is about 1/10 the speed, and the numbers were about the same.

comment:3 Changed 5 years ago by Hachiman

Thank you for reporting. I'll back as soon as I'll able reproduce or will need more information.

comment:4 Changed 5 years ago by frank

  • Component changed from network to network/NAT

comment:5 Changed 5 years ago by bqbauer

Problem still exists in 2.1.2

comment:6 Changed 5 years ago by Hachiman

bqbauer, could you please describe your environment little bit. What I'm interested is server and client do you use? In tests you're describing the hdd is also involved to minimize influence of other Vbox subsystems could you please redirect sftp client out put to /dev/null (if you're client is in cygwin)? And could you please attach your log file to get more information about hardware environment have you got.

comment:7 Changed 5 years ago by cemerick

Just to echo the OP, I see a big rate difference copying to a regular host vs. copying to a vbox guest over NAT:

chas% scp big_file chas@atlantic:/dev/null big_file 19% 24MB 3.3MB/s 00:30 ETA

chas% scp -P 8022 big_file chas@code:/dev/null big_file 10% 13MB 719.8KB/s 02:37 ETA

big_file is a arbitrary 100MB file. Atlantic is an x2100 box running OpenSolaris 2008.11. Code is an OS 2008.11 vbox v2.1.0 guest on Atlantic, accessible via NAT. In general, the speed difference is 5x; I also manage to see burst of 5MB/s to atlantic, whereas 900K is the best I see to code.

I haven't yet switched code over to use host-based networking, so I can't comment on the difference there (yet?).

comment:8 Changed 5 years ago by cemerick

I don't know jack about the internals of vbox, but #1335 seems like the same (or closely related) issue. The original comment there isn't heartening. :-|

comment:9 Changed 5 years ago by frank

Was there any improvement with VirtualBox 2.2.0 (better check 2.2.2)?

comment:10 Changed 5 years ago by bqbauer

It appears improved, but still no better than 1/2 the speed using NAT. I will make every attempt to provide better data this week.

comment:11 Changed 5 years ago by bqbauer

I apologize for not getting back to this sooner.

The data below and attached log files are from VB 2.2.4 on a 64-bit OpenSolaris 2008.11 host. My host environments (so far tested on two hosts):

System 1:

Intel Q6600 quad core CPU with 8GB memory running OpenSolaris 2008.11. Host has a ZFS root mirror with two fast Seagate 7200.12 500GB drives. Intel X38 chipset with ICH9 SATA controllers in native non-RAID mode. Ethernet is an Intel e1000g, chipset 82572.

System 2:

Intel i7-920 CPU with 12GB memory running OpenSolaris 2008.11. Similar drive configuration, Intel X58 chipset and Intel e1000g ethernet, chipset 82567.

Information below is from system #1, although #2 returns similar results.

For the files transferred, I'm using the OpenSolaris 2008.11 ISO file (688MB) and Solaris x86 Adobe Reader v9.1 installer (47MB).

In an XP 32-bit guest with 1GB memory and NAT, the 47MB file transfers at about 7Mb/s using command line FTP. It is the same if I direct output to the null device ("nul:" in the Windows command line) or to the virtual hard drive. The 688MB file transfer slows to less than 3Mb/s by the time it finishes.

An OpenSolaris guest with NAT is a little faster transferring the 49MB file at around 8.5Mb/s.

With bridged networking, the performance on the XP guest using FTP on either file varies between 300-400Mb/s. These transfer rates are for output directed to the null device. When the output is to the virtual hard drive, the transfer rates range from about 250-300Mb/s.

The transfer rates for bridged networking in an OpenSolaris guest are about double that of the XP guest (500-600Mb/s) for both files.

I'm attaching log files for all of these tests.

Changed 5 years ago by bqbauer

Changed 5 years ago by bqbauer

Changed 5 years ago by bqbauer

Changed 5 years ago by bqbauer

comment:12 Changed 5 years ago by Hachiman

Thank you, for update. I will investigate the issue.

comment:13 Changed 5 years ago by bqbauer

I don't know that this can be called "fixed", but NAT performance on 2009.06 hosts has increased significantly, probably because of Crossbow? My guests using NAT now get consistently 150-200Mb/s with any host, about half what they get with bridged networking. This is about 20x faster than under a 2008.11 host, all tested with VB 2.2.4.

comment:14 Changed 5 years ago by bqbauer

Tested the second host system I previously described. Both systems show this 20x NAT improvement when running 2009.06. Booted a backup disk of 2008.11, and the slowness of NAT returned.

What's interesting is SSH is about 20% slower using bridged networking than NAT; Bridged is about 50Mb/s, NAT about 65Mb/s. I don't know if this is anything of concern.

comment:15 Changed 5 years ago by Hachiman

  • Status changed from new to closed
  • Resolution set to duplicate

duplicate #3400

comment:16 Changed 5 years ago by bqbauer

Nice to be fixed with 2.2.4 and 2009.06, but see ticket 4343 where NAT is now broken. Don't know if the two issues should be cross-referenced.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use