VirtualBox

Ticket #3400 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Outbound TCP transfers very slow in NAT mode

Reported by: rindfuss Owned by:
Priority: major Component: network/NAT
Version: VirtualBox 2.1.4 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

I have vbox 2.1.5r43070, host win xp pro sp3, guest opensuse 11.0, all x86, in a fast ethernet lan environment (100 Mbit/s both ways). I noticed that in NAT mode, downloads from a network server to the vm run at the expected speed of up to 10 Mbytes/s (depending on the protocol used), whereas uploads are about 30 times slower (~330 kbytes/s). In host interface mode, both directions work at full speed. This was tested with ftp, smb and scp. Peter

Attachments

VBox.log Download (54.0 KB) - added by vladie 5 years ago.
vbox defect demonstration log

Change History

comment:1 Changed 5 years ago by Hachiman

Does anything change with 2.2.2?

comment:2 follow-ups: ↓ 3 ↓ 5 Changed 5 years ago by rindfuss

Not really. My last test with 2.2.2 and ftp: download ~ 11 MB/s upload ~ 600 kB/s Should be 11 MB both ways (as is in bridged mode). Peter

comment:3 in reply to: ↑ 2 ; follow-up: ↓ 4 Changed 5 years ago by Hachiman

Replying to rindfuss:

Not really. My last test with 2.2.2 and ftp: download ~ 11 MB/s upload ~ 600 kB/s Should be 11 MB both ways (as is in bridged mode). Peter

Hello Peter, Does it depend on chosen protocol? can you check e.g. if the scp upload/download has other ratio?

comment:4 in reply to: ↑ 3 Changed 5 years ago by rindfuss

Replying to Hachiman:

Replying to rindfuss:

Not really. My last test with 2.2.2 and ftp: download ~ 11 MB/s upload ~ 600 kB/s Should be 11 MB both ways (as is in bridged mode). Peter

Hello Peter, Does it depend on chosen protocol? can you check e.g. if the scp upload/download has other ratio?

Just tested: scp shows the very same problem in NAT mode. Bridged mode is fine, again.

comment:5 in reply to: ↑ 2 Changed 5 years ago by ronon

Replying to rindfuss:

Not really. My last test with 2.2.2 and ftp: download ~ 11 MB/s upload ~ 600 kB/s Should be 11 MB both ways (as is in bridged mode). Peter

I have similar problem on WinXP Pro SP3 Guest running on WinXP Pro SP3 Host.

comment:6 Changed 5 years ago by frank

The NAT send performance should have notably increased with VirtualBox 3.0.2, can you confirm that?

comment:7 Changed 5 years ago by vladie

Replying to Hachiman:

Does it change for you with  3.0.6_B1?

Just tested, bug IS NOT fixed :( Downloads ~30mb/s, uploads ~1.3mb/s

comment:8 Changed 5 years ago by frank

vladie, please attach a VBox.log file of such a 3.0.6 Beta 1 VM session to this defect.

Changed 5 years ago by vladie

vbox defect demonstration log

comment:9 Changed 5 years ago by vladie

i've added log. i've started VM, tried to upload file throught NAT, then shutdowned VM.

comment:10 Changed 5 years ago by vladie

just tested in 3.0.6 release, bug still exists and very annoying :(

comment:11 Changed 5 years ago by frank

Any difference when using the E1000 device emulation? There are E1000 drivers even for WinXP available on the internet ...

comment:12 Changed 5 years ago by vladie

just tried with e1000 desktop, problem persists:(

comment:13 Changed 4 years ago by rindfuss

In 3.0.10, the problem is still there in the standard configuration. But if I increase buffer sizes according to 9.12.3 "Tuning TCP/IP buffers for NAT" in the docs, I get an almost optimal result: Outbound transfers are now only 10% below the maximum speed. I have set all 4 buffers to the max value of 1024 kBytes.

comment:14 Changed 4 years ago by Hachiman

Does it change in 3.1?

comment:15 follow-up: ↓ 16 Changed 4 years ago by nemebean

No, I was having the same problem with a Win XP guest on Kubuntu 9.10 in 3.1.0. Fortunately, the TCP/IP buffer tuning seems to have largely fixed the problem for me too. Also, for reference the relevant section of the manual is now 9.14.3.

comment:16 in reply to: ↑ 15 Changed 4 years ago by Hachiman

Replying to nemebean:

No, I was having the same problem with a Win XP guest on Kubuntu 9.10 in 3.1.0. Fortunately, the TCP/IP buffer tuning seems to have largely fixed the problem for me too. Also, for reference the relevant section of the manual is now 9.14.3.

Thanks for feedback. Probably your experience could be added on  HOWTO page.

comment:17 Changed 4 years ago by Hachiman

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use