VirtualBox

Ticket #2742 (closed defect: duplicate)

Opened 5 years ago

Last modified 4 years ago

VirtualBox SegFaults / crash when resumed from saved state

Reported by: TiCPU Owned by:
Priority: major Component: VMM
Version: VirtualBox 2.2.2 Keywords: standby crash resume resumed
Cc: jeromepoulin@… Guest type: Windows
Host type: Linux

Description (last modified by frank) (diff)

If I suspend my virtual machine, then resume it, VirtualBox crashes and the machine appears as aborted. It could be a problem on my side, but anyway, here's a backtrace: Backtrace:  http://ticpu.net:8080/~jerome/vbox-xp-resume-crash.7z

Attachments

VBox.log Download (51.5 KB) - added by TiCPU 5 years ago.
VBox.Log for version 2.2.2 with matching add-ons and modules.
VBox.2.log Download (48.0 KB) - added by RoBox 5 years ago.
vbox.log

Change History

comment:1 Changed 5 years ago by TiCPU

If I suspend my virtual machine, then resume it, VirtualBox crashes and the machine appears as aborted. It could be a problem on my side, but anyway, here's a backtrace:

Core dump:  http://ticpu.net:8080/~jerome/vbox-xp-resume-crash.7z

Core was generated by `/opt/VirtualBox/VirtualBox -startvm XP'.
Program terminated with signal 11, Segmentation fault.
#0  0xb51ac086 in _XrmInternalStringToQuark () from /usr/lib/libX11.so.6
(gdb) bt
#0  0xb51ac086 in _XrmInternalStringToQuark () from /usr/lib/libX11.so.6
#1  0xb51ac444 in XrmStringToQuark () from /usr/lib/libX11.so.6
#2  0xb51dacaa in _XimInitialResourceInfo () from /usr/lib/libX11.so.6
#3  0xb51d3156 in _XimLocalOpenIM () from /usr/lib/libX11.so.6
#4  0xb51dd730 in _XimOpenIM () from /usr/lib/libX11.so.6
#5  0xb51ccaa1 in _XimRegisterIMInstantiateCallback () from /usr/lib/libX11.so.6
#6  0xb51bf8f2 in XRegisterIMInstantiateCallback () from /usr/lib/libX11.so.6
#7  0xb5983e36 in QXIMInputContext::QXIMInputContext () from /opt/VirtualBox/libVBoxQtGui.so.4
#8  0xb5982044 in QInputContextFactory::create () from /opt/VirtualBox/libVBoxQtGui.so.4
#9  0xb54ff62e in QApplication::inputContext () from /opt/VirtualBox/libVBoxQtGui.so.4
#10 0xb552de6a in QWidget::inputContext () from /opt/VirtualBox/libVBoxQtGui.so.4
#11 0xb553b625 in QWidget::updateMicroFocus () from /opt/VirtualBox/libVBoxQtGui.so.4
#12 0xb553c205 in QWidget::qt_metacall () from /opt/VirtualBox/libVBoxQtGui.so.4
#13 0xb59ce67f in QFrame::qt_metacall () from /opt/VirtualBox/libVBoxQtGui.so.4
#14 0xb587c0f3 in QAbstractScrollArea::qt_metacall () from /opt/VirtualBox/libVBoxQtGui.so.4
#15 0xb586981c in QTextEdit::qt_metacall () from /opt/VirtualBox/libVBoxQtGui.so.4
#16 0xb5c6d1ea in QMetaObject::activate () from /opt/VirtualBox/libVBoxQtCore.so.4
#17 0xb5c6d5ef in QMetaObject::activate () from /opt/VirtualBox/libVBoxQtCore.so.4
#18 0xb56869fb in QTextControl::microFocusChanged () from /opt/VirtualBox/libVBoxQtGui.so.4
#19 0xb5685ca2 in QTextControl::ensureCursorVisible () from /opt/VirtualBox/libVBoxQtGui.so.4
#20 0xb567c536 in QTextControlPrivate::setContent () from /opt/VirtualBox/libVBoxQtGui.so.4
#21 0xb567e813 in QTextControl::setHtml () from /opt/VirtualBox/libVBoxQtGui.so.4
#22 0xb5865ef4 in QTextEdit::setHtml () from /opt/VirtualBox/libVBoxQtGui.so.4
#23 0xb58692c0 in QTextEdit::setText () from /opt/VirtualBox/libVBoxQtGui.so.4
#24 0xb791c9e6 in VBoxProblemReporter::message () from /opt/VirtualBox/VirtualBox.so
#25 0xb792065d in VBoxProblemReporter::cannotStartMachine () from /opt/VirtualBox/VirtualBox.so
#26 0xb794e0b3 in VBoxConsoleWnd::finalizeOpenView () from /opt/VirtualBox/VirtualBox.so
#27 0xb7a0e060 in VBoxConsoleWnd::qt_metacall () from /opt/VirtualBox/VirtualBox.so
#28 0xb5c6d1ea in QMetaObject::activate () from /opt/VirtualBox/libVBoxQtCore.so.4
#29 0xb5c6d5ef in QMetaObject::activate () from /opt/VirtualBox/libVBoxQtCore.so.4
---Type <return> to continue, or q <return> to quit--- 
#30 0xb5c71fd3 in QSingleShotTimer::timeout () from /opt/VirtualBox/libVBoxQtCore.so.4
#31 0xb5c71ed0 in QSingleShotTimer::timerEvent () from /opt/VirtualBox/libVBoxQtCore.so.4
#32 0xb5c6a1cb in QObject::event () from /opt/VirtualBox/libVBoxQtCore.so.4
#33 0xb54ff3b1 in QApplicationPrivate::notify_helper () from /opt/VirtualBox/libVBoxQtGui.so.4
#34 0xb54fdf36 in QApplication::notify () from /opt/VirtualBox/libVBoxQtGui.so.4
#35 0xb5c5bd64 in QCoreApplication::notifyInternal () from /opt/VirtualBox/libVBoxQtCore.so.4
#36 0xb5c802ca in QTimerInfoList::activateTimers () from /opt/VirtualBox/libVBoxQtCore.so.4
#37 0xb5c80ef0 in QEventDispatcherUNIX::activateTimers () from /opt/VirtualBox/libVBoxQtCore.so.4
#38 0xb5c810e3 in QEventDispatcherUNIX::processEvents () from /opt/VirtualBox/libVBoxQtCore.so.4
#39 0xb556e9d3 in QEventDispatcherX11::processEvents () from /opt/VirtualBox/libVBoxQtGui.so.4
#40 0xb5c5a4f4 in QEventLoop::processEvents () from /opt/VirtualBox/libVBoxQtCore.so.4
#41 0xb5c5a58d in QEventLoop::exec () from /opt/VirtualBox/libVBoxQtCore.so.4
#42 0xb5c5c10c in QCoreApplication::exec () from /opt/VirtualBox/libVBoxQtCore.so.4
#43 0xb54fdcc9 in QApplication::exec () from /opt/VirtualBox/libVBoxQtGui.so.4
#44 0xb78e8922 in TrustedMain () from /opt/VirtualBox/VirtualBox.so
#45 0x080495d7 in ?? ()
#46 0x08048c8c in ?? ()
#47 0xb7d89fc8 in __libc_start_main () from /lib/libc.so.6
#48 0x08048bc5 in ?? ()
(gdb) 

comment:2 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

This was actually fixed some releases ago. Before you re-open this ticket please check the latest release 2.2.2.

comment:3 Changed 5 years ago by TiCPU

  • Status changed from closed to reopened
  • Resolution fixed deleted

I started my XP, did suspend while it was starting, resumed: OK. Windows XP fully started on desktop, in windowed mode, did suspend, resumed:

Failed to start the virtual machine Windows XP. Unable to restore the virtual machine's saved state from '/root/.VirtualBox/Machines/Windows XP/Snapshots/{45ac5550-e669-4bc7-8cf8-fa3415397d38}.sav'. It may be damaged or from an older version of VirtualBox. Please discard the saved state before starting the virtual machine (VERR_SSM_LOAD_CONFIG_MISMATCH).

Result Code: NS_ERROR_FAILURE (0x80004005) Component: Console Interface: IConsole {9511bc54-15ee-4ddf-808e-472aba03809c}

Changed 5 years ago by TiCPU

VBox.Log for version 2.2.2 with matching add-ons and modules.

comment:4 Changed 5 years ago by TiCPU

I just attached the VBox.log file and the version of the bug note should be changed from 2.0.6 to 2.2.2, updated VBox, modules and add-ons.

Changed 5 years ago by RoBox

vbox.log

comment:5 Changed 5 years ago by RoBox

I would like to clarify that when I got this error it was after hitting pause and then close and choosing save state. I had several snapshots already and tried reverting to a couple of them, but it does not fix the error, nor change the name of the .sav file it is referring to as having a problem. The details section says: Result Code: E_FAIL (0x80004005) Component: Console Interface: IConsole {9511bc54-15ee-4ddf-808e-472aba03809c}

I obviously can't change anything about my virtual machine because it is saved in a running state. I think that should have changed when I tried to revert to previous snapshots; so, that reversion appears to not be working. Yes, I am using version 2.2.2.

comment:6 Changed 5 years ago by frank

  • Version changed from VirtualBox 2.0.6 to VirtualBox 2.2.2

comment:7 Changed 5 years ago by frank

  • Description modified (diff)

comment:8 Changed 5 years ago by frank

  • Summary changed from VirtualBox SegFaults / crash when resumed from standby to VirtualBox SegFaults / crash when resumed from saved state

TiCPU and RoBox, looking at your log files I don't see a crash but instead you seem to have some problems loading a snapshot? Are you sure that the original issue (crash after loading a snapshot / saved state) isn't fixed? Not being able to load a saved state is still a bug of course but this seems to be different from a crash.

comment:9 follow-up: ↓ 10 Changed 5 years ago by TiCPU

I confirm, it does not crash anymore, but it won't load at all as soon as Windows has gone past loading some driver, I couldn't tell what driver, but when it is loaded Virtual Box says VERR_SSM_LOAD_CONFIG_MISMATCH and aborts, no more segfault. However, the only way to resume is still to discard the save state.

comment:10 in reply to: ↑ 9 Changed 5 years ago by RoBox

Maybe this was posted in the wrong place? But yes, the virtual machine would not start up and I got the VERR_SSM_LOAD_CONFIG_MISMATCH error. I think after reverting like 2 or three snapshots then I got it to work (though it was useless to me at that point). It's strange that this happened and that I couldn't simply revert one snapshot and get it to work. VirtualBox did continue to work except that one guest which failed to start.

comment:11 Changed 5 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to duplicate

Ok, in that case this is a duplicate of #3984, at least it is now.

comment:12 Changed 5 years ago by frank

To all: This bug is quite difficult to reproduce for us. We are looking for an easy way to reproduce this bug to be able to test a potential fix. Please post any comment to #3984.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use