VirtualBox

Ticket #3984 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Unable to restore state under certain conditions (VBox 2.2.2) -> fixed in SVN/3.0.10

Reported by: halcwb Owned by:
Priority: major Component: shared folders
Version: VirtualBox 3.0.0 Keywords:
Cc: Guest type: other
Host type: other

Description

I had created a Windows XP VM in the previous version of VB on Ubuntu 8.10. This worked fine. After I upgraded VB to 2.2.2 and Ubuntu to 9.04 I get the message: "Unable to restore the virtual machine's saved state" Details of the error message can be found in the attached files

Attachments

VBox.log Download (41.7 KB) - added by halcwb 5 years ago.
Windows-2009-06-02-11-51-37.log Download (47.7 KB) - added by RFK 5 years ago.
RFK
VBox.2.log Download (47.7 KB) - added by Sasquatch 5 years ago.
2.2.4 failing restore saved state
vbox-2009-07-26-22-41-17.log Download (47.8 KB) - added by derfel 5 years ago.
LoadExec failed with rc=VERR_SSM_LOAD_CONFIG_MISMATCH for unit 'pgm'!
VBox.log.2 Download (41.6 KB) - added by oefe 5 years ago.
Log file with the error

Change History

Changed 5 years ago by halcwb

comment:1 Changed 5 years ago by frank

Which VBox version created the snapshot? Was that 2.2.2?

comment:2 Changed 5 years ago by halcwb

I first discarded the old snapshots, made with the previous version. Then I suspended the machine with the 2.2.2 version. Only, still I get the above described problem.

Regards -- Casper

comment:3 Changed 5 years ago by frank

  • Host type changed from Linux to other
  • Component changed from other to VMM
  • Summary changed from Unable to restore state after upgrade to VirtualBox 2.2.2 r46594 linux.amd64 (Apr 27 2009 18:57:04) release to Unable to restore state (VBox 2.2.2)

comment:4 Changed 5 years ago by frank

  • Summary changed from Unable to restore state (VBox 2.2.2) to Unable to restore state under certain conditions (VBox 2.2.2)

comment:5 Changed 5 years ago by TiCPU

I just want to subscribe to this bug as  http://www.virtualbox.org/ticket/2742 is now a duplicate of here.

comment:6 Changed 5 years ago by RFK

I want to subscribe too, because I'm having the same problem under OSX 10.5.7 host.

comment:7 Changed 5 years ago by lyxus

Same thing under 10.5.7 host.

I have to shut down the guest OS since i cannot save the state

comment:8 follow-up: ↓ 11 Changed 5 years ago by frank

To all: This bug is quite difficult to reproduce for us. We are looking for an easy way to reproduce this bug to be able to test a potential fix.

comment:9 Changed 5 years ago by RoBox

I just tried it again and yes, fail. since I can't copy and paste the text of the error:  http://img20.imageshack.us/img20/4921/captureg.png

  1. pause virtual machine
  2. close menu > save state
  3. try to start virtual machine

error

comment:10 Changed 5 years ago by RoBox

I should also say that: I had multiple snapshots. Most recent was of running machine. Tried to revert to current snapshot and that did not fix problem. Had to discard it. Still did not fix it. Had to discard another snapshot. No. Discarded my final snapshot and it still gets the same error. Guest VM remains in "saved" state.

comment:11 in reply to: ↑ 8 Changed 5 years ago by RFK

Replying to frank:

To all: This bug is quite difficult to reproduce for us. We are looking for an easy way to reproduce this bug to be able to test a potential fix.

I'm willing to work with you on helping you reproduce the bug. My information is in my posts at  http://forums.virtualbox.org/viewtopic.php?f=8&t=17555&sid=3b4195c463cc11a0d142653d1455dce2

comment:14 Changed 5 years ago by TiCPU

I just want to add that now that I switched back to my normal image, switching network card won't help, I need to completely disable all network cards except the first NAT card, using PCNet III, at least I can confirm it is network related!

My setup is:
Net1:  NAT PCNet III
Net2:  Bridged Server T to eth0
Net3:  Bridged PCNet III to wlan0
this setup causes the problem with my XP.

Sorry for the French box, forgot to add this to my last message.

PS.: Don't know how I got that last empty comment...

comment:15 Changed 5 years ago by RoBox

I should add, I was able to create a new VM and point it to the .vdi file and get it to work that way. So, it was just a corrupted save state or XML file that was the problem. That was after I had discarded all the snapshots, however. I don't know if I could have done that with some snapshots active or just edit the XML file (which is only possible apparently after all instances of VirtualBox executable are closed) not that I'd know how to edit that anyway.

comment:16 Changed 5 years ago by blakeb

I was not able to recreate the error on another machine, but was able to fix it by switching to all PCNet III adapters rather than Intel MT 1000 Desktop.

comment:17 Changed 5 years ago by donaldshimoda

I can confirm same problem, host linux 64 bits

Linux xxxxxx 2.6.29.4-custom #1 SMP PREEMPT Mon May 25 14:24:03 COT 2009 x86_64 GNU/Linux

guest windows xp SP3

3 network cards, all PCNet III adapters, one of this have bridged networking.

If i DISABLE that board anca save the state. If i ENABLE the bridged board the saved state cannot be restored.

comment:18 Changed 5 years ago by parren

Same here, Ubuntu 9.04 64bit host, WinXP SP 3 guest, PCNet-Fast III Host-only adapter and PCNet-Fast III NAT adapter. Disabling the NATed adapter seems to have fixed the problem.

Error message:

Failed to start the virtual machine WinXP.
Unable to restore the virtual machine's saved state from '.../Snapshots/{40200540-be37-402c-b783-93e135743aa3}.sav'.
It may be damaged or from an older version of VirtualBox. 
Please discard the saved state before starting the virtual machine (VERR_SSM_LOAD_CONFIG_MISMATCH).

Details:

Result Code: 
NS_ERROR_FAILURE (0x80004005)
Component: 
Console
Interface: 
IConsole {9511bc54-15ee-4ddf-808e-472aba03809c}

comment:19 Changed 5 years ago by halcwb

I can confirm the problem is in the network card interfaces. I have normally two network cards, one for wired and one for wireless. I disabled the wireless and then I could save and restore state without any problems.

Regards Casper

comment:20 follow-up: ↓ 22 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

comment:21 Changed 5 years ago by TiCPU

Fixed like in SVN and next version of Virtual Box or fixed as if you want to restore use PCNet III, or as this bug is now network related and another bug is open?

comment:22 in reply to: ↑ 20 Changed 5 years ago by RFK

  • Status changed from closed to reopened
  • Resolution fixed deleted

Replying to frank: It's not fixed as far as I am concerned. I still receive the same "Unable to restore the virtual machine's saved state".

comment:23 Changed 5 years ago by frank

RFK, please attach a VBox.log file of such an attempt to restore a saved state.

Changed 5 years ago by RFK

RFK

comment:24 Changed 5 years ago by tim-mattison

I have several Ubuntu images that exhibit this sort of problem but don't give me any error message. I am running Mac OS 10.5.7 and VirtualBox 2.2.2 r47978. When I pause an Ubuntu 64-bit image it goes and saves the state to disk and then as soon as the virtual machine closes it shows "Aborted" in the VirtualBox window.

I will gather some logs and submit them in a few days.

comment:25 Changed 5 years ago by Sasquatch

I have the same problems, using 3 NICs with the Intel adapter. One attached to bridged (wlan, which is no longer connected though), one to internal and the last one to NAT. Log added. I don't have any snapshots on the VM. This is really problematic, as I saved it's state so I could continue on some documents. Luckily, I saved them before sending the VM to saved state, but it's still a big issue. VB 2.2.4, Linux Host, XP Guest. Strangely, a Linux VM doesn't give these errors, while the settings are almost the same. Only difference is one NIC setting, instead of Bridged it's attached to Host-Only. And no USB enabled, compared to the Windows XP VM.

Changed 5 years ago by Sasquatch

2.2.4 failing restore saved state

comment:26 Changed 5 years ago by frank

Sasquatch, did you try 3.0.0 Beta1 by chance? The Beta contains an additional fix regarding this problem

comment:27 Changed 5 years ago by Sasquatch

No, I haven't tried the beta yet, because I need a stable system right now. I will update next week to the beta, but until then, I guess I have to live with it. I might remove the Bridged adapter (hook it to something else) and disable USB and see how that goes.

comment:28 Changed 5 years ago by Sasquatch

I've done a few tests, disabling both USB and changing the bridged adapter to "not attached", then only disabling USB, and as last change the bridged adapter while USB is enabled again. All these scenarios didn't change a thing, it restored just fine. I let the VM go to the logon screen and logged in, both with the same results. Even changing the settings back to how they were didn't cause a failure in restoring the VM state.

Now the only thing that I'm certain off that was different, was that I was using Shared Folders when it failed, and the tests I just did was with a clean boot, nothing opened or anything. Now I can't seem to make it fail again.

comment:29 Changed 5 years ago by frank

Indeed, we believe that this problem is related to shared folders. If someone could install the Beta 2 (just released) and reproduce this problem we would appreciate if one could upload a VBox.log file because we added some logs which might help us finding the problem.

comment:30 Changed 5 years ago by sunlover

  • Status changed from reopened to closed
  • Resolution set to duplicate
  • Version changed from VirtualBox 2.2.2 to VirtualBox 3.0.0
  • Component changed from VMM to shared folders
  • Summary changed from Unable to restore state under certain conditions (VBox 2.2.2) to Unable to restore state under certain conditions (VBox 2.2.2) -> Duplicate of #1595

This is most likely a duplicate of  http://www.virtualbox.org/ticket/1595 The problem with shared folders and saved state has been fixed. The next VBox version will contain the fix.

Changed 5 years ago by derfel

LoadExec failed with rc=VERR_SSM_LOAD_CONFIG_MISMATCH for unit 'pgm'!

comment:31 Changed 5 years ago by derfel

  • Status changed from closed to reopened
  • Resolution duplicate deleted

I've reopened this bug because I don't think it's really fixed.

After the upgrade from Virtualbox 2.x to 3.0.2 the guest (win xp) doesn't resume from the suspended state with the following error:

00:00:19.321 SSM: LoadExec failed with rc=VERR_SSM_LOAD_CONFIG_MISMATCH for unit 'pgm'!

I've attached the vbox-2009-07-26-22-41-17.log file.

comment:32 follow-up: ↓ 35 Changed 5 years ago by sunlover

The problem with shared folders has been fixed. You experienced another problem.

You had a saved state from version 2.x and then tried to load the saved state using VBox 3.0.2, right?

comment:33 Changed 5 years ago by derfel

Yes. Shouldn't Virtualbox convert or read anyway the old saved state?

comment:34 Changed 5 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Yes.

comment:35 in reply to: ↑ 32 Changed 5 years ago by zooko

  • Status changed from closed to reopened
  • Resolution fixed deleted

Replying to sunlover:

The problem with shared folders has been fixed. You experienced another problem.

You had a saved state from version 2.x and then tried to load the saved state using VBox 3.0.2, right?

I seem to be having this "another problem". I'm running Ubuntu, and was using virtualbox-ose 2.1.4-dfsg-1ubuntu3 to run a Windows XP guest. I saved state with that, upgraded to Karmic, and now I have virtualbox-ose 3.0.6-dfsg-1ubuntu1. When I try to resume, I get:

Failed to start the virtual machine wxp.

Unable to restore the virtual machine's saved state from '/home/zooko/.VirtualBox/Machines/wxp/Snapshots/{aaa9de2e-7d47-4baf-98f2-6726b3533cb4}.sav'. It may be damaged or from an older version of VirtualBox. Please discard the saved state before starting the virtual machine (VERR_SSM_LOAD_CONFIG_MISMATCH).

Details: Result Code:

NS_ERROR_FAILURE (0x80004005) Component: Console Interface: IConsole {0a51994b-cbc6-4686-94eb-d4e4023280e2}

I've opened a ticket with Ubuntu here:  https://bugs.launchpad.net/ubuntu/+source/virtualbox-ose/+bug/447558

frank: I don't understand what you mean by saying "Yes" and closing this ticket. Is there a different ticket for this problem? Is saving with 2 and resuming with 3 a wontfix?

Thanks!

comment:36 Changed 5 years ago by zooko

I added a note to  https://bugs.launchpad.net/virtualbox/+bug/447558/comments/2 sketching out how I worked-around this by downgrading to the older virtualbox and shutting down the guest.

comment:37 Changed 5 years ago by oefe

I have a similar problem after upgrading from VirtualBox 2.1.2 to 3.08. Host is Mac OS X 10.6, Guest Windows 2000 VM had no audio, no USB, no CD-ROM...

The log contains the same message: SSM: LoadExec failed with rc=VERR_SSM_LOAD_CONFIG_MISMATCH for unit 'pgm'!

After downgrading to VB 2.1.2 the VM works again.

Changed 5 years ago by oefe

Log file with the error

comment:38 Changed 4 years ago by sandervl73

  • Summary changed from Unable to restore state under certain conditions (VBox 2.2.2) -> Duplicate of #1595 to Unable to restore state under certain conditions (VBox 2.2.2) -> fixed in SVN/3.0.10

comment:39 Changed 4 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use