VirtualBox

Ticket #2741 (closed defect: worksforme)

Opened 5 years ago

Last modified 4 years ago

XP guest hangs during boot when EHCI enabled

Reported by: oudalrich Owned by:
Priority: major Component: USB
Version: VirtualBox 2.0.6 Keywords: USB, EHCI
Cc: Guest type: Windows
Host type: Linux

Description

When EHCI is enabled, the Windows XP guest on my Ubuntu 8.10 host fails to boot. It displays the Windows logo with the progress bar below it for a few seconds, then the screen turns black and nothing happens any more. One core of the guest system is pegged at 100% until I power off the VM.

The problem was reported in the forum a while ago (with logs):  http://forums.virtualbox.org/viewtopic.php?t=4695&highlight=ehci+boot

My log is in the attachment.

Attachments

VBox.log Download (53.6 KB) - added by oudalrich 5 years ago.
VBox.2.log Download (50.9 KB) - added by firecat53 5 years ago.

Change History

Changed 5 years ago by oudalrich

comment:1 Changed 5 years ago by firecat53

Exact same problem. I'm using an existing XP installation using the raw image. XP will boot fine with USB 1 enabled, but after selecting USB 2.0, it will freeze on bootup. It will boot in safe mode and allow me to remove the USB controller, but then when it detects the new hardware on a subsequent boot, the VM will freeze. I've attached my Vbox.log as well.

FYI, system is Archlinux 64 bit, with Virtualbox 2.1.0 (this behavior has been unchanged since I first created the VM 6 months ago with an earlier version of Virtualbox).

Scott

Changed 5 years ago by firecat53

comment:2 Changed 5 years ago by kronenpj

I believe I'm seeing the same behavior. My VM was migrated from VMware Server 1.x but I haven't investigated a fresh installation. I'll try that very soon.

comment:3 Changed 5 years ago by kronenpj

Fresh installation works fine. As does the existing installation if EHCI is disabled. I just now tried removing the EHCI devices by displaying hidden devices within device manager and rebooting. Windows freezes depending on which devices are removed, so that's not helping.

I did notice that the freeze occurs just before the EHCI controller is suspended.

Unsuccessful run (Windows freezes): 00:00:50.568 OHCI: Software reset 00:00:50.568 OHCI: USB Reset 00:00:50.569 OHCI: USB Operational 00:00:51.124 EHCI: Hardware reset 00:00:51.125 EHCI: USB Operational 00:00:51.327 SharedFolders host service: connected, u32ClientID = 1 (reset)

Successful run (Windows works fine): 00:02:24.271 OHCI: Software reset 00:02:24.271 OHCI: USB Reset 00:02:24.271 OHCI: USB Operational 00:02:24.829 EHCI: Hardware reset 00:02:24.830 EHCI: USB Operational 00:02:25.035 SharedFolders host service: connected, u32ClientID = 2 00:02:26.605 EHCI: USB Suspended ...

Both Windows installations use this driver for EHCI support: Intel 82801FB/FBM USB2 Enhanced Host Controller - 265C

I hope this is useful! -Paul

comment:4 Changed 4 years ago by Technologov

This bug looks similar to bug #2907

-Technologov

comment:5 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to worksforme

No reaction for along time. Please reopen if it still applies to 3.0.10 or newer.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use