VirtualBox

Opened 16 years ago

Closed 15 years ago

Last modified 14 years ago

#2676 closed defect (fixed)

Selecting a virtual machine must not start it automatically => Fixed in SVN

Reported by: Ronny Standtke Owned by:
Component: GUI Version: VirtualBox 2.0.6
Keywords: Cc:
Guest type: other Host type: Linux

Description

I am using VirtualBox on Kubuntu-8.04.1. If I select any virtual machine in the large left hand side list with a single click of the left mouse button the virtual machine starts up automatically. This is really annoying if e.g. you just want to check the settings of a virtual machine without starting it. This is a major usability issue. This is also a regression because previous versions of VirtualBox did not have this bug.

Attachments (1)

VBoxSelectorWnd.patch (623 bytes ) - added by Bogdan Mustiata 15 years ago.
VBoxSelectorWnd.cpp patch

Download all attachments as: .zip

Change History (20)

comment:1 by Frank Mehnert, 16 years ago

This does apparently only happen with Kubuntu as far as I can say.

comment:2 by Dirck, 15 years ago

Same with OpenSuse-11.1 (x86_64) and VirtualBox 2.1.0

comment:3 by sehe, 15 years ago

Same on intrepid, Gnome, VBox 2.1.2

Very annoying. It is practically impossible to go to 'settings' without accidentally booting/restoring a VPC

comment:4 by Frank Mehnert, 15 years ago

We cannot reproduce this on Intrepid/Gnome. Any special mouse setting?

comment:5 by sehe, 15 years ago

Nope, most certainly not. I despise single-click (or for that matter, mousing in general) in all contexts.

If you are looking for specific config files, I might upload them.

Thanks, Seth

comment:6 by sehe, 15 years ago

Additionally: I can vouch that previous versions (I think <2.1) did not have this problem on the exact same machine. I hardly if ever change desktop settings, so I'm pretty sure I didn't switch this behaviour on myself, even apart from the above arguments why this would be wholly unlikely.

Cheers

comment:7 by Dirck, 15 years ago

Nothing changed on OpenSuse-11.1 (x86_64), KDE and VirtualBox 2.1.2

comment:8 by Frank Mehnert, 15 years ago

We can reproduce it on some hosts. I've seen this on one Ubuntu 8.10 (GNOME) host (one click starts the VM), on another host, a double click is required to start a VM. Must be some setting somewhere. The reason for this behavior is the definition of this signal.

comment:9 by Frank Mehnert, 15 years ago

Btw, with another host I meant another Ubuntu 8.10 (GNOME) host.

comment:10 by Javier Ariza, 15 years ago

The some here , with VirtualBox 2.1.2 in Kubuntu Intrepid (with kde 4.2.00). VirtualBox package downloaded from Virtualbox site. Linux PC 2.6.27-11-generic #1 SMP Thu Jan 29 19:24:39 UTC 2009 i686 GNU/Linux

comment:11 by Javier Ariza, 15 years ago

Ah, nothing especial with mouse. Work ok in all another apps.

comment:12 by Dirck, 15 years ago

Same behavior with VirtualBox 2.1.4

comment:13 by Dirck, 15 years ago

For technical reasons (hardware and (virtual-)disks movement) I reinstalled the host-environment (OpenSuse-11.1 (x86_64), KDE 3.5), made all the recommended updates and installed VirtualBox 2.2.0 in this sequence : The bug(?) is gone. One click selects the machine, a doubleclick starts the machine.

comment:14 by Bogdan Mustiata, 15 years ago

Same behaviour with VirtualBox 3.0.6 (deb provided from website), and 3.0.10 sources compiled, under kubuntu 9.04. It probably depends on some deep setting inside QT libraries and is only triggered in certain circumstances. On my system it happens all the time.

Actually I saw that a workaround was done in order to circumvent this by setting the style (in src/VBox/Frontends/VirtualBox/src/VBoxSelectorWnd.cpp, lines 502-506, at revision 16490 from SVN).

While the spirit of the fix is good, the problem is the setting the value by using an invalid CSS statement (without specifying the value). Namely it should be:

mVMListView->setStyleSheet ("activate-on-singleclick : 0");

instead of

mVMListView->setStyleSheet ("activate-on-singleclick");

as it is now.

Probably the version without the value is simply ignored by QT. Having that change, it works.

I'm going to attach also a patch file.

by Bogdan Mustiata, 15 years ago

Attachment: VBoxSelectorWnd.patch added

VBoxSelectorWnd.cpp patch

comment:15 by Bogdan Mustiata, 15 years ago

The unpatched version exhibits the same problem under kubuntu 9.10.

comment:16 by Frank Mehnert, 15 years ago

Summary: selecting a virtual machine must not start it automaticallySelecting a virtual machine must not start it automatically => Fixed in SVN

Thank you for this information, this small fix seems indeed to work!

comment:17 by Bogdan Mustiata, 15 years ago

I've updated my sources from svn and as of rev. 24253 which is HEAD, the change is not there.

comment:18 by Frank Mehnert, 15 years ago

r24263 from yesterday. Note that the external subversion repository isn't synchronized immediately so changes will take some time until they will be public visible.

comment:19 by Frank Mehnert, 15 years ago

Resolution: fixed
Status: newclosed

Fixed in 3.0.12.

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use