VirtualBox

Ticket #2675 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

VirtualBox 2.0.6 crashes on Copy (before any Paste) -> fixed in SVN

Reported by: p2k Owned by:
Priority: critical Component: clipboard
Version: VirtualBox 2.0.6 Keywords: segfault copy
Cc: Guest type: Windows
Host type: Linux

Description

Copying text on the host side frequently crashes the guest.

Here's the dmesg log:

[174179.337994] VirtualBox[31593]: segfault at 9ed52ec ip b7d1abee sp b40fbd0c error 4 in libc-2.8.90.so[b7caa000+158000]

Some information about my system:

$ uname -a
Linux mydesktop 2.6.27-10-generic #1 SMP Fri Nov 21 12:00:22 UTC 2008 i686 GNU/Linux

$ cat /etc/issue
Ubuntu 8.10 \n \l

$ cat /etc/apt/sources.list.d/virtualbox.list
deb http://download.virtualbox.org/virtualbox/debian intrepid non-free

I've started my VM with :

$ echo -n 1 | sudo tee /proc/sys/fs/suid_dumpable
$ ulimit -c unlimited
$ /usr/lib/virtualbox/VirtualBox -startvm "Windows"

and will post my coredump when I get one.

Regards, Patrick.

Change History

comment:1 Changed 5 years ago by michael

A core dump would be very helpful, thanks! I take it from the information above that you are using the Intrepid debs from Sun.

comment:5 Changed 5 years ago by p2k

That's it:

$ apt-cache show virtualbox-2.0 
Package: virtualbox-2.0
Version: 2.0.6-39765_Ubuntu_intrepid
Architecture: i386
Maintainer: Sun Microsystems, Inc. <info@virtualbox.org>
Installed-Size: 64036
Pre-Depends: debconf (>= 1.1) | debconf-2.0
Depends: libc6 (>= 2.4), libgcc1 (>= 1:4.1.1), libqt4-network (>= 4.4.3), libqtcore4 (>= 4.4.3), libqtgui4 (>= 4.4.3), libsdl1.2debian (>= 1.2.10-1), libssl0.9.8 (>= 0.9.8f-5), libstdc++6 (>= 4.2.1), libx11-6, libxcursor1 (>> 1.1.2), libxext6, libxml2 (>= 2.6.27), libxslt1.1 (>= 1.1.18), libxt6, python2.5 (>= 2.5), psmisc, adduser
Recommends: libasound2, libpulse0, libsdl-ttf2.0-0, dkms, linux-headers, gcc, make, binutils, bridge-utils, uml-utilities, libhal1 (>= 0.5), pdf-viewer
Conflicts: virtualbox
Replaces: virtualbox
Provides: virtualbox
Priority: optional
Section: misc
Filename: pool/non-free/v/virtualbox-2.0/virtualbox-2.0_2.0.6-39765_Ubuntu_intrepid_i386.deb
Size: 30152018
SHA1: bdda18265f9c0f21a22a0cd2cb8acbff23879f8c
MD5sum: c5653bbabed78fb97858e127375cd6cd
Description: Sun xVM VirtualBox
 VirtualBox is a powerful PC virtualization solution allowing you to run a
 wide range of PC operating systems on your Linux system. This includes
 Windows, Linux, FreeBSD, DOS, OpenBSD and others. VirtualBox comes with a broad
 feature set and excellent performance, making it the premier virtualization
 software solution on the market.

I just noticed it crashes in different places, so there may be several problems:

[75836.026152] VirtualBox[5887]: segfault at 90 ip b5f93c06 sp b419a250 error 6 in VBoxC.so[b5f1f000+9b000]
[90152.398766] VirtualBox[12883]: segfault at 94 ip b6061c06 sp b4257250 error 6 in VBoxC.so[b5fed000+9b000]
[95994.162673] VirtualBox[26127]: segfault at 11e ip b6099c06 sp b428f250 error 6 in VBoxC.so[b6025000+9b000]
[174179.337994] VirtualBox[31593]: segfault at 9ed52ec ip b7d1abee sp b40fbd0c error 4 in libc-2.8.90.so[b7caa000+158000]

comment:6 Changed 5 years ago by p2k

Another crash :

[145406.931335] VirtualBox[6174]: segfault at a2 ip b6042c06 sp b4238250 error 6 in VBoxC.so[b5fce000+9b000]

No coredump for now, as I rebooted recently and restarted VirtualBox but forgot to relaunch it so that I would get one...

comment:7 Changed 5 years ago by p2k

Could that be related to the fact that my Windows guest is running the Sun xVM virtualbox Guest Additions version 2.0.2 ? How can I upgrade this component?

comment:8 Changed 5 years ago by michael

Nothing the guest can do should cause segfaults on the host, but you can upgrade the additions by following the instructions in the user manual.

comment:9 Changed 5 years ago by frank

Sorry, without a core dump it is really difficult to find the reason.

comment:10 Changed 5 years ago by michael

For what it is worth, though, that looks like the line '*ppMsg = pMsg;' in 'int HGCMThread::MsgGet (HGCMMsgCore ppMsg)'.

comment:11 Changed 5 years ago by p2k

I just got another crash :

[493577.539451] VirtualBox[11733]: segfault at a0 ip b6003c06 sp b420a250 error 6 in VBoxC.so[b5f8f000+9b000]

This time, I ended up with a 600MB core file. As it may contain some sensible information, I'd rather not publish it on a public address. How should I send it to you ?

comment:12 Changed 5 years ago by p2k

Core file virtualbox-2.0.6-39765_Ubuntu_intrepid_i386-core.11723.bz2 uploaded

comment:13 Changed 5 years ago by frank

One additional question: Did you ever tried an older version of VirtualBox, that is, did you ever saw a clipboard crash with VirtualBox 2.0.4?

comment:14 Changed 5 years ago by p2k

I have previously been using versions 2.0.2 and 2.0.4 without ever seeing such a crash.

comment:15 Changed 5 years ago by frank

Interesting. How likely is it that this bug just did not show up with 2.0.4? Did you use 2.0.4 as extensive as you are using version 2.0.6?

comment:16 Changed 5 years ago by p2k

I've been using VirtualBox-2 several hours per day since september 23rd 2008.

Here's my virtualbox installation history on this box :

$ zgrep virtualbox /var/log/aptitude*
/var/log/aptitude.3.gz:[INSTALLED] virtualbox-2.0
/var/log/aptitude.2.gz:[UPDATED] virtualbox-2.0 2.0.2-36488_Ubuntu_hardy -> 2.0.4-38406_Ubuntu_hardy
/var/log/aptitude.1.gz:[UPDATED] virtualbox-2.0 2.0.4-38406_Ubuntu_hardy -> 2.0.4-38406_Ubuntu_intrepid
/var/log/aptitude.1.gz:[UPDATED] virtualbox-2.0 2.0.4-38406_Ubuntu_intrepid -> 2.0.6-39765_Ubuntu_intrepid

comment:17 Changed 5 years ago by p2k

Yet another crash :

[669422.877158] VirtualBox[11002]: segfault at 98f3c24 ip b7d3ebee sp b411fd1c error 4 in libc-2.8.90.so[b7cce000+158000]

Could that be related to the fact that I also have a  Synergy server on the host that interacts with the clipboard?

comment:18 Changed 5 years ago by p2k

Core file virtualbox-2.0.6-39765_Ubuntu_intrepid_i386-core.10976.bz2 is being uploaded

comment:19 Changed 5 years ago by p2k

And another one:

[678436.499113] VirtualBox[11740]: segfault at 118 ip b6063c06 sp b426a250 error 6 in VBoxC.so[b5fef000+9b000]

comment:20 Changed 5 years ago by frank

Patrick, do you still have the VBox.log file available which was generated when you got the 2nd core dump you uploaded today? Or do you have a VBox.log file available from any of such crashes?

comment:21 Changed 5 years ago by p2k

Sure, log files uploaded as virtualbox-2.0.6-39765_Ubuntu_intrepid_i386-p2k-Logs.tar.bz2.

comment:22 Changed 5 years ago by p2k

Another one:

[758527.873844] VirtualBox[26096]: segfault at 3f3c ip b5ff5c06 sp b40ff250 error 6 in VBoxC.so[b5f81000+9b000]

comment:23 Changed 5 years ago by sunlover

Patrick, the problem could be indeed caused by the old guest additions. Please upgrade them to 2.0.6. Check the UserManual "4.2.1 Installing the Windows Guest Additions".

comment:24 Changed 5 years ago by p2k

Alright, I've upgraded the guest additions to 2.0.6.

comment:25 Changed 5 years ago by p2k

Crash on another Ubuntu 8.10 system with a fresh Windows XP install and 2.0.6 version of guest additions software:

[496412.165812] VirtualBox[1999]: segfault at f0 ip b605dc06 sp b4253250 error 6 in VBoxC.so[b5fe9000+9b000]

FWIW, synergy is not installed on this system.

comment:26 Changed 5 years ago by p2k

And another one:

[497308.183643] VirtualBox[20925]: segfault at 8cc ip b6088c06 sp b427e250 error 6 in VBoxC.so[b6014000+9b000]

comment:27 Changed 5 years ago by p2k

Another crash on copy/paste:

[73487.079557] VirtualBox[6147]: segfault at 42 ip b5fafc06 sp b41b6250 error 6 in VBoxC.so[b5f3b000+9b000]

comment:28 Changed 5 years ago by p2k

I just upgraded to VirtualBox 2.1.0 and also have updated my guest additions:

$ apt-cache show virtualbox-2.1
Package: virtualbox-2.1
Version: 2.1.0-41146_Ubuntu_intrepid
Architecture: i386
Maintainer: Sun Microsystems, Inc. <info@virtualbox.org>
Installed-Size: 70780
Pre-Depends: debconf (>= 1.1) | debconf-2.0
Depends: libc6 (>= 2.4), libcap1, libgcc1 (>= 1:4.1.1), libqt4-network (>= 4.4.3), libqtcore4 (>= 4.4.3), libqtgui4 (>= 4.4.3), libsdl1.2debian (>= 1.2.10-1), libssl0.9.8 (>= 0.9.8f-5), libstdc++6 (>= 4.2.1), libx11-6, libxcursor1 (>> 1.1.2), libxext6, libxml2 (>= 2.6.27), libxmu6, libxslt1.1 (>= 1.1.18), libxt6, python2.5 (>= 2.5), psmisc, adduser
Recommends: libasound2, libpulse0, libsdl-ttf2.0-0, dkms, linux-headers, gcc, make, binutils, libhal1 (>= 0.5), pdf-viewer, libgl1
Conflicts: virtualbox
Replaces: virtualbox
Provides: virtualbox
Priority: optional
Section: misc
Filename: pool/non-free/v/virtualbox-2.1/virtualbox-2.1_2.1.0-41146_Ubuntu_intrepid_i386.deb
Size: 35961446
SHA1: f2a183b63118621cec97ac81d6eeb4ea9ce99c6f
MD5sum: 4c12e11beabaab9b5b9f2bc3b2c45645
Description: Sun xVM VirtualBox

I'll keep you informed if crashes still occur.

Regards, Patrick.

comment:29 Changed 5 years ago by michael

I would certainly be interested to know. We haven't actually done anything yet that would be likely to fix this, but I suspect that it is timing-related, so 2.10 may still make it go away.

comment:30 Changed 5 years ago by michael

  • Summary changed from VirtualBox 2.0.6 crashes on Copy (before any Paste) to VirtualBox 2.0.6 crashes on Copy (before any Paste) -> fixed in SVN

I hope that the latest SVN sources (publicly available as of tonight sometime) will fix this issue.

comment:31 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use