VirtualBox

Ticket #2666 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

Serial port option prohibits saving settings even when serial port disabled => Fixed in SVN

Reported by: bleh Owned by:
Priority: minor Component: GUI
Version: VirtualBox 2.0.6 Keywords:
Cc: Guest type: other
Host type: other

Description (last modified by frank) (diff)

If a Serial Port is disabled, it is expected that even if it contains invalid settings, it will not prohibit saving guest settings.

To reproduce:

  1. Open settings for any guest
  2. Select "Serial Ports" in left pane
  3. Check "Enable Serial Port"
  4. For Port Mode, select "Host Pipe" and note that status reads "Invalid settings detected"
  5. Uncheck "Enable Serial Port"
  6. Note that the OK button is grayed out.

Change History

comment:1 Changed 5 years ago by frank

  • Host type changed from Windows to other
  • Description modified (diff)

comment:2 Changed 5 years ago by frank

  • Summary changed from Serial port option prohibits saving settings even when serial port disabled to Serial port option prohibits saving settings even when serial port disabled => Fixed in SVN

The reason for this check is that we store the parameters even if the port is disabled. This way a port can be disabled temporarily without loosing the parameters. Fixed the check in SVN.

comment:3 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use