VirtualBox

Ticket #2667 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Having a SATA disk crashes Virtualbox at high disk activity

Reported by: arvind_cse Owned by:
Priority: major Component: virtual disk
Version: VirtualBox 2.0.6 Keywords: SATA CRASHES VIRTUALBOX
Cc: Guest type: Linux
Host type: Windows

Description

Hi, I have installed virtual box (2.0.2,2.0.4,2.0.6) on windows xp host. Installed Ubuntu guest. Virtual box keeps crashing when i use SATA drive and try to run some disk intensive applications (Like installing oracle in the SATA drive). Have tried the same with Ubuntu 8.04 and 8.10 with all the above 3 mentioned versions of virtual box. Removing the SATA and having only IDE seems to be working fine without any issues.

Figured this issue to be with the SATA drives after so many permutation and combination of virtual box configurations and guest OS.

Attachments

Logs.zip Download (197.4 KB) - added by arvind_cse 5 years ago.
Logs of the Vbox having sata disk and crashing
Logs.2.zip Download (68.4 KB) - added by arvind_cse 5 years ago.
Logs_11282008

Change History

Changed 5 years ago by arvind_cse

Logs of the Vbox having sata disk and crashing

comment:1 Changed 5 years ago by aeichner

Can you try to increase the hyper heap RAM with VBoxManage setextradata <vmname> "/VBoxInternal/MM/cbHyperHeap" "2048000" or lower the RAM you assigned to the VM?

The only crash I have seen from the logs you provided is the Guru Meditation in VBox.log.1. The assertion which failed showed and out of memory condition.

If my guess is right than it crashes only with SATA controller enabled because the SATA controller needs some memory to operate too. While running the VM the guest will use more and more of the RAM it sees which is about 1.5GB in your config and the hypervisor needs some memory to make the memory accessible to the guest.

This error would also occur if it would be possible to have more than one IDE controller and is not a bug in the SATA controller as far as I can tell. To be sure can you provide some logs with version 2.0.6? Your logs are all from 2.0.2. Thank you.

Changed 5 years ago by arvind_cse

Logs_11282008

comment:2 Changed 5 years ago by arvind_cse

Hi, As suggested i made the changes(installed Virtualbox 2.0.6 and added cbHyperHeap) and had no issues till now(approx 8 hrs operation). But now again Vbox crashed giving the Guru Meditation. I have attached the log with description logs_11292008. Also this happened when i tried to plug in a usb drive. Not sure if this crash happened due to the USB. Any help would be appreciated.

comment:3 Changed 5 years ago by aeichner

The cause is the same. Seems the value of 2048000 for the heap is still not enough in your case. You can try to increase it further until it works. The value you specify should be a multiple of 4096.

comment:4 Changed 5 years ago by sandervl73

  • Priority changed from minor to major

comment:5 Changed 5 years ago by aeichner

  • Status changed from new to closed
  • Resolution set to fixed

This should be fixed since 2.2 actually. Closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use