VirtualBox

Ticket #2665 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Must paste into host first before cut and paste works

Reported by: annicoran1 Owned by:
Priority: minor Component: clipboard
Version: VirtualBox 2.1.2 Keywords:
Cc: Guest type: other
Host type: other

Description

Virtualbox 2.0.6 on Windows Vista 32bit sp1. After first installing virutalbox, and a linux guest (tried this with fedora 9, sles10, opensuse 11....same on all)...if I try to cut and paste from guest to host (ie from gedit to notepad), it doesn't work...paste doesn't show up as an option.

If I try cutting and pasting from host to guest, this works fine...and I can then copy from guest to host.

Change History

comment:1 Changed 5 years ago by war59312

Confirmed with Fedora 10 on Windows XP Pro. SP3 x86..

comment:2 Changed 5 years ago by michael

Is this still occuring with the current version of VirtualBox?

comment:3 Changed 5 years ago by war59312

Sadly yes. Still happening with XP SP3 and Win7 Beta 1 with VirtualBox 2.1.2

comment:4 Changed 5 years ago by michael

war59312: do you mean with both XP SP3 and Win7 Beta 1 hosts, or is one of those a guest?

comment:5 Changed 5 years ago by war59312

Host or guest, does not seem to matter. :(

comment:6 Changed 5 years ago by michael

  • Version changed from VirtualBox 2.0.6 to VirtualBox 2.1.2

You misunderstood me. I would like to be sure which combination(s) of host system(s) and guest system(s) you see this issue with. Since Windows and Linux hosts and guests use different clipboard code in many places, knowing this should help us to identify the problem.

comment:7 Changed 5 years ago by alandhae

I'm running VB 2.1.2 on Opensuse 10.3 two guests:
Opensuse 11.0
WinXP SP3

I've observed following behaviour:
Cut/Paste from host <-> WinXP guest is working
Cut/Paste between guests is working
Cut/Paste to/from Linux guest is NOT working.
both guests have bidirectional clipboard enabled.

comment:8 Changed 5 years ago by war59312

Guest (Win7 beta 1 x86) Cant Copy To Host (Vista SP1 x86) Guest (WinXP SP3 x86) Cant Copy To Host (Vista SP1 x86) Guest (Fedora 10 x86) Cant Copy To Host (WinXP SP3 x86)

Like original post says if I then copy from host to guest now above work just fine.

comment:9 Changed 5 years ago by michael

war59312: could you also attach a log file after running one of the guests on which copying failed? Thanks.

comment:10 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen this ticket if the problem persists with VirtualBox 2.2.2. Make sure to attach a suitable VBox.log file in that case.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use