VirtualBox

Ticket #2592 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

Can't change shared file read-only attribute

Reported by: TwoBit Owned by:
Priority: major Component: shared folders
Version: VirtualBox 2.0.4 Keywords:
Cc: Guest type: Windows
Host type: other

Description

A Windows client using a shared folder from a Windows host is unable to change the read-only attribute of files on the host. Reproducibility is simple: Open Windows Explorer on the client, select a file on the host and right-click to bring up its properties. Change the read-only checkbox and click the OK button. This has no effect.

Change History

comment:1 Changed 5 years ago by Ohmu

I'm having the same problem. I've reported it  here:

I'll paste the post for convenience:

VirtualBox 1.5.6_OSE Host: Ubuntu Heron Guest: Vista SP1 Guest Addns installed

In Ubuntu host I've created /my/share/ and done chmod a+rwx /my/share

In VirtualBox settings, I've set this to my shared folder & ensured 'Read Only' attribute is unset.

In Vista SP1 client, I have mapped this to my Y: drive

I point Windows Explorer to Y:, right click, Create New Folder (Minor)Problem: It's invisible. Needs a rightclick+refresh to see it.

Major Problem: Right click on it, Properties: its 'Read Only' attribute is set. I clear it, Apply, ok. Now I bring up the properties again. It has reverted!!!

Total mystery. I can write files into this folder. I can create an empty doc, type into it, save it.

This problem is affecting me because I need to set Visual Studio to build into the shared folder: Y:\ReleaseBuild\ and Visual Studio is not allowing it, presumably as it sees it as readonly.

Please someone fix!!!

Sam|Ohmu

comment:2 Changed 5 years ago by Ohmu

This ticket's component field should be set to:Guest Additions / Share I don't want to create a new ticket there. Can someone change it here?

comment:3 Changed 5 years ago by sandervl73

  • Component changed from other to shared folders

comment:4 Changed 5 years ago by sandervl73

  • Guest type changed from other to Windows

comment:5 Changed 5 years ago by i-nZ

I am experiencing the same problem with VirtualBox 2.2.0 on a Linux 32bit host and a Windows XP SP3 guest

comment:6 Changed 5 years ago by AliBaba

I can confirm that problem.

File permissions won't be remembered and applications (except Explorer) can't write to the Shared Folder.

Linux host, XP SP3 guest.

comment:7 Changed 5 years ago by Zawullon

This bug still present in new Virtual Box 3.0. In Virtual Box 2.2 I work with files normally, but after update I can`t save files from Lazarus to shared folder because any file on create (or write changes) from Lazarus has 400 permissions. Host: Ubuntu 8.04.2 Client: Windows XP SP3

comment:8 follow-up: ↓ 9 Changed 5 years ago by meah

Same behaviour on Ver 3.0 Host: Fedora 9 Guest: W2K (see ticket #3712).

copy with Explorer creates 664 copy with totalcommander creates 400 - delete of the files from totalcommander is possible copy with cmd creates 400 - delete of the files from cmd is possible

comment:9 in reply to: ↑ 8 Changed 5 years ago by coffeemonk

Seeing the read-only bug on VirtualBox 3.0.0, Ubuntu 9.04 host, Windows XP Pro SP3 guest.

This was working fine prior to VirtualBox 3.0 upgrade, now the main software I use cannot save updated versions of its existing project files to my shared folder, and I cannot change the read-only setting of the hosts's shared folders/files.

This bug is threatening to make VirtualBox useless to me, as this is pretty much the only software I run in VirtualBox. I may investigate reverting to an older version if this doesn't get addressed soon.

Also, I removed Guest Additions v3.x and installed Guest Additions v2.1.4 as suggested by others and in other discussions of related bugs, but this had no affect for me.

comment:10 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #4381.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use