VirtualBox

Ticket #2593 (closed defect: worksforme)

Opened 5 years ago

Last modified 4 years ago

Virtualbox crashes with message "Consider BIOS upgrade"

Reported by: dlandmj Owned by:
Priority: major Component: other
Version: VirtualBox 2.0.4 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

I just installed Virtualbox within Kubuntu Hardy to run Windows XP.

The Windows XP works fine - except that it crashes frequently and, as far as I can see so far, randomly.

When I "send an error report" to Microsoft, I get the message below. I posted this on the Virtualbox forums, and got the suggestion I should try a memory test on the (physical) machine. I did, and the memory is all right.

Any thoughts?

Consider BIOS upgrade

Microsoft is unable to determine the exact cause of this error. However, this problem was most likely caused by an error in your computer’s random access memory (RAM). RAM is the main internal storage area the computer uses to run programs and store data.

During the crash analysis, we noticed the basic input/output (BIOS) system version on this computer does not match the specifications for the central processing unit (CPU), also known as a processor, that is installed on your computer. This can occur when a newer processor is installed on an older system board or older BIOS. Using a BIOS that does not support the installed processor can result in Windows system crashes. Contact your computer manufacturer or motherboard manufacturer for an updated version of BIOS for your computer's processor.

How do I find my computer manufacturer (OEM)?

Click Start, click Run, type msinfo32, and then click OK. Your computer OEM is listed as the System Manufacturer in the right pane of the System Information window.

Click to go online to see contact information for most computer manufacturers

Additional information

Note

Upgrading the BIOS version may require moderate to advanced troubleshooting skills. If you are uncomfortable with performing these steps, you might want to consider consulting with paid technical support.

If your computer contains an Intel processor, you can use special utilities to identify your specific processor. Click the following link to go online for more information: Intel Processor Identification Utility

Attachments

Magenta-2009-04-29-13-54-21.log Download (50.5 KB) - added by kaydub 5 years ago.
VBox.log file, have more if error not found here.
VBox.log Download (36.4 KB) - added by kaydub 5 years ago.
Another log to hopefully indicate the problem.

Change History

comment:1 Changed 5 years ago by dlandmj

I think I've fixed this, but if I have, then something should be changed in Virtualbox.

I just increased the memory allocation for Virtualbox from the "recommended" 192MB to 256MB, and the frequent crashes stopped.

Looks like Virtualbox should "recommend" more than 192MB.

Thanks.

comment:2 Changed 5 years ago by kaydub

I have same problem, running Windows XP Pro in VirtualBox on Ubuntu Intrepid Ibex (2.6.27-9-generic) and everything is perfect except for the random BSoD crashes. I have allocated 512MB of memory to my VirtualBox.

They only occur once everytime I boot the machine up. As my computer is a notebook I do shutdown the whole system pretty much daily to move back and forth from my office/home-office. The crash occurs whether I save the machine state, or shutdown completely. When I "send an error report" to Microsoft, I get the same message asking me to consider BIOS upgrade.

Thanks.

comment:3 Changed 5 years ago by kaydub

bump?

This is still happening to me, I am now using Jaunty as my host and VirtualBox 2.2.2 r46594. Everything runs smoothly, until eventually it blue screens / restarts and tries to send an error report to microsoft upon restart which leaves me with this page:

 http://wer.microsoft.com/responses/Response.aspx/1445/en-us/5.1.2600.2.00010100.3.0?SGD=25be380a-2027-4631-8685-8ee41cd91f3e

comment:4 Changed 5 years ago by frank

kaydub, please attach a VBox.log file of such a session. We were never able to reproduce this bug.

Changed 5 years ago by kaydub

VBox.log file, have more if error not found here.

Changed 5 years ago by kaydub

Another log to hopefully indicate the problem.

comment:5 Changed 5 years ago by kaydub

Happens at least twice a day, more often when pausing/resuming .. noticed this message in dmesg this time when it happened, not sure if its related..

"[ 2022.144445] warning: `VirtualBox' uses 32-bit capabilities (legacy support in use)"

comment:6 Changed 5 years ago by frank

kaydub, you can ignore that warning, it is harmless and expected. Regarding your real problem: Your Windows guest crashes from time to time but if I understood you correctly, only the guest, not the VM itself, correct?

Did you check any later version of VirtualBox (2.2.4 or 3.0.2)? Any hint to reproduce the problem?

comment:7 Changed 4 years ago by Technologov

No response, please close.

-Technologov

comment:8 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to worksforme
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use