VirtualBox

Opened 15 years ago

Closed 15 years ago

Last modified 14 years ago

#2461 closed defect (fixed)

VM Freeze while copying within shared folder

Reported by: Nick Hemsley Owned by:
Component: shared folders Version: VirtualBox 2.0.4
Keywords: freeze Cc:
Guest type: Windows Host type: Linux

Description

I am using ubuntu 8.04, running Vista as a guest OS. I am getting freezes when attempting to compile a .net project using nant.

I have narrowed it down to copying the file Nullables.Nhibernate.pdb (which I will attach), from one part of the shared filesystem to another.

This bug seems to be related to http://www.virtualbox.org/ticket/2055. However, neither 2.0.2 or the attached vboxsf.sys work.

I have attached 2 log files, one for the 2.0.2 version of vboxsf.sys (vbox.log), which causes a Guru Meditation, and one with the vboxsf.sys attached in ticket 2055 (Vbox.log.crash-with-trac-vbox.sys-file) which just freezed the system and causes video corruption.

I will attached the file that causes this bug, Nullables.Nhibernate.pdb.

Attachments (6)

Vbox.log.crash-with-trac-vbox.sys-file (50.1 KB ) - added by Nick Hemsley 15 years ago.
vbox.log with vboxsf.sys from ticket #2055
VBox.log (210.8 KB ) - added by Nick Hemsley 15 years ago.
vbox.log with 2.0.2 version of vboxsf.sys, Guru Meditation
VBox.png (17.5 KB ) - added by Nick Hemsley 15 years ago.
screenshot taken by GM with 2.0.2 version of vboxsf.sys
Nullables.NHibernate.pdb (71.5 KB ) - added by Nick Hemsley 15 years ago.
files.zip (248.3 KB ) - added by Nick Hemsley 15 years ago.
Files which cause problem when copying using xcopy
VBoxSF.sys (186.6 KB ) - added by sunlover 15 years ago.
Updated fix for xcopy /e Vista guest crash. For VBox 2.0.x.

Download all attachments as: .zip

Change History (12)

by Nick Hemsley, 15 years ago

vbox.log with vboxsf.sys from ticket #2055

by Nick Hemsley, 15 years ago

Attachment: VBox.log added

vbox.log with 2.0.2 version of vboxsf.sys, Guru Meditation

by Nick Hemsley, 15 years ago

Attachment: VBox.png added

screenshot taken by GM with 2.0.2 version of vboxsf.sys

by Nick Hemsley, 15 years ago

Attachment: Nullables.NHibernate.pdb added

comment:1 by Nick Hemsley, 15 years ago

Also, this bug only happens when I am using the copy, or xcopy command (also nant's copy). Copying with Explorer does not seem to excercise this bug.

Nick

comment:2 by Nick Hemsley, 15 years ago

Actually, *sigh*

It only happens reliably when I xcopy from the directory.

I will attach the minimum number of files that cause this problem. The following command causes problem:

xcopy /e files temp

by Nick Hemsley, 15 years ago

Attachment: files.zip added

Files which cause problem when copying using xcopy

comment:3 by sunlover, 15 years ago

Version: VirtualBox 2.0.2VirtualBox 2.0.4

Thanks for your detailed report and a good testcase. The problem has been reproduced. The attached driver fixes the crash here. Please test it and let me know whether it works for you.

comment:4 by Frank Mehnert, 15 years ago

Ticket #2323 has been marked as a duplicate of this one.

by sunlover, 15 years ago

Attachment: VBoxSF.sys added

Updated fix for xcopy /e Vista guest crash. For VBox 2.0.x.

comment:5 by sunlover, 15 years ago

Marked ticket #2337 as a duplicate of this one.

comment:6 by Frank Mehnert, 15 years ago

Resolution: fixed
Status: newclosed

Should be fixed in 2.0.6.

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use