VirtualBox

Ticket #2460 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

incorrect keyboard layout

Reported by: ebunda Owned by:
Priority: major Component: other
Version: VirtualBox 2.0.2 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

The Log states the following: 11:53:13.012 VirtualBox 2.0.2 r36488 linux.x86 (Sep 12 2008 18:50:37) release log 11:53:13.012 Log opened 2008-10-21T18:24:50.968736000Z 11:53:13.024 OS Product: Linux 11:53:13.024 OS Release: 2.6.22.5-31-default 11:53:13.024 OS Version: #1 SMP 2007/09/21 22:29:00 UTC 11:53:13.034 Your keyboard layout does not appear to fully supported by 11:53:13.034 VirtualBox. If you would like to help us improve the product, 11:53:13.034 please submit a bug report and attach this logfile. 11:53:13.034 11:53:13.034 The correct table for your layout is: 11:53:13.034 "\xba\xaa","1!","2\"","3\xb7","4$","5%","6&","7/","8(","9)","0=","'?","\xa1\xbf", 11:53:13.034 "qQ","wW","eE","rR","tT","yY","uU","iI","oO","pP","PR","+*", 11:53:13.034 "aA","sS","dD","fF","gG","hH","jJ","kK","lL","\xf1\xd1","QW","\xe7\xc7", 11:53:13.035 "zZ","xX","cC","vV","bB","nN","mM",",;",".:","-_","<>","\x0\x0","\x0\x0"

Keycodes such as Ctrl+Atl-Right arrow do not work in MSWord in a WinXP guest.

Change History

comment:1 Changed 5 years ago by michael

The message is probably just a bogus one due to a bug in 2.0.2 which is fixed for 2.0.4 (the layout looks like a standard Spanish one).

comment:2 Changed 5 years ago by ebunda

Confirmed this is fixed in 2.0.4.. And yes it is a standard Spanish keyboard.

comment:3 Changed 5 years ago by michael

What about the keycodes in MS-Word?

comment:4 Changed 5 years ago by ebunda

keycodes like I mentioned (Alt-Ctrl-Right arrow) in MS-Word and special Spanish characters also work fine throughout. It works like it should :)

comment:5 Changed 5 years ago by michael

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for reporting back. I will close this ticket.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use