VirtualBox

Ticket #2391 (closed defect: fixed)

Opened 6 years ago

Last modified 4 years ago

host networking unreliable

Reported by: hramrach Owned by:
Priority: major Component: network/hostif
Version: VirtualBox 2.0.2 Keywords:
Cc: Guest type: Linux
Host type: Mac OS X

Description

The host networking often breaks.

Usually the machine would boot and not get any ip address (pausing during the boot process) but restarting network later brings the network up.

In some cases the network just works or it does not work at all. I tried looking with tcpdump, and while the virtual machine tried to obtain the IP address I saw packets coming from the DHCP server. Also the DHCP server logs show the machine asking for address and the server sending offers. The virtual machine never sees the offers, though.

Attachments

vboxlog123.log Download (205.0 KB) - added by jurabonn 5 years ago.
VBox Log

Change History

comment:1 Changed 5 years ago by frank

  • Component changed from network to network/hostif

comment:2 Changed 5 years ago by jurabonn

Hi,

that is exactly(!) the same issue i encounter! I have already confirmed another bug, but no answer yet.

Host: Ubuntu 8.04 LTS 64bit Guest: Ubuntu Jeos 8.04 32bit

Some times it works, sometimes it doesn´t! The Guest can send packages (they are delivered), but it never receives any... Very annyoing when you use a guest with 3 NICs....

--- Possible workaround: Try "ifconfig eth(x) down; ip route flush cache; ifconfig eth(x) up" (x is supposed to be 1,2,3,whatever)

It might help sometimes. But it makes it look like beeing a routing problem

Changed 5 years ago by jurabonn

VBox Log

comment:3 Changed 5 years ago by jurabonn

Hi,

this is the result of a ping test I did on the following Setup:

Host: Ubuntu 8.04 LTS 64bit; 2.6.24-23-server; VBoxVersion: 2.1.4r42893 Guest: Ubuntu Jeos 8.04 32bit; 2.6.24-22-generic; VBoxGuestAddition installed

# NIC1, NIC2, NIC3 (S,R,N)


1 y y y S 2 y y y R 3 n n y R 4 n y y R 5 y y y S 5 y n y R 7 y y y R 8 y n n S 9 y n n S 10 y y n R 11 y y y R 12 y n n N 13 y y y N 14 y n y N 15 y y y N


# = Round NIC1,2,3 are in different subnets y,n = pinging from another (dedicated) maschine worked or not

S = Start from zero (VBoxHeadless -startvm ...) R = Reboot N = /etc/init.d/networking restart (inside the guest)


As you can see, there is no configuration change or anything else then rebooting or restarting.... It does randomly work or not work!!!!

comment:4 Changed 5 years ago by jurabonn

sorry, that was supposed to be a readable list... i will post that as a code block:

#   nic1  nic2  nic3  S,R,N
1    y     y     y      S 
2    y     y     y      R 
3    n     n     y      R 
4    n     y     y      R 
5    y     y     y      S 
5    y     n     y      R 
7    y     y     y      R 
8    y     n     n      S 
9    y     n     n      S 
10   y     y     n      R 
11   y     y     y      R 
12   y     n     n      N 
13   y     y     y      N 
14   y     n     y      N 
15   y     y     y      N 

comment:5 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

There was a related fix in VBox 3.0.6 or VBox 3.0.8 which probably affect your problem. Please reopen if this problem persists with VirtualBox 3.0.10.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use