VirtualBox

Ticket #2314 (closed defect: duplicate)

Opened 6 years ago

Last modified 6 years ago

excessive syslogging (pgmPoolTracDerefGCPhys) VM halts

Reported by: umeboshi Owned by:
Priority: major Component: VMM
Version: VirtualBox 1.6.6 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description (last modified by frank) (diff)

I've noticed that certain machines seem to freeze, and the syslog gets filled very quickly.

I have an AMD Turion 64 bit dual core cpu, but all of my OS's are running i386 (host and all guests). The OS's (or iso's, rather) that display this behavior are the ubuntu-8.04.1-desktop-i386.iso image and some of the recent daily builds of the debian-testing-netinst.iso images. I tried the daily build for 23Sept2008, and that one seems to be ok, but the problem exists in the 16Sept2008 version of the daily build. I'm letting you know this in case you need something to test with, and don't feel like getting the larger ubuntu image.

AFAICT, this problem only appears when VT is enabled. I really don't want to go back to disabling VT. Now that I'm used to it, going back makes things seem like they're moving at a snail's pace.

Also, why is it that I have to disable VT for all machines, when I only need to disable it for one? It seems that if each machine has an option for using VT, that each one should run according to that setting. I think that if VT has to be enabled/disabled for all machines, then the configuation option should stay with the global preferences, and not be a per machine option.

here is a snipped from /var/log/syslog:

Sep 23 16:31:07 bard kernel: [15242.263109] !!R0-Assertion Failed!!
Sep 23 16:31:07 bard kernel: [15242.263109] Expression: <NULL>
Sep 23 16:31:07 bard kernel: [15242.263109] 
Location  : /home/michael/technik/s\
ources/archive/pkg-virtualbox/build-area/virtualbox-ose-1.6.6-dfsg/src/VBox/VMM\
/VMMAll/PGMAllPool.cpp(2738) void pgmPoolTracDerefGCPhys(PGMPOOL*, 
PGMPOOLPAGE*\
, RTHCPHYS, RTGCPHYS)
Sep 23 16:31:07 bard kernel: [15242.263109]
Sep 23 16:31:07 bard kernel: [15242.263109] !!R0-Assertion Failed!!
Sep 23 16:31:07 bard kernel: [15242.263109] Expression: <NULL>
Sep 23 16:31:07 bard kernel: [15242.263109] 
Location  : /home/michael/technik/s\
ources/archive/pkg-virtualbox/build-area/virtualbox-ose-1.6.6-dfsg/src/VBox/VMM\
/VMMAll/PGMAllPool.cpp(2738) void pgmPoolTracDerefGCPhys(PGMPOOL*, 
PGMPOOLPAGE*\
, RTHCPHYS, RTGCPHYS)
Sep 23 16:31:07 bard kernel: [15242.263109]
Sep 23 16:31:07 bard kernel: [15242.263109] !!R0-Assertion Failed!!
Sep 23 16:31:07 bard kernel: [15242.263109] Expression: <NULL>
Sep 23 16:31:07 bard kernel: [15242.263109] 
Location  : /home/michael/technik/s\
ources/archive/pkg-virtualbox/build-area/virtualbox-ose-1.6.6-dfsg/src/VBox/VMM\
/VMMAll/PGMAllPool.cpp(2738) void pgmPoolTracDerefGCPhys(PGMPOOL*, 
PGMPOOLPAGE*\
, RTHCPHYS, RTGCPHYS)

I'm getting about 1900-2000 entries like this per second.

This problem doesn't occur consistenly every time the VM is booted, but it occurs probably about 75% of the time, in my experience. At least that's with the ubuntu VM. Running the netinst build from 16Sept2008 will freeze the VM and deluge the syslog every time.

Attachments

testmachine-2008-09-24-09-29-51.log Download (37.5 KB) - added by umeboshi 6 years ago.
log from running debian netinst iso from 16Sept2008
ubuntu-2008-09-24-09-36-59.log Download (33.9 KB) - added by umeboshi 6 years ago.
log from running ubuntu-8.04.1-desktop-i386.iso
syslog-tail Download (870 bytes) - added by umeboshi 6 years ago.
snippet of syslog entries

Change History

Changed 6 years ago by umeboshi

log from running debian netinst iso from 16Sept2008

Changed 6 years ago by umeboshi

log from running ubuntu-8.04.1-desktop-i386.iso

Changed 6 years ago by umeboshi

snippet of syslog entries

comment:1 Changed 6 years ago by umeboshi

Sorry about that cut-n-paste above on the syslog snippet. I used tail and attached a better snippet.

comment:2 Changed 6 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate
  • Component changed from other to VMM
  • Description modified (diff)
  • Summary changed from excessive syslogging - VM halts to excessive syslogging (pgmPoolTracDerefGCPhys) VM halts

Duplicate of #1881.

comment:3 Changed 6 years ago by frank

Joseph, please add a short comment to #1881 to be automatically get added to the cc list.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use